summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorax Redneck 34noff2019-05-11 17:57:47 +0300
committerax Redneck 34noff2019-05-11 17:57:47 +0300
commitc7a4b573fbbd315a51e775345a492408a33cd4c9 (patch)
tree3f3555929d3f3f3ee1ededa0dffd30c7b3d6969a
downloadaur-c7a4b573fbbd315a51e775345a492408a33cd4c9.tar.gz
3.49.15 (initial commit)
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..002992815724
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat May 11 14:56:04 UTC 2019
+pkgbase = mtpaint-wjaguar
+ pkgdesc = Simple paint program for creating icons and pixel based artwork (Dmitry Groshevs fork)
+ pkgver = 3.49.15
+ pkgrel = 1
+ url = https://github.com/wjaguar/mtPaint
+ arch = x86_64
+ license = GPL3
+ depends = gtk2
+ depends = giflib
+ depends = openjpeg
+ depends = lcms2
+ optdepends = gifsicle: for exporting GIF files from mtPaint
+ provides = mtpaint
+ conflicts = mtpaint
+ source = https://github.com/wjaguar/mtPaint/archive/91676e939e1198fa536a0cdefbcd9331c70efc4c.zip
+ sha256sums = 94cbb124219f11664639492114eb65185b6f0ffe04f505609f6784842e718554
+
+pkgname = mtpaint-wjaguar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89723e3f9a3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Alexey Trifonov <otaku [at] rambler dot ru>
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Roman Kyrylych <roman@archlinux.org>
+# Contributor: yosh64 <yosh64.at.gmail.dot.com>
+
+pkgname=mtpaint-wjaguar
+pkgver=3.49.15
+pkgrel=1
+_commit="91676e939e1198fa536a0cdefbcd9331c70efc4c"
+pkgdesc='Simple paint program for creating icons and pixel based artwork (Dmitry Groshev''s fork)'
+arch=('x86_64')
+url='https://github.com/wjaguar/mtPaint'
+license=('GPL3')
+depends=('gtk2' 'giflib' 'openjpeg' 'lcms2')
+optdepends=('gifsicle: for exporting GIF files from mtPaint')
+provides=('mtpaint')
+conflicts=('mtpaint')
+source=("https://github.com/wjaguar/mtPaint/archive/$_commit.zip")
+sha256sums=('94cbb124219f11664639492114eb65185b6f0ffe04f505609f6784842e718554')
+
+prepare() {
+ cd "mtPaint-$_commit"
+
+ # Recommended by Mark Tyler himself
+ sed -i 's:$LIBS $LDFLAGS:$LDFLAGS $LIBS:' configure
+}
+
+build() {
+ cd "mtPaint-$_commit"
+
+ export CFLAGS="-w `pkg-config libopenjpeg --cflags` $CFLAGS"
+ ./configure --prefix=/usr --mandir=/usr/share/man man intl GIF jpeg tiff cflags lcms2 jp2
+ make
+}
+
+package() {
+ make -C "mtPaint-$_commit" DESTDIR="$pkgdir" install
+}
+
+# vim:ts=2 sw=2 et: