summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2015-06-28 20:14:02 +0200
committerJaroslav Lichtblau2015-06-28 20:14:02 +0200
commit4bada9dcfea1246ae74375a81579f1ecd6bf9178 (patch)
treee0634293ed85bd15aaca8ec3d84110bfd2773407
parent5811dff00c8ef1f7d81e5fa682114685d81d81db (diff)
downloadaur-4bada9dcfea1246ae74375a81579f1ecd6bf9178.tar.gz
mu-0.9.12-1
-rw-r--r--PKGBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6899710eb9b..e8298ea9a0ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
-# Maintainer: megadriver <megadriver at gmx dot com>
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: megadriver <megadriver at gmx dot com>
# Contributor: Tom Willemsen <tom at ryuslash dot org>
# Contributor: Uwe <moc liamg skcuneelu <-- look what I did there>
# Contributor: Nicolas Pouillard <nicolas dot pouillard at gmail dot com>
# Contributor: Vain
pkgname=mu
-pkgver=0.9.11
+pkgver=0.9.12
pkgrel=1
pkgdesc="A collection of utilities for indexing and searching Maildirs"
arch=('i686' 'x86_64')
url="http://www.djcbsoftware.nl/code/mu"
-install=$pkgname.install
license=('GPL3')
depends=('xapian-core' 'gmime' 'sqlite3')
optdepends=('cronie: Updating index regularly')
conflicts=('mailutils')
-source=("https://github.com/djcb/mu/archive/v$pkgver.tar.gz")
-md5sums=('6b774454b181c9814992e7c9a24b9441')
+install=$pkgname.install
+source=($pkgname-$pkgver.tar.gz::https://github.com/djcb/mu/archive/v$pkgver.tar.gz)
+sha256sums=('b871124fc7774a2593815f89286671a8f31d7243bb898a8ca454685599f2b9af')
prepare() {
- cd $srcdir/mu-$pkgver
- cd toys/mug
+ cd "${srcdir}"/$pkgname-$pkgver/toys/mug
+
sed -i 's|MUGDIR|"/usr/share/pixmaps"|g' mug.c
}
build() {
- cd $srcdir/mu-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
+
# msg2pdf and mug will be built only if webkitgtk is installed
autoreconf --force --install
./configure --prefix=/usr
@@ -33,17 +35,18 @@ build() {
}
package() {
- cd $srcdir/mu-$pkgver
- make DESTDIR=$pkgdir install
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ make DESTDIR="${pkgdir}" install
# if msg2pdf and mug were built, install them
# if not, remove the unneeded mug manpage
if [ -f toys/msg2pdf/msg2pdf ]; then
- install -m755 toys/msg2pdf/msg2pdf $pkgdir/usr/bin/msg2pdf
+ install -m755 toys/msg2pdf/msg2pdf "${pkgdir}"/usr/bin/msg2pdf
fi
if [ -f toys/mug/mug ]; then
- install -m755 toys/mug/mug $pkgdir/usr/bin/mug
- install -Dm644 toys/mug/mug.svg $pkgdir/usr/share/pixmaps/mug.svg
+ install -m755 toys/mug/mug "${pkgdir}"/usr/bin/mug
+ install -Dm644 toys/mug/mug.svg "${pkgdir}"/usr/share/pixmaps/mug.svg
else
- rm $pkgdir/usr/share/man/man1/mug.1
+ rm "${pkgdir}"/usr/share/man/man1/mug.1
fi
}