summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2015-06-28 19:59:13 +0200
committerJaroslav Lichtblau2015-06-28 19:59:13 +0200
commit5811dff00c8ef1f7d81e5fa682114685d81d81db (patch)
tree0fc680035ff7888bd5d9945dad1a02186405d24b
downloadaur-5811dff00c8ef1f7d81e5fa682114685d81d81db.tar.gz
mu transfer to AUR4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
-rw-r--r--mu.install34
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c13661a394b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mu
+ pkgdesc = A collection of utilities for indexing and searching Maildirs
+ pkgver = 0.9.11
+ pkgrel = 1
+ url = http://www.djcbsoftware.nl/code/mu
+ install = mu.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = xapian-core
+ depends = gmime
+ depends = sqlite3
+ optdepends = cronie: Updating index regularly
+ conflicts = mailutils
+ source = https://github.com/djcb/mu/archive/v0.9.11.tar.gz
+ md5sums = 6b774454b181c9814992e7c9a24b9441
+
+pkgname = mu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6899710eb9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: megadriver <megadriver at gmx dot com>
+# Contributor: Tom Willemsen <tom at ryuslash dot org>
+# Contributor: Uwe <moc liamg skcuneelu <-- look what I did there>
+# Contributor: Nicolas Pouillard <nicolas dot pouillard at gmail dot com>
+# Contributor: Vain
+
+pkgname=mu
+pkgver=0.9.11
+pkgrel=1
+pkgdesc="A collection of utilities for indexing and searching Maildirs"
+arch=('i686' 'x86_64')
+url="http://www.djcbsoftware.nl/code/mu"
+install=$pkgname.install
+license=('GPL3')
+depends=('xapian-core' 'gmime' 'sqlite3')
+optdepends=('cronie: Updating index regularly')
+conflicts=('mailutils')
+source=("https://github.com/djcb/mu/archive/v$pkgver.tar.gz")
+md5sums=('6b774454b181c9814992e7c9a24b9441')
+
+prepare() {
+ cd $srcdir/mu-$pkgver
+ cd toys/mug
+ sed -i 's|MUGDIR|"/usr/share/pixmaps"|g' mug.c
+}
+
+build() {
+ cd $srcdir/mu-$pkgver
+ # msg2pdf and mug will be built only if webkitgtk is installed
+ autoreconf --force --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/mu-$pkgver
+ make DESTDIR=$pkgdir install
+ # if msg2pdf and mug were built, install them
+ # if not, remove the unneeded mug manpage
+ if [ -f toys/msg2pdf/msg2pdf ]; then
+ install -m755 toys/msg2pdf/msg2pdf $pkgdir/usr/bin/msg2pdf
+ fi
+ if [ -f toys/mug/mug ]; then
+ install -m755 toys/mug/mug $pkgdir/usr/bin/mug
+ install -Dm644 toys/mug/mug.svg $pkgdir/usr/share/pixmaps/mug.svg
+ else
+ rm $pkgdir/usr/share/man/man1/mug.1
+ fi
+}
diff --git a/mu.install b/mu.install
new file mode 100644
index 000000000000..0893726051c3
--- /dev/null
+++ b/mu.install
@@ -0,0 +1,34 @@
+# -*- mode: sh; -*-
+infodir=usr/share/info
+filelist=(mu-guile.info.gz mu4e.info.gz)
+
+install_info() {
+ [ -x usr/bin/install-info ] || return 0
+ if [ -f $infodir/mu-guile.info.gz ]; then install-info $infodir/mu-guile.info.gz $infodir/dir 2> /dev/null; fi
+ if [ -f $infodir/mu4e.info.gz ]; then install-info $infodir/mu4e.info.gz $infodir/dir 2> /dev/null; fi
+}
+
+post_install() {
+ install_info
+ echo ''
+ echo 'Set the default maildir: "export MAILDIR=~/YourMaildir"'
+ echo 'If MAILDIR is empty, mu will use ~/Mail by default'
+ echo 'You can also specify a maildir with the --maildir option'
+ echo ''
+ echo 'First run: "mu index" (it may take a while if you have lots of mail)'
+ echo 'Sample cron entry: "0 12 * * * mu index" (add the --maildir option if needed)'
+ echo ''
+}
+
+post_upgrade() {
+ install_info
+ echo ''
+ echo 'You might need to execute "mu index --rebuild" after the upgrade'
+ echo ''
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ if [ -f $infodir/mu-guile.info.gz ]; then install-info --delete $infodir/mu-guile.info.gz $infodir/dir 2> /dev/null; fi
+ if [ -f $infodir/mu4e.info.gz ]; then install-info --delete $infodir/mu4e.info.gz $infodir/dir 2> /dev/null; fi
+}