summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-10-08 18:41:44 +0200
committerChristopher Arndt2020-10-08 18:41:44 +0200
commitdf9f73b7e3af97cafc87f2dce09610b549b4cefa (patch)
treec44fc54c2badaa88a5476d80d07b087f994f5b63
parentee1e03c3463c420582893f7521c9640ba6304dd9 (diff)
downloadaur-df9f73b7e3af97cafc87f2dce09610b549b4cefa.tar.gz
Update depends due to dependency packag rename
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c2435ffe165..c4d8361c7348 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = mu-editor
pkgdesc = A simple Python editor for beginner programmers
pkgver = 1.0.3
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://codewith.mu/
arch = any
license = GPL3
makedepends = gendesk
makedepends = python-setuptools
+ depends = pigpio
depends = python-appdirs
depends = python-gpiozero
depends = python-guizero
depends = python-matplotlib
depends = python-nudatus
- depends = python-pigpio
depends = python-pgzero
depends = python-pycodestyle
depends = python-pyflakes
diff --git a/.gitignore b/.gitignore
index 0a99f3ae8cb6..1336582a4f66 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,5 @@ src/
pkg/
mu-editor-*.tar.gz
mu-editor-*.pkg.tar.xz
+mu-editor-*.pkg.tar.zst
.AURINFO
-
diff --git a/PKGBUILD b/PKGBUILD
index 049dad726905..d5d32d65ef8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,15 @@
pkgname=mu-editor
epoch=1
pkgver=1.0.3
-pkgrel=1
+pkgrel=2
pkgdesc='A simple Python editor for beginner programmers'
arch=('any')
url='https://codewith.mu/'
license=('GPL3')
-depends=('python-appdirs' 'python-gpiozero' 'python-guizero' 'python-matplotlib' 'python-nudatus'
- 'python-pigpio' 'python-pgzero' 'python-pycodestyle' 'python-pyflakes'
- 'python-pyqtchart>=5.11.3' 'python-pyserial' 'python-qscintilla-qt5' 'python-qtconsole'
+depends=('pigpio' 'python-appdirs' 'python-gpiozero' 'python-guizero'
+ 'python-matplotlib' 'python-nudatus' 'python-pgzero'
+ 'python-pycodestyle' 'python-pyflakes' 'python-pyqtchart>=5.11.3'
+ 'python-pyserial' 'python-qscintilla-qt5' 'python-qtconsole'
'python-requests' 'python-semver' 'qt5-serialport')
makedepends=('gendesk' 'python-setuptools')
source=("$pkgname-$pkgver.tar.gz::https://github.com/mu-editor/mu/archive/$pkgver.tar.gz"