summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-01-15 22:00:38 +0100
committerChristopher Arndt2019-01-15 22:00:38 +0100
commitf29ce894d71755a3acddd97603de790731524086 (patch)
tree333c0f2aa69533ac3ae5facdda94424d7e4ed1e7
parent0abca6f3405657a0da59d0bc0fe8a417e9052dd3 (diff)
downloadaur-f29ce894d71755a3acddd97603de790731524086.tar.gz
New upstream version; updated patch
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--webbrowser-issue31014.diff8
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c23215d0bbd..cae78b86df90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mu-editor
pkgdesc = A simple Python editor for beginner programmers
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
epoch = 1
url = https://codewith.mu/
@@ -17,17 +17,17 @@ pkgbase = mu-editor
depends = python-pgzero
depends = python-pycodestyle
depends = python-pyflakes
- depends = python-pyqtchart
+ depends = python-pyqtchart>=5.11.3
depends = python-pyserial
depends = python-qscintilla-qt5
depends = python-qtconsole
depends = python-requests
depends = python-semver
depends = qt5-serialport
- source = mu-editor-1.0.1.tar.gz::https://github.com/mu-editor/mu/archive/1.0.1.tar.gz
+ source = mu-editor-1.0.2.tar.gz::https://github.com/mu-editor/mu/archive/1.0.2.tar.gz
source = webbrowser-issue31014.diff
- sha256sums = 41abc6415ba8c51d62ad6e465dbefec4b0382d586c60d602ebb3d9e373fc5710
- sha256sums = ee2b9210ddb25ccc29ff857e450646d7b3cd7336a8532de29c76cd2176cc980e
+ sha256sums = 77f59e2697c30393dc0ae460994ccde150f69174dc8c3603887c54be068f6516
+ sha256sums = 6f2ebf536883ae182ec6a8118b049d7ff039b23d55f846eb7541a2ff0ae1849f
pkgname = mu-editor
diff --git a/PKGBUILD b/PKGBUILD
index 0c4e5e2f4e81..b839f629394c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,21 @@
pkgname=mu-editor
epoch=1
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc='A simple Python editor for beginner programmers'
arch=('any')
url='https://codewith.mu/'
license=('GPL3')
depends=('python-appdirs' 'python-gpiozero' 'python-guizero' 'python-matplotlib' 'python-nudatus'
- 'python-pigpio' 'python-pgzero' 'python-pycodestyle' 'python-pyflakes' 'python-pyqtchart'
- 'python-pyserial' 'python-qscintilla-qt5' 'python-qtconsole' 'python-requests'
- 'python-semver' 'qt5-serialport')
+ 'python-pigpio' 'python-pgzero' 'python-pycodestyle' 'python-pyflakes'
+ 'python-pyqtchart>=5.11.3' 'python-pyserial' 'python-qscintilla-qt5' 'python-qtconsole'
+ 'python-requests' 'python-semver' 'qt5-serialport')
makedepends=('gendesk' 'python-setuptools')
source=("$pkgname-$pkgver.tar.gz::https://github.com/mu-editor/mu/archive/$pkgver.tar.gz"
'webbrowser-issue31014.diff')
-sha256sums=('41abc6415ba8c51d62ad6e465dbefec4b0382d586c60d602ebb3d9e373fc5710'
- 'ee2b9210ddb25ccc29ff857e450646d7b3cd7336a8532de29c76cd2176cc980e')
+sha256sums=('77f59e2697c30393dc0ae460994ccde150f69174dc8c3603887c54be068f6516'
+ '6f2ebf536883ae182ec6a8118b049d7ff039b23d55f846eb7541a2ff0ae1849f')
prepare() {
diff --git a/webbrowser-issue31014.diff b/webbrowser-issue31014.diff
index 5f1264349509..439742c6ae18 100644
--- a/webbrowser-issue31014.diff
+++ b/webbrowser-issue31014.diff
@@ -1,8 +1,8 @@
diff --git a/mu/logic.py b/mu/logic.py
-index be7c7e7..0607676 100644
+index ebd9cd2..3625d7c 100644
--- a/mu/logic.py
+++ b/mu/logic.py
-@@ -977,6 +977,21 @@ class Editor:
+@@ -1006,6 +1006,21 @@ class Editor:
else:
self._view.reset_annotations()
@@ -24,10 +24,10 @@ index be7c7e7..0607676 100644
def show_help(self):
"""
Display browser based help about Mu.
-@@ -990,7 +1005,7 @@ class Editor:
- major_version = '.'.join(__version__.split('.')[:2])
+@@ -1015,7 +1030,7 @@ class Editor:
url = 'https://codewith.mu/{}/help/{}'.format(language_code,
major_version)
+ logger.info('Showing help at %r.', url)
- webbrowser.open_new(url)
+ self._open_webbrowser(url)