summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Random2019-07-23 17:30:37 +0200
committerJack Random2019-07-23 17:30:37 +0200
commit0ba2051583445167d0b881b299992f0782810bec (patch)
treedeb5e8e43cfa397a20377fad3a9d4af31f95fd6e
parent3f9f35f53084f3940ed73cd4a09bfee79f0b9032 (diff)
downloadaur-0ba2051583445167d0b881b299992f0782810bec.tar.gz
Fix compilation [1, 2] | minor updates
[1] https://github.com/djcb/mu/issues/1452 [2] https://groups.google.com/forum/#!topic/mu-discuss/iosQX8C5wzI
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbffe9290e85..5d310dc2ef31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mu-git
pkgdesc = mu and mu4e from git
- pkgver = 1.0.158.g508d3d4a
+ pkgver = 1.3.3.1.gb7cda29b
pkgrel = 1
url = http://www.djcbsoftware.nl/code/mu
arch = i686
@@ -10,7 +10,6 @@ pkgbase = mu-git
depends = xapian-core
depends = guile
depends = gmime3
- depends = json-glib
optdepends = emacs: mu4e support
provides = mu
conflicts = mu
diff --git a/PKGBUILD b/PKGBUILD
index 596ed8afb429..16833eb9f5af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
# Thanks to the maintainers and contributors of the mu binary package
pkgname=mu-git
-pkgver=1.0.158.g508d3d4a
+pkgver=1.3.3.1.gb7cda29b
pkgrel=1
pkgdesc="mu and mu4e from git"
arch=('i686' 'x86_64')
url="http://www.djcbsoftware.nl/code/mu"
-depends=('xapian-core' 'guile' 'gmime3' 'json-glib')
+depends=('xapian-core' 'guile' 'gmime3')
makedepends=('git')
optdepends=('emacs: mu4e support')
license=('GPL')
@@ -19,14 +19,17 @@ md5sums=('SKIP')
pkgver() {
cd mu
- printf "%s" "$(git describe --tags|tr - .|cut -c2-)"
+ printf "%s" "$(git describe --tags | tr - .)"
+}
+
+prepare() {
+ cd mu
+ ./autogen.sh
}
build() {
cd mu
- autoreconf -i
- sed -i 's|MUGDIR|"/usr/share/pixmaps"|' toys/mug/mug.c
- ./configure --prefix=/usr --disable-webkit --disable-gtk --enable-mu4e
+ ./configure --prefix=/usr --disable-webkit --disable-gtk --enable-mu4e --enable-guile --enable-shared
}
package() {