summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuu2020-08-01 03:20:29 -0300
committeryuu2020-08-01 03:20:29 -0300
commitc58e52efa6669f25bcd55d1603be2e2f3505389f (patch)
treec5ee24273551433526919a20bdb6474f5b241758
downloadaur-c58e52efa6669f25bcd55d1603be2e2f3505389f.tar.gz
Initial commit: add 'PKGBUILD', 'mu-wizard.install', '.SRCINFO'
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--mu-wizard.install29
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e579bf088b9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mu-wizard-git
+ pkgdesc = Shell script to easily setup mu4e on Emacs
+ pkgver = 0.r4.g97b6519
+ pkgrel = 1
+ url = https://github.com/cemkeylan/mu-wizard
+ install = mu-wizard.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = isync
+ depends = msmtp
+ depends = mu
+ depends = pass
+ optdepends = pash: alternative password manager
+ optdepends = pm: alternative password manager
+ provides = mu-wizard
+ conflicts = mu-wizard
+ source = git+https://github.com/cemkeylan/mu-wizard
+ md5sums = SKIP
+
+pkgname = mu-wizard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a964a7ae7f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer : Yuu $(echo \<yuu-tutamail+com\>|sed s/\+/./g\;s/\-/@/)
+# Upstream author : Cem Keylan <https://github.com/cemkeylan>
+
+pkgname=mu-wizard-git
+pkgver=0.r4.g97b6519
+pkgrel=1
+pkgdesc="Shell script to easily setup mu4e on Emacs"
+arch=('any')
+url=https://github.com/cemkeylan/mu-wizard
+license=('GPL3')
+depends=('isync' 'msmtp' 'mu' 'pass')
+makedepends=('git')
+optdepends=('pash: alternative password manager'
+ 'pm: alternative password manager')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install="${pkgname%-git}.install"
+source=("git+$url")
+md5sums=('SKIP')
+
+# Git, no tags available.
+# Use number of revisions since beginning of the history.
+pkgver() {
+ cd "${pkgname%-git}"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}/"
+}
diff --git a/mu-wizard.install b/mu-wizard.install
new file mode 100644
index 000000000000..a64cd23b9ace
--- /dev/null
+++ b/mu-wizard.install
@@ -0,0 +1,29 @@
+post_install() {
+ echo -e "\n\e[1m Cem Keylan’s mu-wizard $1\e[0m\n"
+ cat <<-EOF
+ Configuration
+ -------------
+ Emacs will not be loading the configurations, you will need to set it
+ manually. In your init file, you may choose to load the configuration in the
+ following ways.
+ - (load-file "~/.config/mu4e/mu4e-config.el")
+ - (add-to-list 'load-path "~/.config/mu4e")
+ (require 'mu4e-config)
+ - (use-package mu4e-config
+ :after mu4e
+ :load-path "~/.config/mu4e")
+
+ ’domains.csv’ file
+ ------------------
+ mu-wizard doesn't come with a predefined ’domains.csv’ file, but it can use
+ one if it is found on ’/usr/share/mu-wizard/domains.csv’. mu-wizard also
+ saves the domain information that you use when creating an account on your
+ configuration directory, so you don't have to retype every detail when
+ creating a second account with the same domain.
+
+ External links
+ --------------
+ - Official repository on GitHub: https://github.com/cemkeylan/mu-wizard
+
+EOF
+}