summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXabre2019-03-12 11:16:56 +0100
committerXabre2019-03-12 11:16:56 +0100
commit10626d4a91d0ebdebaa2b3b96c5d992e5373516f (patch)
tree6ab134216ae26bc58f5372a40e0982fce1707c6b
parentb87746d32dbaea26f8085936c8ba43f8700f3306 (diff)
downloadaur-10626d4a91d0ebdebaa2b3b96c5d992e5373516f.tar.gz
Fix missing include
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71745f68eacb..8d5145b6e0f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mudlet
pkgdesc = A modern MUD client with a graphical user inteface and built in Lua scripting
pkgver = 3.17.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.mudlet.org
arch = i686
arch = x86_64
@@ -27,7 +27,7 @@ pkgbase = mudlet
conflicts = mudlet-dev
conflicts = mudlet-git
conflicts = mudlet-deb
- source = http://www.mudlet.org/download/Mudlet-3.17.1.tar.xz
+ source = https://www.mudlet.org/wp-content/files/Mudlet-3.17.1.tar.xz
sha256sums = 383949ba397fcf55cd6dcd72b485fa4e8c44b9c7721f2df3c7c32a3242787ce4
pkgname = mudlet
diff --git a/PKGBUILD b/PKGBUILD
index 7cd3ec437fee..9a6d47355698 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Xabre <xabre @archlinux.info>
pkgname=mudlet
pkgver=3.17.1
-pkgrel=1
+pkgrel=2
pkgdesc="A modern MUD client with a graphical user inteface and built in Lua scripting"
arch=('i686' 'x86_64')
url="http://www.mudlet.org"
@@ -16,15 +16,16 @@ depends=('qt5-base' 'qt5-multimedia' 'hunspell' 'libzip' 'glu' 'lua51' \
'qt5-gamepad' 'lua51-utf8' 'lua51-lcf' 'ttf-font' 'pugixml' 'lua-yajl')
makedepends=('boost' 'qt5-tools')
conflicts=('mudlet-dev' 'mudlet-git' 'mudlet-deb')
-source=("http://www.mudlet.org/download/Mudlet-${pkgver}.tar.xz")
+#source=("http://www.mudlet.org/download/Mudlet-${pkgver}.tar.xz")
##using alternate link
-##source=("https://www.mudlet.org/wp-content/files/Mudlet-${pkgver}.tar.xz")
+source=("https://www.mudlet.org/wp-content/files/Mudlet-${pkgver}.tar.xz")
sha256sums=('383949ba397fcf55cd6dcd72b485fa4e8c44b9c7721f2df3c7c32a3242787ce4')
prepare() {
cd "$srcdir/src"
sed -i 's,QString path = "../src/mudlet-lua/lua/LuaGlobal.lua";,QString path = "/usr/share/mudlet/lua/LuaGlobal.lua";,' TLuaInterpreter.cpp
sed -i 's;"mudlet.app/Contents/Resources/mudlet-lua/lua/";"mudlet.app/Contents/Resources/mudlet-lua/lua/", "/usr/share/mudlet/lua/";' mudlet-lua/lua/LuaGlobal.lua
+ sed -i '31 a #include <QToolButton>' discord.h
}
build() {