summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2018-07-15 19:35:36 +0200
committerJaroslav Lichtblau2018-07-15 19:35:36 +0200
commitbe729f73d155b5743ff7f5c37d44c3ab0288b35a (patch)
tree2c7cf38d6a58684c8eadd0173cecf373bc69991a
parent2f1cee006195946ddee41cdbf3fd5640bec7fa13 (diff)
downloadaur-mudmagic.tar.gz
mudmagic PKGBUILD update to current standards
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91efc4392c97..e2b244cdb84d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,11 @@
+# Generated by mksrcinfo v8
+# Sun Jul 15 17:35:33 UTC 2018
pkgbase = mudmagic
pkgdesc = A GTK2 mud client with automapper
pkgver = 1.9
pkgrel = 4
url = http://www.mudmagic.com/mud-client/
- arch = i686
+ arch = x86_64
license = GPL
makedepends = pkgconfig
depends = libglade>=2
@@ -12,7 +14,7 @@ pkgbase = mudmagic
depends = sqlite3
options = !libtool
source = http://downloads.sourceforge.net/kyndig/mudmagic-1.9.tar.gz
- md5sums = 25d106683edaf8241700aea22de27e83
+ sha256sums = bfb40914c88ce024c9e641890bdb83c60965303f4b8098d9986026014392f94a
pkgname = mudmagic
diff --git a/PKGBUILD b/PKGBUILD
index 496362e50662..1d4ff09a98ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,24 @@ pkgname=mudmagic
pkgver=1.9
pkgrel=4
pkgdesc="A GTK2 mud client with automapper"
-arch=('i686')
+arch=('x86_64')
url="http://www.mudmagic.com/mud-client/"
license=('GPL')
depends=('libglade>=2' 'libmxp' 'pcre' 'sqlite3')
makedepends=('pkgconfig')
options=('!libtool')
source=(http://downloads.sourceforge.net/kyndig/$pkgname-$pkgver.tar.gz)
-md5sums=('25d106683edaf8241700aea22de27e83')
+sha256sums=('bfb40914c88ce024c9e641890bdb83c60965303f4b8098d9986026014392f94a')
build() {
- cd ${srcdir}/$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
./configure --prefix=/usr --disable-static --mandir=/usr/share/man
- make || return 1
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
make DESTDIR=${pkgdir} install
}