summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2016-02-08 10:00:56 -0800
committerAnatol Pomozov2016-02-08 10:01:24 -0800
commit95c8a61fed79c02282bf3b3401fb7fd3620b43a8 (patch)
tree5bdfb29fbea7e8c99a1c840b2051cf5ec921f525
parentf878483f55ff229be7721e178cb9cd7bd0771e86 (diff)
downloadaur-95c8a61fed79c02282bf3b3401fb7fd3620b43a8.tar.gz
Comple fixes from @condy
Compilation failed because of the unused variables. I make a simple workaround, just remove the `-Werror' flag. Another typo is `Release'.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3484d9fd0fa..563c6140de1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Feb 8 18:01:22 UTC 2016
pkgbase = muduo
pkgdesc = A C++ non-blocking multi-threaded network library
pkgver = 1.0.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/chenshuo/muduo
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 489db1031343..544a692c5416 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=muduo
pkgver=1.0.7
-pkgrel=1
+pkgrel=2
pkgdesc='A C++ non-blocking multi-threaded network library'
url='https://github.com/chenshuo/muduo'
license=(BSD)
@@ -15,10 +15,11 @@ sha1sums=('b37881ba54a59d1847560aa2b1bdcd2e8250a35c')
build() {
cd muduo-$pkgver
+ sed -i '/-Werror/d' CMakeLists.txt
BUILD_NO_EXAMPLES=1 INSTALL_DIR=/usr ./build.sh
}
package() {
- cd build/Release
+ cd build/release
make install DESTDIR="$pkgdir"
}