summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRealex-fire2015-06-08 23:04:21 +0700
committerRealex-fire2015-06-08 23:04:21 +0700
commitd03972a9333a5f13b2428c9d4eb104081b9f3abb (patch)
tree2f187505a387f07a54a98202bb1cee173c2658eb
downloadaur-d03972a9333a5f13b2428c9d4eb104081b9f3abb.tar.gz
Initial import
-rw-r--r--.AURINFO27
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD39
-rw-r--r--muffin-git.install10
4 files changed, 104 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..27b98ffd239f
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,27 @@
+pkgbase = muffin-git
+ pkgdesc = A window manager for GNOME
+ pkgver = 527.d9f4fcd
+ pkgrel = 1
+ url = https://github.com/linuxmint/muffin
+ install = muffin-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = gnome-doc-utils
+ makedepends = gnome-common
+ makedepends = git
+ depends = clutter
+ depends = gobject-introspection
+ depends = cinnamon-desktop-git
+ depends = libcanberra
+ depends = startup-notification
+ depends = zenity
+ depends = dconf
+ provides = muffin
+ conflicts = muffin
+ source = git+https://github.com/linuxmint/muffin.git
+ options = !emptydirs
+
+pkgname = muffin-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48f89a870b53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = muffin-git
+ pkgdesc = A window manager for GNOME
+ pkgver = 527.d9f4fcd
+ pkgrel = 1
+ url = https://github.com/linuxmint/muffin
+ install = muffin-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = gnome-doc-utils
+ makedepends = gnome-common
+ makedepends = git
+ depends = clutter
+ depends = gobject-introspection
+ depends = cinnamon-desktop-git
+ depends = libcanberra
+ depends = startup-notification
+ depends = zenity
+ depends = dconf
+ provides = muffin
+ conflicts = muffin
+ options = !emptydirs
+ source = git+https://github.com/linuxmint/muffin.git
+ sha512sums = SKIP
+
+pkgname = muffin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f50517947747
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Realex
+# Based on muffin PKGBUILD
+
+_pkgname=muffin
+pkgname=${_pkgname}-git
+pkgver=527.d9f4fcd
+pkgrel=1
+pkgdesc="A window manager for GNOME"
+arch=('i686' 'x86_64')
+url="https://github.com/linuxmint/muffin"
+license=('GPL')
+depends=('clutter' 'gobject-introspection' 'cinnamon-desktop-git' 'libcanberra'
+ 'startup-notification' 'zenity' 'dconf')
+makedepends=('intltool' 'gnome-doc-utils' 'gnome-common' 'git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+options=('!emptydirs')
+install=${pkgname}.install
+source=("git+https://github.com/linuxmint/${_pkgname}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ PYTHON=python2 ./autogen.sh --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/muffin \
+ --localstatedir=/var --disable-static --disable-schemas-compile \
+ --enable-compile-warnings=minimum
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/muffin-git.install b/muffin-git.install
new file mode 100644
index 000000000000..2daef58d5574
--- /dev/null
+++ b/muffin-git.install
@@ -0,0 +1,10 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ post_install
+}