summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2022-05-24 20:21:16 +0800
committerYour Name2022-05-24 20:21:16 +0800
commitbb3116f486930f8bbf7bb35d44f9e1a8a090ec61 (patch)
tree35f4df23db8a80a56ff7c6b6a367bfe64f5e89df
parentd0e38582a3456bafb052aaf407086aa0c3e188de (diff)
downloadaur-bb3116f486930f8bbf7bb35d44f9e1a8a090ec61.tar.gz
Update 2.2.0-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f89881683e0..2b5111fc50dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mujoco
pkgdesc = Multi-Joint dynamics with Contact. A general purpose physics simulator.
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.mujoco.org
arch = x86_64
license = Apache
@@ -17,7 +17,7 @@ pkgbase = mujoco
depends = tinyobjloader
source = https://github.com/deepmind/mujoco/archive/refs/tags/2.2.0.tar.gz
source = mujoco.patch
- sha256sums = 5bd3847aca1f53e2467b680f797fe74ce6a1c20870e0fee534cfda38a25ea1d5
+ sha256sums = 98cab2735817456c028e96ba34b2ee2c94cc4fab33ebcae15ab46fcc45a762ad
sha256sums = fa5799290dd68bd2bdd520515484112c3a72079af6425ee6d01b6865e81bdab1
pkgname = mujoco
diff --git a/PKGBUILD b/PKGBUILD
index d3467f929358..f07d2cf3b1d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mujoco
pkgver=2.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Multi-Joint dynamics with Contact. A general purpose physics simulator."
arch=('x86_64')
url="https://www.mujoco.org"
@@ -9,7 +9,7 @@ depends=('libgl' 'glfw' 'tinyxml2' 'tinyobjloader')
makedepends=('libccd' 'abseil-cpp' 'gtest' 'benchmark' 'cmake' 'git')
source=("https://github.com/deepmind/mujoco/archive/refs/tags/$pkgver.tar.gz"
"${pkgname}.patch")
-sha256sums=('5bd3847aca1f53e2467b680f797fe74ce6a1c20870e0fee534cfda38a25ea1d5'
+sha256sums=('98cab2735817456c028e96ba34b2ee2c94cc4fab33ebcae15ab46fcc45a762ad'
'fa5799290dd68bd2bdd520515484112c3a72079af6425ee6d01b6865e81bdab1')
prepare() {
@@ -35,7 +35,7 @@ package() {
rmdir $pkgdir/usr/local
mkdir $pkgdir/usr/lib/mujoco
mv $pkgdir/usr/bin/* $pkgdir/usr/lib/mujoco/
- rmdir $pkgdir/usr/bin
- mkdir $pkgdir/usr/include/mujoco
- mv $pkgdir/usr/include/*.h $pkgdir/usr/include/mujoco/
+ for _file in $pkgdir/usr/lib/mujoco/*; do
+ ln -s $_file $pkgdir/usr/bin/mujoco-$(basename $_file)
+ done
}