summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Boyle2022-08-01 11:24:37 +0100
committerJonathan Boyle2022-08-01 11:24:37 +0100
commit746089a72789e6c3e297e9a1677993fa4d0ac35e (patch)
treeb1e6a14199c6fc2fb806a7ea690117ed6327d745
parent147866a55ce153117659047429eedd4d880787a5 (diff)
downloadaur-746089a72789e6c3e297e9a1677993fa4d0ac35e.tar.gz
Updated Version 1.1.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--RELEASENOTES.md27
3 files changed, 34 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 727a0cafd860..5a3c2709da80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mulle-make
pkgdesc = Build projects with tools like cmake, meson, autoconf
- pkgver = 0.16.0
+ pkgver = 1.1.1
pkgrel = 1
epoch = 1
url = https://github.com/mulle-sde/mulle-make
@@ -9,8 +9,8 @@ pkgbase = mulle-make
groups = mulle-sde-all
license = BSD3
depends = bash
- depends = mulle-bashfunctions>=3.4.0
- source = https://github.com/mulle-sde/mulle-make/archive/0.16.0.tar.gz
- md5sums = 05d09aa487f8a992b786077e0091ab86
+ depends = mulle-bashfunctions>=4.1.1
+ source = https://github.com/mulle-sde/mulle-make/archive/1.1.1.tar.gz
+ md5sums = afc2c578d2baa2fc4cd445270ccdfc61
pkgname = mulle-make
diff --git a/PKGBUILD b/PKGBUILD
index 03d8fdc19691..83e0f12d96d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonathan Boyle <programmerfalcon@gmail.com>
pkgname=mulle-make
-pkgver=0.16.0
+pkgver=1.1.1
pkgrel=1
epoch=1
pkgdesc="Build projects with tools like cmake, meson, autoconf"
@@ -8,11 +8,11 @@ arch=('any')
url="https://github.com/mulle-sde/mulle-make"
license=('BSD3')
groups=('mulle-sde-all')
-depends=('bash' 'mulle-bashfunctions>=3.4.0')
+depends=('bash' 'mulle-bashfunctions>=4.1.1')
changelog="RELEASENOTES.md"
-source=("https://github.com/mulle-sde/mulle-make/archive/0.16.0.tar.gz")
+source=("https://github.com/mulle-sde/mulle-make/archive/1.1.1.tar.gz")
noextract=()
-md5sums=('05d09aa487f8a992b786077e0091ab86')
+md5sums=('afc2c578d2baa2fc4cd445270ccdfc61')
validpgpkeys=()
package() {
diff --git a/RELEASENOTES.md b/RELEASENOTES.md
index e72feb86622e..08f6a3cc4d10 100644
--- a/RELEASENOTES.md
+++ b/RELEASENOTES.md
@@ -1,3 +1,28 @@
+### 1.1.1
+
+* * fix command -v being used with mudo
+
+## 1.1.0
+
+* add build --analyze flag for scan-build/mulle-scan-build
+* some fixes for Windows
+
+
+# 1.0.0
+
+* big function rename to `<tool>`::`<file>`::`<function>` to make it easier to read hopefully
+* enables an 'aux' definition directory, to support share/etc style definition placements
+* mulle-make will no longer clobber an existing build directory, that it hasn't created itself
+* the autoconf plugin now looks to a bootstrap script in addition to autogen.sh, still prefering autogen.sh though
+* definition **remove** is now definition **unset**. That was necessary because a remove may reestablish a default value, where as an unset really NULLs the value so to speak
+* experimental support to build Makefile projects
+* recognizes and forwards the ``OTHER_CFLAGS`` (as well as CPP, CXX, LD) environment variables
+* ninja will not be used by default, unless the version is >= 1.11 (which is not released yet)
+* runs with zsh if bash is not installed
+* if there are no headers to install, ninja install will be skipped in the cmake Headers phase, which circumvents a useless error
+* mulle-make uses mulle-bashfunctions 4 now
+
+
## 0.16.0
* Various small improvements
@@ -281,7 +306,7 @@
### 0.3.3
-* unify mulle-bashfunctions-env usage
+* unify mulle-bashfunctions usage
### 0.3.2