summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Boyle2021-02-13 23:58:01 +0000
committerJonathan Boyle2021-02-13 23:58:01 +0000
commit1d27244db6c082bbdb8aa8258842f319177fd0fe (patch)
treeb12a012b929a3d27154038c706d0a36e4a3c19fe
downloadaur-1d27244db6c082bbdb8aa8258842f319177fd0fe.tar.gz
Initial Commit of Version 0.4.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--RELEASENOTES.md48
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..936859d3d625
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mulle-platform
+ pkgdesc = Query platform specifica and search for libraries
+ pkgver = 0.4.2
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/mulle-sde/mulle-platform
+ changelog = RELEASENOTES.md
+ arch = any
+ groups = mulle-sde-all
+ license = BSD3
+ depends = bash
+ depends = mulle-bashfunctions>=3.3.0
+ source = https://github.com/mulle-sde/mulle-platform/archive/0.4.2.tar.gz
+ md5sums = 88a5fda939aa70f6dc39abc62c3ea747
+
+pkgname = mulle-platform
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a63d5b0149a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jonathan Boyle <programmerfalcon@gmail.com>
+pkgname=mulle-platform
+pkgver=0.4.2
+pkgrel=1
+epoch=1
+pkgdesc="Query platform specifica and search for libraries"
+arch=('any')
+url="https://github.com/mulle-sde/mulle-platform"
+license=('BSD3')
+groups=('mulle-sde-all')
+depends=('bash' 'mulle-bashfunctions>=3.3.0')
+changelog="RELEASENOTES.md"
+source=("https://github.com/mulle-sde/mulle-platform/archive/0.4.2.tar.gz")
+noextract=()
+md5sums=('88a5fda939aa70f6dc39abc62c3ea747')
+validpgpkeys=()
+
+package() {
+ # Install License
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Run Install
+ cd bin
+ chmod +x installer
+ ./installer "${pkgdir}/usr"
+
+ # Move libexec to lib/$pkgname
+ cd "${pkgdir}/usr"
+ mkdir -p "lib/${pkgname}"
+ mv libexec/* "lib/${pkgname}"
+ rm -r libexec
+}
diff --git a/RELEASENOTES.md b/RELEASENOTES.md
new file mode 100644
index 000000000000..5114aecaba9b
--- /dev/null
+++ b/RELEASENOTES.md
@@ -0,0 +1,48 @@
+### 0.4.2
+
+* Various small improvements
+
+### 0.4.1
+
+* improve searchpath and includepath
+
+## 0.4.0
+
+* new command includepath for header search paths
+
+
+## 0.3.0
+
+* add searchpath command
+* improved the search command, the default is no longer wholearchive though
+* improved output of linker flags
+
+
+## 0.2.0
+
+* changed to mulle-bashfunctions 2 call convention
+* moved to mulle-bashfunctions v2
+
+
+## 0.1.0
+
+* add wholearchive commmand
+* fix emitted code for unmarked libraries
+* small beauty fixes in logging and code
+
+
+### 0.0.4
+
+* add whole-archive-as-needed for gcc
+
+### 0.0.3
+
+* improve whole-archive output
+
+### 0.0.2
+
+* fix libexec not being found
+
+# 0.0.0
+
+* Various small improvements