summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Boyle2022-08-01 11:25:44 +0100
committerJonathan Boyle2022-08-01 11:25:44 +0100
commit8827110d127fe3259f37704eff24b66b5399ee10 (patch)
treebb46e7fc01cbaec4871750a78284b1bfeb270dc4
parent8ee62d49d4d015b6886395f23550bfb1fb0ad0b4 (diff)
downloadaur-8827110d127fe3259f37704eff24b66b5399ee10.tar.gz
Updated Version 1.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
-rw-r--r--RELEASENOTES.md24
3 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d31c8735ae5..e49f1df6b08c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mulle-sourcetree
pkgdesc = Project composition and maintenance with build support
- pkgver = 0.25.0
+ pkgver = 1.1.0
pkgrel = 1
epoch = 1
url = https://github.com/mulle-sde/mulle-sourcetree
@@ -9,8 +9,9 @@ pkgbase = mulle-sourcetree
groups = mulle-sde-all
license = BSD3
depends = bash
- depends = mulle-bashfunctions>=3.4.0
- source = https://github.com/mulle-sde/mulle-sourcetree/archive/0.25.0.tar.gz
- md5sums = 549a2ab9c90ac9b722e8e6be9691a155
+ depends = mulle-bashfunctions>=4.1.1
+ depends = mulle-env>=4.1.0
+ source = https://github.com/mulle-sde/mulle-sourcetree/archive/1.1.0.tar.gz
+ md5sums = c0b6b01ab0a8a459c110ebc00ca6b56c
pkgname = mulle-sourcetree
diff --git a/PKGBUILD b/PKGBUILD
index 0b1c0513b5f8..f5353d423ba2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonathan Boyle <programmerfalcon@gmail.com>
pkgname=mulle-sourcetree
-pkgver=0.25.0
+pkgver=1.1.0
pkgrel=1
epoch=1
pkgdesc="Project composition and maintenance with build support"
@@ -8,11 +8,11 @@ arch=('any')
url="https://github.com/mulle-sde/mulle-sourcetree"
license=('BSD3')
groups=('mulle-sde-all')
-depends=('bash' 'mulle-bashfunctions>=3.4.0')
+depends=('bash' 'mulle-bashfunctions>=4.1.1' 'mulle-env>=4.1.0')
changelog="RELEASENOTES.md"
-source=("https://github.com/mulle-sde/mulle-sourcetree/archive/0.25.0.tar.gz")
+source=("https://github.com/mulle-sde/mulle-sourcetree/archive/1.1.0.tar.gz")
noextract=()
-md5sums=('549a2ab9c90ac9b722e8e6be9691a155')
+md5sums=('c0b6b01ab0a8a459c110ebc00ca6b56c')
validpgpkeys=()
package() {
diff --git a/RELEASENOTES.md b/RELEASENOTES.md
index f4c680e0e1b1..05079dfffef7 100644
--- a/RELEASENOTES.md
+++ b/RELEASENOTES.md
@@ -1,3 +1,25 @@
+## 1.1.0
+
+* added mulle-sourcetree-edit-csv and friends
+
+
+# 1.0.0
+
+* big function rename to `<tool>`::`<file>`::`<function>` to make it easier to read hopefully
+* list has now a -m option
+* experimental support for os-specific config files
+* implemented having a different config by uname, if so desired (needs reflect on each platform though)
+* cmake now used no-dynamic-link and no-static-link for `find_library`
+* fix wrong zombification, which means that mulle-sourcetree now doesn't refetch a lot of stuff gratuitously anymore *HUGE IMPROVEMENT*
+* removed parallel clean because of an as of yet undiagnosed problem with it
+* advertise tool in generated file
+* added a **diff** command
+* the status gained --shallow and --deep flags
+* the sync operation can perform some node syncs in parallel now (turn off with --serial)
+* needs mulle-bashfunctions 4.0.0 now
+* runs with zsh when installed, which can double the speed of sourcetree walk operations
+
+
## 0.25.0
* change/fix --no-bequeath --bequeath flags so it does what it promises to do and not the opposite
@@ -123,7 +145,7 @@
* aliases need to include the name, so you can determine the lookup order
* buildorder is now using breadth-first for marks and in-order for filename to make things easier
* support various dedupe options
-* `node_printf` can print environment variables now with %v{ENVNAME,,}
+* `sourcetree::node::printf` can print environment variables now with %v{ENVNAME,,}
* many commands lose the unused filter options --marks --nodetypes and --permissions
* there is now a duplicate command for nodes
* node typeguess is a bit better now