summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 21:55:24 +0200
committeroli2015-06-12 21:55:24 +0200
commitf633269a691a143b033e928fc3d96209349ff10a (patch)
tree659583ee05b717598ca58e801e11f1db3b6444cc
downloadaur-f633269a691a143b033e928fc3d96209349ff10a.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD72
-rw-r--r--cewefotoschau.desktop7
-rw-r--r--schleckerfotodigiservice.desktop7
-rw-r--r--schleckerfotodigiservice.install26
5 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31ff63224a2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mullerfoto-fotostar_de
+ pkgdesc = an offline client for uploading and ordering photos at cewe.de - Schlecker Foto Digital Service (used to be FotoStar Client)
+ pkgver = 4.6.8
+ pkgrel = 2
+ url = http://www.cewe.de/
+ install = schleckerfotodigiservice.install
+ arch = i686
+ license = custom:eula
+ depends = libx11
+ depends = curl
+ conflicts = mullerfoto-fotostar_cz
+ conflicts = mullerfoto-fotostar_sk
+ source = http://dls.photoprintit.de/download/Data/1119/hps/Schlecker_Fotoservice.tgz
+ source = schleckerfotodigiservice.desktop
+ source = cewefotoschau.desktop
+ md5sums = c8a30c0bbc36cea3400fbd097e908116
+ md5sums = 15f89990079d333ad3ac54f4df2082a9
+ md5sums = c360fa7f1e3b16853062922c38fc5559
+
+pkgname = mullerfoto-fotostar_de
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c25ba208f42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=mullerfoto-fotostar_de
+pkgver=4.6.8
+pkgrel=2
+pkgdesc="an offline client for uploading and ordering photos at cewe.de - Schlecker Foto Digital Service (used to be FotoStar Client)"
+url="http://www.cewe.de/"
+license=("custom:eula")
+depends=('libx11' 'curl')
+arch=('i686')
+source=("http://dls.photoprintit.de/download/Data/1119/hps/Schlecker_Fotoservice.tgz" "schleckerfotodigiservice.desktop" "cewefotoschau.desktop")
+install=('schleckerfotodigiservice.install')
+conflicts=('mullerfoto-fotostar_cz' 'mullerfoto-fotostar_sk')
+md5sums=('c8a30c0bbc36cea3400fbd097e908116'
+ '15f89990079d333ad3ac54f4df2082a9'
+ 'c360fa7f1e3b16853062922c38fc5559')
+
+build() {
+ cd $srcdir
+ mkdir -p $pkgdir/usr/{share/$pkgname,bin}
+ KEYACCID=1119
+ CLIENTID=38
+ HPS_VER=$pkgver
+ # download list of links
+ wget -O url_list.txt "http://dls.photoprintit.de/download/Data/${KEYACCID}/hps/${CLIENTID}-index-${HPS_VER}.txt"
+ echo "Downloading and extracting files.."
+ for url in $(awk -F\; '{print $1}' url_list.txt|egrep -v "dll|cewe|setup_Mueller|setup_Fotostar|setup_bol_de|setup_Moj_CeWe"); do
+ wget "http://dls.photoprintit.de/$url"
+ unzip -d $pkgdir/usr/share/$pkgname $(basename $url)
+ done
+ echo "Creating symlinks.."
+ # weird stuff, but this is what the installation script is doing also
+ cd $pkgdir/usr/share/$pkgname
+ version_array=()
+ rm {libCWImageLoader,libCWGUIWidgets}.so{,.0,.0.1} libexpat.so{,.1}
+ for source in *.so*; do
+ libversion=$(echo $source|sed -n 's/\(.*\).so\.\(.*\)/\2/p')
+ libname=$(echo $source|sed -n 's/\(.*\.so\)\..*/\1/p');
+ IFS=$'.' read -a version_array <<< "${libversion}"
+ unset IFS
+ n=${#version_array[*]}
+ target=()
+ for ((i=0;i<n-1;i++)); do
+ target=$(echo -n "$target"."${version_array[i]}")
+ ln -s "$source" "${libname}${target}" || true
+ done
+ done
+ # space in executable filenames is generally a bad idea
+ mv "SCHLECKER Foto Digital Service" "SchleckerFotoDigitalService"
+ mv "CEWE FOTOSCHAU" "CeweFotoschau"
+ # make files executable
+ chmod 0755 ./SchleckerFotoDigitalService
+ chmod 0755 ./CeweFotoschau
+ chmod 0755 ./assistant
+ chmod 0755 ./facedetection
+ # copy EULA
+ install -D -m644 $srcdir/EULA.txt $pkgdir/usr/share/$pkgname/EULA.txt
+ # create startup script
+ (echo "#!/bin/bash
+cd /usr/share/$pkgname
+./CeweFotoschau \"\$@\"") > $pkgdir/usr/bin/CeweFotoschau
+ (echo "#!/bin/bash
+cd /usr/share/$pkgname
+./SchleckerFotoDigitalService \"\$@\"") > $pkgdir/usr/bin/SchleckerFotoDigitalService
+ chmod 0755 $pkgdir/usr/bin/SchleckerFotoDigitalService
+ chmod 0755 $pkgdir/usr/bin/CeweFotoschau
+ # create desktop shortcut
+ install -D -m644 Resources/keyaccount/32.xpm $pkgdir/usr/share/pixmaps/schleckerfotodigiservice.xpm
+ install -D -m644 Resources/keyaccount/fotoschau.xpm $pkgdir/usr/share/pixmaps/fotoschau.xpm
+ install -D -m644 $srcdir/schleckerfotodigiservice.desktop $pkgdir/usr/share/applications/schleckerfotodigiservice.desktop
+ install -D -m644 $srcdir/cewefotoschau.desktop $pkgdir/usr/share/applications/cewefotoschau.desktop
+}
diff --git a/cewefotoschau.desktop b/cewefotoschau.desktop
new file mode 100644
index 000000000000..2333fb380455
--- /dev/null
+++ b/cewefotoschau.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Schlecker Foto Digital Service (photoshow)
+Comment=View/edit your photos before uploading them to Schlecker Foto Digital Service
+Exec=CeweFotoschau
+Icon=fotoschau.xpm
+Categories=Graphics;Photography;
diff --git a/schleckerfotodigiservice.desktop b/schleckerfotodigiservice.desktop
new file mode 100644
index 000000000000..4ae93ec33ed8
--- /dev/null
+++ b/schleckerfotodigiservice.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Schlecker Foto Digital Service
+Comment=Offline client for cewe.de service
+Exec=SchleckerFotoDigitalService
+Icon=schleckerfotodigiservice.xpm
+Categories=Graphics;Photography;
diff --git a/schleckerfotodigiservice.install b/schleckerfotodigiservice.install
new file mode 100644
index 000000000000..3e027a3d5db9
--- /dev/null
+++ b/schleckerfotodigiservice.install
@@ -0,0 +1,26 @@
+post_install() {
+ echo '--------------------------------------------------'
+ echo 'You *MUST* read and agree to the license stored in'
+ echo '/usr/share/mullerfoto-fotostar_de/EULA.txt before'
+ echo 'you start using it'
+ echo '--------------------------------------------------'
+
+ chgrp camera /usr/share/mullerfoto-fotostar_de
+ chmod 775 /usr/share/mullerfoto-fotostar_de
+
+ echo "Add user to group camera to be able to use this program."
+ /bin/true
+}
+
+post_upgrade() {
+/bin/true
+}
+
+pre_remove() {
+/bin/true
+}
+
+op=$1
+shift
+
+$op "$@"