summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-02-05 10:03:37 -0700
committeryochananmarqos2020-02-05 10:03:37 -0700
commitde26a1c2dc6414dd16e5b0e6c3fe27cf13e33eda (patch)
tree7dbba0a6458ae3e7e0eacf2fae2e1f5091a4e889
downloadaur-de26a1c2dc6414dd16e5b0e6c3fe27cf13e33eda.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6c600d99acf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mullpy
+ pkgdesc = Unofficial Mullvad CLI tool to check if you're secured
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/franccesco/mullpy
+ arch = any
+ license = MIT
+ makedepends = python-pip
+ depends = python-requests
+ depends = python-colorama
+ depends = python-click
+ noextract = mullvad_python-0.3.1-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/m/mullvad_python/mullvad_python-0.3.1-py3-none-any.whl
+ source = https://raw.githubusercontent.com/franccesco/mullpy/master/LICENSE.md
+ sha256sums = cd3a939d4f70e5f5c362fdff3a2e8704e3e0c67f7d0cc695436f77d31293266c
+ sha256sums = 9766ae1f6b83bdd3aedb76980ce0644c674fd3f52eaaa06612d589731549fe43
+
+pkgname = mullpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41e5628f057b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=mullpy
+_name=mullvad_python
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Unofficial Mullvad CLI tool to check if you're secured"
+arch=('any')
+url="https://github.com/franccesco/mullpy"
+license=('MIT')
+depends=('python-requests' 'python-colorama' 'python-click')
+makedepends=('python-pip')
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_name-$pkgver-py3-none-any.whl"
+ "https://raw.githubusercontent.com/franccesco/$pkgname/master/LICENSE.md")
+noextract=(*.whl)
+sha256sums=('cd3a939d4f70e5f5c362fdff3a2e8704e3e0c67f7d0cc695436f77d31293266c'
+ '9766ae1f6b83bdd3aedb76980ce0644c674fd3f52eaaa06612d589731549fe43')
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --isolated \
+ --root="$pkgdir" \
+ --ignore-installed \
+ --no-deps *.whl \
+ --no-warn-script-location
+ python -O -m compileall "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}