summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvojvoda3432021-10-27 10:13:52 +0200
committervojvoda3432021-10-27 10:13:52 +0200
commitdeda13e7a29388f07f6c5eaa8e5141d9a466336c (patch)
tree23fa8aa64e4298b1a97d56b0883bd586a42c5e94
downloadaur-deda13e7a29388f07f6c5eaa8e5141d9a466336c.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
-rwxr-xr-xmullvadd.initd12
-rw-r--r--mullvadd.install12
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e5fc1b09f20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = mullvad-openrc
+ pkgdesc = mullvad openrc service
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/vojvoda343/mullvad-openrc
+ arch = any
+ license = GPL
+ depends = openrc
+ source = mullvadd.initd
+ sha256sums = 1a646ecbe3c3e4885e50200197406d667c6387482365e429b4ca9125da9e41e4
+
+pkgname = mullvad-openrc
+ install = mullvadd.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eafcd470cde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: vojvoda343 <voj343@yandex.com>
+pkgname=mullvad-openrc
+pkgver=1.0
+pkgrel=1
+pkgdesc="mullvad openrc service"
+arch=('any')
+url='https://github.com/vojvoda343/mullvad-openrc'
+license=('GPL')
+depends=('openrc')
+source=("mullvadd.initd")
+sha256sums=("1a646ecbe3c3e4885e50200197406d667c6387482365e429b4ca9125da9e41e4")
+
+package() {
+ install -Dm755 ${srcdir}/mullvadd.initd "$pkgdir"/etc/init.d/mullvadd
+ install=mullvadd.install
+}
diff --git a/mullvadd.initd b/mullvadd.initd
new file mode 100755
index 000000000000..97ab51c6500d
--- /dev/null
+++ b/mullvadd.initd
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+description="Mullvad VPN Service"
+
+depend() {
+ need net
+}
+
+supervisor="supervise-daemon"
+command="/opt/Mullvad\ VPN/resources/mullvad-daemon"
+command_args="${MULLVPN_OPTS}"
+#pidfile="/run/${SVCNAME}.pid"
+command_background=true
diff --git a/mullvadd.install b/mullvadd.install
new file mode 100644
index 000000000000..8ea01365438a
--- /dev/null
+++ b/mullvadd.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo " ==> Add the mullvad daemon to system startup wtih 'rc-update add mullvadd default'"
+ echo " ==> Start the mullvad daemon now with 'rc-service mullvadd start'"
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ echo " ==> Make sure you run 'rc-update del mullvadd default'"
+}