summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-12-02 18:28:00 -0700
committeryochananmarqos2019-12-02 18:28:00 -0700
commit18b944939f150c32e2e17f13c887d6c1c8b77e9b (patch)
tree65b5e191f3281b1730b64555b40883a5c84b331f
parenteda5d4ab8fcc61bc72458375f5d7e50de313e179 (diff)
downloadaur-18b944939f150c32e2e17f13c887d6c1c8b77e9b.tar.gz
fixes, but still does not build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba9fd96eea69..bd8a79a3ce43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,8 +14,10 @@ pkgbase = mullvad-vpn
depends = libxss
depends = nss
source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2019.9
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git
source = mullvad-vpn.desktop
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 121d90e6683e64d9c0d2dbb7b346fa918bdb37cf21fdaf9f66232304ed23abc2
pkgname = mullvad-vpn
diff --git a/PKGBUILD b/PKGBUILD
index 3f6ba9d3fbeb..21e4fa6f51bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
# Contributor: Matthew McGinn <mamcgi at gmail dot com>
# Contributor: alicewww <almw at protonmail dot com>
+# Contributor: David Birks <david at tellus dot space>
pkgname=mullvad-vpn
pkgver=2019.9
pkgrel=7
@@ -12,13 +13,18 @@ depends=('libnotify' 'libappindicator-gtk3' 'libxss' 'nss')
makedepends=('git' 'cargo' 'npm')
install="$pkgname.install"
source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=$pkgver"
+ 'git+https://github.com/mullvad/mullvadvpn-app-binaries.git'
"$pkgname.desktop")
sha256sums=('SKIP'
+ 'SKIP'
'121d90e6683e64d9c0d2dbb7b346fa918bdb37cf21fdaf9f66232304ed23abc2')
prepare() {
+ # Point the submodule to our local copy
cd "$srcdir/mullvadvpn-app"
- git submodule update --init --recursive
+ git submodule init dist-assets/binaries
+ git config submodule.mullvadvpn-app-binaries.url "$srcdir/mullvadvpn-app-binaries"
+ git submodule update
}
build() {
@@ -30,6 +36,7 @@ build() {
# Build Electron GUI app
cd gui
npm install --cache "$srcdir/npm-cache"
+ npm run pack:linux
}
check() {