summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-12-08 10:09:53 -0700
committeryochananmarqos2019-12-08 10:09:53 -0700
commit9074565054fb5879601cbfde7747ebc24e5891b5 (patch)
tree3843df084967096596111ddcf260491eb11d2ca1
parentc9de519f9bf6accee69140bd6487bc1df3979665 (diff)
downloadaur-9074565054fb5879601cbfde7747ebc24e5891b5.tar.gz
use static binaries commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f2f426c8a26..800257470ea4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn
pkgdesc = The Mullvad VPN client app for desktop
pkgver = 2019.9
- pkgrel = 11
+ pkgrel = 12
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = mullvad-vpn
depends = libxss
depends = nss
source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2019.9
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=85f5f891ca36ff6e55d5fa22d685694726a61d12
source = mullvad-vpn.desktop
source = update-relays.sh
validpgpkeys = A6A4778440D27368967A7A3578CEAA8CB72E4467
diff --git a/PKGBUILD b/PKGBUILD
index faa3e1a1d3dc..1b06fba7e046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn
pkgver=2019.9
-pkgrel=11
+pkgrel=12
pkgdesc="The Mullvad VPN client app for desktop"
url="https://www.mullvad.net"
arch=('x86_64')
@@ -15,8 +15,9 @@ license=('GPL3')
depends=('libnotify' 'libappindicator-gtk3' 'libxss' 'nss')
makedepends=('git' 'cargo' 'npm' 'rpm')
install="$pkgname.install"
+_commit='85f5f891ca36ff6e55d5fa22d685694726a61d12'
source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=$pkgver"
- 'git+https://github.com/mullvad/mullvadvpn-app-binaries.git'
+ "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit"
"$pkgname.desktop"
'update-relays.sh')
sha256sums=('SKIP'
@@ -24,7 +25,7 @@ sha256sums=('SKIP'
'121d90e6683e64d9c0d2dbb7b346fa918bdb37cf21fdaf9f66232304ed23abc2'
'ec125bc9cfe2403bacfcaebf4b58f88b4d734b0f6194c23016efd7e15684f8e0')
validpgpkeys=('A6A4778440D27368967A7A3578CEAA8CB72E4467')
- # tagger Linus Färnstrand <linus at mullvad dot net> 1570795216 +0200
+ # Linus Färnstrand (code signing key) <linus at mullvad dot net>
prepare() {
# Point the submodule to our local copy
@@ -35,7 +36,11 @@ prepare() {
git submodule update
# Verify git tag
- git tag -v "$pkgver"
+ git verify-tag "$pkgver"
+
+ # Verify git commit
+ #cd "$srcdir/mullvadvpn-app-binaries"
+ #git verify-commit "$_commit"
}
build() {