summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-12-24 09:56:14 -0700
committeryochananmarqos2019-12-24 09:56:14 -0700
commitd6929e31e547e02d0182e9bfca60550ed51c1230 (patch)
tree222f36e11bdde109b732c06c883ea1636c792802
parent5f2b1fdeda95f20ac44d255f607519c58394fde6 (diff)
downloadaur-d6929e31e547e02d0182e9bfca60550ed51c1230.tar.gz
disable building of rpm
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9b171e72ad7..5ec8d1f0f72a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn
pkgdesc = The Mullvad VPN client app for desktop
pkgver = 2019.10
- pkgrel = 1
+ pkgrel = 2
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
@@ -9,7 +9,6 @@ pkgbase = mullvad-vpn
makedepends = git
makedepends = cargo
makedepends = npm
- makedepends = rpm
depends = libnotify
depends = libappindicator-gtk3
depends = libxss
diff --git a/PKGBUILD b/PKGBUILD
index 4c32cae52a7e..32cd508e728f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Matthew McGinn <mamcgi at gmail dot com>
# Contributor: alicewww <almw at protonmail dot com>
# Contributor: David Birks <david at tellus dot space>
@@ -8,13 +8,13 @@
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn
pkgver=2019.10
-pkgrel=1
+pkgrel=2
pkgdesc="The Mullvad VPN client app for desktop"
url="https://www.mullvad.net"
arch=('x86_64')
license=('GPL3')
depends=('libnotify' 'libappindicator-gtk3' 'libxss' 'nss')
-makedepends=('git' 'cargo' 'npm' 'rpm')
+makedepends=('git' 'cargo' 'npm')
install="$pkgname.install"
_commit='0c1a0aca41492fbb9ef1f187122e2f5bda0927ba'
source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=$pkgver?signed"
@@ -35,6 +35,9 @@ prepare() {
git config submodule.mullvadvpn-app-binaries.url \
"$srcdir/mullvadvpn-app-binaries"
git submodule update
+
+ # Disable building of rpm
+ sed -i "s/'deb', 'rpm'/'deb'/g" gui/tasks/distribution.js
}
build() {