summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortelans2019-08-10 09:38:31 +1200
committertelans2019-08-10 09:38:31 +1200
commit25b92362c2200d5688c28b5b9ddfb164af0b4b53 (patch)
treee43820847cf6703f1587bdccf6d25bfccf65ed54
downloadaur-25b92362c2200d5688c28b5b9ddfb164af0b4b53.tar.gz
initial upload
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD51
-rw-r--r--mullvad-daemon.service14
-rw-r--r--mullvad-vpn-beta.install13
-rw-r--r--mullvad-vpn.desktop8
5 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fbb9df71230
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = mullvad-vpn-beta
+ pkgdesc = VPN Client for Mullvad.net, a bitcoin-friendly VPN for anonymity and privacy
+ pkgver = 2019.7
+ pkgrel = 1
+ url = https://www.mullvad.net
+ install = mullvad-vpn-beta.install
+ arch = x86_64
+ license = GPL3
+ depends = gconf
+ depends = gtk3
+ depends = libnotify
+ depends = libappindicator-gtk2
+ depends = libxss
+ depends = nss
+ provides = mullvad-vpn
+ conflicts = mullvad-vpn-old
+ conflicts = mullvad-vpn
+ replaces = mullvad-vpn-old
+ replaces = mullvad-vpn
+ source = mullvad-daemon.service
+ source = mullvad-vpn.desktop
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2019.7-beta1/MullvadVPN-2019.7-beta1_x86_64.rpm
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2019.7-beta1/MullvadVPN-2019.7-beta1_x86_64.rpm.asc
+ validpgpkeys = A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF
+ md5sums = ed3a49275addbd5f2098a33bd605f1d3
+ md5sums = 9628b4f93e72f5cca0a47087ae10b0fd
+ md5sums = 8525f785caa496c20c097440e40ed16b
+ md5sums = SKIP
+
+pkgname = mullvad-vpn-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a41ac64fd25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: telans <telans@protonmail.com>
+# Contributor: Matthew McGinn <mamcgi@gmail.com>
+# Contributor: alicewww <almw@protonmail.com>
+
+pkgname=mullvad-vpn-beta
+_pkgname=mullvad-vpn
+pkgver=2019.7
+_betaver=beta1
+pkgrel=1
+pkgdesc="VPN Client for Mullvad.net, a bitcoin-friendly VPN for anonymity and privacy"
+_github_url="https://github.com/mullvad/mullvadvpn-app"
+url="https://www.mullvad.net"
+arch=('x86_64')
+license=('GPL3')
+depends=('gconf' 'gtk3' 'libnotify' 'libappindicator-gtk2' 'libxss' 'nss')
+conflicts=('mullvad-vpn-old' 'mullvad-vpn')
+replaces=('mullvad-vpn-old' 'mullvad-vpn')
+provides=($_pkgname)
+validpgpkeys=("A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF")
+source=(mullvad-daemon.service
+ mullvad-vpn.desktop
+ "https://github.com/mullvad/mullvadvpn-app/releases/download/${pkgver}-${_betaver}/MullvadVPN-${pkgver}-${_betaver}_${arch}.rpm"
+ "https://github.com/mullvad/mullvadvpn-app/releases/download/${pkgver}-${_betaver}/MullvadVPN-${pkgver}-${_betaver}_${arch}.rpm.asc")
+
+md5sums=('ed3a49275addbd5f2098a33bd605f1d3'
+ '9628b4f93e72f5cca0a47087ae10b0fd'
+ '8525f785caa496c20c097440e40ed16b'
+ 'SKIP')
+
+install=$pkgname.install
+
+package() {
+ install -Dm644 mullvad-daemon.service "${pkgdir}/usr/lib/systemd/system/mullvad-daemon.service"
+
+ install -d "${pkgdir}/opt/${_pkgname}"
+ cp -a "${srcdir}/opt/Mullvad VPN/." "${pkgdir}/opt/${_pkgname}"
+
+ chmod 755 "${pkgdir}/opt/${_pkgname}/${_pkgname}"
+
+ mkdir -p ${pkgdir}/usr/bin
+ ln -s "/opt/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ install -d "${pkgdir}/usr/share/applications"
+ install ${_pkgname}.desktop "${pkgdir}/usr/share/applications"
+ sed -i s%/usr/share%/opt% ${pkgdir}/usr/share/applications/${_pkgname}.desktop
+
+ install -m755 "${srcdir}/usr/bin/mullvad" "${pkgdir}/usr/bin/mullvad"
+
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor"
+ cp -a "${srcdir}/usr/share/icons/hicolor/." "${pkgdir}/usr/share/icons/hicolor"
+}
diff --git a/mullvad-daemon.service b/mullvad-daemon.service
new file mode 100644
index 000000000000..4831b98add19
--- /dev/null
+++ b/mullvad-daemon.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Mullvad VPN daemon
+Wants=network.target
+After=network-online.target
+StartLimitBurst=5
+StartLimitIntervalSec=20
+
+[Service]
+Restart=always
+RestartSec=1
+ExecStart="/opt/mullvad-vpn/resources/mullvad-daemon" -v --disable-stdout-timestamps
+
+[Install]
+WantedBy=multi-user.target
diff --git a/mullvad-vpn-beta.install b/mullvad-vpn-beta.install
new file mode 100644
index 000000000000..a60c2504f804
--- /dev/null
+++ b/mullvad-vpn-beta.install
@@ -0,0 +1,13 @@
+post_upgrade() {
+ echo -------------------------------------------------------------
+ echo 'You need to restart the mullvad daemon'
+ echo '# systemctl restart mullvad-daemon'
+ echo -------------------------------------------------------------
+}
+
+post_install() {
+ echo -------------------------------------------------------------
+ echo 'Make sure to enable and run the mullvad daemon'
+ echo '# systemctl enable --now mullvad-daemon'
+ echo -------------------------------------------------------------
+}
diff --git a/mullvad-vpn.desktop b/mullvad-vpn.desktop
new file mode 100644
index 000000000000..89fdff6dc9b6
--- /dev/null
+++ b/mullvad-vpn.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mullvad VPN
+Comment=Mullvad VPN client
+Exec="/opt/mullvad-vpn/mullvad-vpn" %U
+Terminal=false
+Type=Application
+Icon=mullvad-vpn
+Categories=Network;