summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-02-05 09:39:23 -0700
committeryochananmarqos2020-02-05 09:39:23 -0700
commit2e2c9002c0845eddac238eee04d6558fecced910 (patch)
treed10d9b9bbc1d57d447fd892b08310dba1b8b4126
parent3fe09f0c4475a1187b4dcd15f32f25d6a9baa38a (diff)
downloadaur-2e2c9002c0845eddac238eee04d6558fecced910.tar.gz
updated to 2020.1-beta1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
-rwxr-xr-xupdate-relays.sh35
3 files changed, 51 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2cedb7de79c..6c952249d7f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = mullvad-vpn-beta
pkgdesc = The Mullvad VPN client app for desktop (latest/beta release)
- pkgver = 2019.10.stable
- pkgrel = 2
+ pkgver = 2020.1.beta1
+ pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
license = GPL3
makedepends = git
- makedepends = cargo
+ makedepends = go-pie
+ makedepends = rust
makedepends = npm
depends = libnotify
depends = libappindicator-gtk3
@@ -15,15 +16,15 @@ pkgbase = mullvad-vpn-beta
depends = nss
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2019.10?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=0c1a0aca41492fbb9ef1f187122e2f5bda0927ba?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2020.1-beta1
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=90b0c06b59a0b9d6cda69924377335f39854b216?signed
source = mullvad-vpn.desktop
source = update-relays.sh
- validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
+ validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 121d90e6683e64d9c0d2dbb7b346fa918bdb37cf21fdaf9f66232304ed23abc2
- sha256sums = ec125bc9cfe2403bacfcaebf4b58f88b4d734b0f6194c23016efd7e15684f8e0
+ sha256sums = 89267795175c5be95d13e8f700b69654faf2f38f35be5033eb8e94da404d2353
pkgname = mullvad-vpn-beta
diff --git a/PKGBUILD b/PKGBUILD
index 7dcb2628d510..646c45cbedc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,30 +6,32 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn-beta
-_pkgver=2019.10
-_channel=stable
-pkgver=${_pkgver}.${_channel}
-pkgrel=2
+_pkgver=2020.1
+_channel=beta
+pkgver=${_pkgver}.${_channel}1
+pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (latest/beta release)"
url="https://www.mullvad.net"
arch=('x86_64')
license=('GPL3')
depends=('libnotify' 'libappindicator-gtk3' 'libxss' 'nss')
-makedepends=('git' 'cargo' 'npm')
+makedepends=('git' 'go-pie' 'rust' 'npm')
provides=("${pkgname%-beta}")
conflicts=("${pkgname%-beta}")
install="${pkgname%-beta}.install"
-_commit='0c1a0aca41492fbb9ef1f187122e2f5bda0927ba'
-source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}?signed"
+_commit='90b0c06b59a0b9d6cda69924377335f39854b216'
+source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}-${_channel}1" #?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit?signed"
"${pkgname%-beta}.desktop"
'update-relays.sh')
sha256sums=('SKIP'
'SKIP'
'121d90e6683e64d9c0d2dbb7b346fa918bdb37cf21fdaf9f66232304ed23abc2'
- 'ec125bc9cfe2403bacfcaebf4b58f88b4d734b0f6194c23016efd7e15684f8e0')
-validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87')
+ '89267795175c5be95d13e8f700b69654faf2f38f35be5033eb8e94da404d2353')
+ #'EA0A77BF9E115615FC3BD8BC7653B940E494FE87' SIGNATURE NOT FOUND
# Linus Färnstrand (code signing key) <linus at mullvad dot net>
+validpgpkeys=('8339C7D2942EB854E3F27CE5AEE9DECFD582E984')
+ # David Lönnhager (code signing) <david dot l at mullvad dot net>
prepare() {
# Point the submodule to our local copy
@@ -44,13 +46,25 @@ prepare() {
}
build() {
+ cd "$srcdir/mullvadvpn-app/wireguard/wireguard-go"
+
+ # Build wireguard-go
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -v -o libwg.a -buildmode c-archive
+
+ target_triple_dir="../../build/lib/x86_64-unknown-linux-gnu"
+ mkdir -p $target_triple_dir
+ cp libwg.a $target_triple_dir
+
cd "$srcdir/mullvadvpn-app"
# Remove old Rust build artifacts
cargo clean --release --locked
# Build mullvad-daemon
- cargo build --release --locked
+ cargo build --release --locked --all-features
# Copy binaries for packaging
cp dist-assets/binaries/x86_64-unknown-linux-gnu/{openvpn,sslocal} \
diff --git a/update-relays.sh b/update-relays.sh
index ef63dcd6afbf..88f43c3ca60b 100755
--- a/update-relays.sh
+++ b/update-relays.sh
@@ -1,19 +1,22 @@
#!/bin/bash
+echo "Updating relay list..."
+set +e
read -d '' JSONRPC_CODE <<-JSONRPC_CODE
- var buff = "";
- process.stdin.on('data', function (chunk) {
- buff += chunk;
- })
- process.stdin.on('end', function () {
- var obj = JSON.parse(buff);
- var output = JSON.stringify(obj.result, null, ' ');
- process.stdout.write(output);
- })
- JSONRPC_CODE
+var buff = "";
+process.stdin.on('data', function (chunk) {
+ buff += chunk;
+})
+process.stdin.on('end', function () {
+ var obj = JSON.parse(buff);
+ var output = JSON.stringify(obj.result, null, ' ');
+ process.stdout.write(output);
+})
+JSONRPC_CODE
+set -e
- JSONRPC_RESPONSE="$(curl -X POST \
- --fail \
- -H "Content-Type: application/json" \
- -d '{"jsonrpc": "2.0", "id": "0", "method": "relay_list_v3"}' \
- https://api.mullvad.net/rpc/)"
- echo "$JSONRPC_RESPONSE" | node -e "$JSONRPC_CODE" > dist-assets/relays.json
+JSONRPC_RESPONSE="$(curl -X POST \
+ --fail \
+ -H "Content-Type: application/json" \
+ -d '{"jsonrpc": "2.0", "id": "0", "method": "relay_list_v3"}' \
+ https://api.mullvad.net/rpc/)"
+echo $JSONRPC_RESPONSE | node -e "$JSONRPC_CODE" > dist-assets/relays.json