summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-05-16 11:15:12 -0600
committerMark Wagie2022-05-16 11:15:12 -0600
commit44ca62fa5b6811c768e0233e3918f3188d8f3fe8 (patch)
treede193a1d28695b0e2c34289d06e1a196dff1a5fd
parenta22433b30f65b93f81f262527c311a1d99bc16a3 (diff)
downloadaur-44ca62fa5b6811c768e0233e3918f3188d8f3fe8.tar.gz
2022.2-beta1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
2 files changed, 17 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bded3d306ec..e8bc762cd251 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-beta
pkgdesc = The Mullvad VPN client app for desktop (beta channel)
- pkgver = 2022.1.stable1
+ pkgver = 2022.2.beta1
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
@@ -18,8 +18,8 @@ pkgbase = mullvad-vpn-beta
provides = mullvad-vpn
conflicts = mullvad-vpn
options = !lto
- source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2022.1?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=973ee47bec89df537b8ecae20235071055693ec5
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2022.2-beta1?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec?signed
source = mullvad-vpn.sh
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
diff --git a/PKGBUILD b/PKGBUILD
index 00424f12f8c7..7b4e937b53ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn-beta
-_pkgver=2022.1
-_channel=stable
+_pkgver=2022.2
+_channel=beta
_rel=1
# beta
pkgver=${_pkgver}.${_channel}${_rel}
@@ -23,12 +23,11 @@ provides=("${pkgname%-beta}")
conflicts=("${pkgname%-beta}")
options=('!lto')
install="${pkgname%-beta}.install"
-_commit=973ee47bec89df537b8ecae20235071055693ec5
+_commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec
source=(
-# "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}-${_channel}${_rel}?signed" # beta
- "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}?signed" # stable
-# "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit?signed"
- "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit" # unverified commit by mvd-ows
+ "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}-${_channel}${_rel}?signed" # beta
+# "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}?signed" # stable
+ "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
"${pkgname%-beta}.sh"
)
sha256sums=('SKIP'
@@ -71,14 +70,13 @@ prepare() {
build() {
cd "$srcdir/mullvadvpn-app"
local RUSTC_VERSION=$(rustc --version)
- local PRODUCT_VERSION=$(node -p "require('./gui/package.json').version" | \
- sed -Ee 's/\.0//g')
+ local PRODUCT_VERSION=$(cd gui/; node -p "require('./package.json').version" | sed -Ee 's/\.0//g')
source env.sh ""
- echo "Building Mullvad VPN $PRODUCT_VERSION..."
+ echo "Building Mullvad VPN ${PRODUCT_VERSION}..."
echo "Updating version in metadata files..."
- ./version-metadata.sh inject $PRODUCT_VERSION --desktop
+ ./version-metadata.sh inject ${PRODUCT_VERSION} --desktop
echo "Building wireguard-go..."
pushd wireguard/libwg
@@ -96,7 +94,7 @@ build() {
export MULLVAD_ADD_MANIFEST="1"
- echo "Building Rust code in release mode using $RUSTC_VERSION..."
+ echo "Building Rust code in release mode using ${RUSTC_VERSION}..."
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
@@ -104,8 +102,8 @@ build() {
mkdir -p dist-assets/shell-completions
for sh in bash zsh fish; do
- echo "Generating shell completion script for $sh..."
- cargo run --bin mullvad --frozen --release -- shell-completions "$sh" \
+ echo "Generating shell completion script for ${sh}..."
+ cargo run --bin mullvad --frozen --release -- shell-completions ${sh} \
dist-assets/shell-completions/
done
@@ -119,15 +117,12 @@ build() {
mullvad-exclude
)
for binary in ${binaries[*]}; do
- cp "target/release/$binary" "dist-assets/$binary"
+ cp target/release/${binary} dist-assets/${binary}
done
echo "Updating relay list..."
cargo run --bin relay_list --frozen --release > dist-assets/relays.json
- echo "Updating API address cache..."
- cargo run --bin address_cache --frozen --release > dist-assets/api-ip-address.txt
-
# Build Electron GUI app
pushd gui
echo "Packing final release artifact..."
@@ -184,6 +179,6 @@ package() {
for icon_size in 16 32 48 64 128 256 512 1024; do
icons_dir=usr/share/icons/hicolor/${icon_size}x${icon_size}/apps
- install -Dm644 $icons_dir/${pkgname%-beta}.png -t $pkgdir/$icons_dir
+ install -Dm644 ${icons_dir}/${pkgname%-beta}.png -t "$pkgdir/${icons_dir}"
done
}