summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-03-24 12:03:00 -0600
committerMark Wagie2023-03-24 12:03:00 -0600
commit960dae825bff71a4294ee708aeeec738472dd97d (patch)
tree6486435344e14b796c34c200c75c317c17c1574d
parent1f933595a1854bbd4ef112e75974e02c3e7ef99e (diff)
downloadaur-960dae825bff71a4294ee708aeeec738472dd97d.tar.gz
2023.3-beta1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e37bc976995..d3cee30879c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-beta
pkgdesc = The Mullvad VPN client app for desktop (beta channel)
- pkgver = 2023.2.stable
+ pkgver = 2023.3.beta1
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
@@ -20,8 +20,8 @@ pkgbase = mullvad-vpn-beta
provides = mullvad-vpn
conflicts = mullvad-vpn
options = !lto
- source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=ccfbaa279d04b4f93dff489880e3fb3ae67025bd?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=f6dca66645c82501a330416ad39c7e63bcdae57d?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=3598eead7d65184dcf83a27a79b9b11887d70e2b?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=29a4c7205e78c651fcd1b8c3a55181c0d86a50d3?signed
source = no-rpm.diff
source = mullvad-vpn.sh
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
diff --git a/PKGBUILD b/PKGBUILD
index 1b33a8d56ac0..cd9bcda43543 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn-beta
-_pkgver=2023.2
-_channel=stable
+_pkgver=2023.3
+_channel=beta
_rel=1
-#pkgver=${_pkgver}.${_channel}${_rel} # beta
-pkgver=${_pkgver}.${_channel} # stable
+pkgver=${_pkgver}.${_channel}${_rel} # beta
+#pkgver=${_pkgver}.${_channel} # stable
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (beta channel)"
arch=('x86_64')
@@ -21,8 +21,8 @@ provides=("${pkgname%-beta}")
conflicts=("${pkgname%-beta}")
options=('!lto')
install="${pkgname%-beta}.install"
-_tag=ccfbaa279d04b4f93dff489880e3fb3ae67025bd # tags/2023.2^0
-_commit=f6dca66645c82501a330416ad39c7e63bcdae57d
+_tag=3598eead7d65184dcf83a27a79b9b11887d70e2b # tags/2023.3-beta1^0
+_commit=29a4c7205e78c651fcd1b8c3a55181c0d86a50d3
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
'no-rpm.diff'
@@ -91,11 +91,11 @@ build() {
cargo build --frozen --release
echo "Preparing for packaging Mullvad VPN ${PRODUCT_VERSION}..."
- mkdir -p dist-assets/shell-completions
+ mkdir -p build/shell-completions
for sh in bash zsh fish; do
echo "Generating shell completion script for ${sh}..."
cargo run --bin mullvad --frozen --release -- shell-completions ${sh} \
- dist-assets/shell-completions/
+ build/shell-completions/
done
echo "Updating relays.json..."
@@ -145,11 +145,11 @@ package() {
install -m755 "$srcdir/${pkgname%-beta}.sh" "$pkgdir/usr/bin/${pkgname%-beta}"
# Install completions
- install -Dm644 dist-assets/shell-completions/mullvad.bash \
+ install -Dm644 build/shell-completions/mullvad.bash \
"$pkgdir/usr/share/bash-completion/completions/mullvad"
- install -Dm644 dist-assets/shell-completions/_mullvad -t \
+ install -Dm644 build/shell-completions/_mullvad -t \
"$pkgdir/usr/share/zsh/site-functions/"
- install -Dm644 dist-assets/shell-completions/mullvad.fish -t \
+ install -Dm644 build/shell-completions/mullvad.fish -t \
"$pkgdir/usr/share/fish/vendor_completions.d/"
# Install desktop file & icons from deb