summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-12 16:36:34 -0600
committerMark Wagie2021-10-12 16:36:34 -0600
commit9e44fd46ea40561d0663570b1c2eb5c49ddc3334 (patch)
treebcb97814d38578734eb76fe27083035dab1f0e38
parentcbe051a3987073c2de855a0a2ce787f71530eefc (diff)
downloadaur-9e44fd46ea40561d0663570b1c2eb5c49ddc3334.tar.gz
2021.5-beta1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD40
2 files changed, 19 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4ab1e3fb28e..c5906d169b56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-beta
pkgdesc = The Mullvad VPN client app for desktop (beta channel)
- pkgver = 2021.4.stable
+ pkgver = 2021.5.beta1
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
@@ -9,17 +9,18 @@ pkgbase = mullvad-vpn-beta
makedepends = cargo
makedepends = git
makedepends = go
- makedepends = nvm
+ makedepends = npm
depends = iputils
depends = libnotify
depends = libappindicator-gtk3
depends = nss
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.4?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=3a236d50fd1ffb67cd3d29fbfc31393cdf03a224
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.5-beta1?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=19a97997b188855d0ba5aedb7419683df45d93bc?signed
source = mullvad-vpn.sh
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
+ validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
sha256sums = SKIP
sha256sums = SKIP
sha256sums = a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4
diff --git a/PKGBUILD b/PKGBUILD
index 6bb64a56eebe..aece1616bc15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,28 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn-beta
-_pkgver=2021.4
-_channel=stable
-pkgver=${_pkgver}.${_channel}
+_pkgver=2021.5
+_channel=beta
+_rel=1
+# beta
+pkgver=${_pkgver}.${_channel}${_rel}
+# stable
+#pkgver=${_pkgver}.${_channel}
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (beta channel)"
url="https://www.mullvad.net"
arch=('x86_64')
license=('GPL3')
depends=('iputils' 'libnotify' 'libappindicator-gtk3' 'nss')
-makedepends=('cargo' 'git' 'go' 'nvm')
+makedepends=('cargo' 'git' 'go' 'npm')
provides=("${pkgname%-beta}")
conflicts=("${pkgname%-beta}")
install="${pkgname%-beta}.install"
-_commit=3a236d50fd1ffb67cd3d29fbfc31393cdf03a224
+_commit=19a97997b188855d0ba5aedb7419683df45d93bc
source=(
-# "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}-${_channel}1?signed" # beta
- "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}?signed" # stable
-# "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit?signed" # unverified commit by mvd-ows
- "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit"
+ "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}-${_channel}${_rel}?signed" # beta
+# "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}?signed" # stable
+ "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit?signed"
"${pkgname%-beta}.sh"
)
sha256sums=('SKIP'
@@ -31,21 +34,10 @@ sha256sums=('SKIP'
'a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87'
# Linus Färnstrand (code signing key) <linus@mullvad.net>
-# '8339C7D2942EB854E3F27CE5AEE9DECFD582E984'
+ '8339C7D2942EB854E3F27CE5AEE9DECFD582E984'
)
# David Lönnhager (code signing) <david.l@mullvad.net>
-_ensure_local_nvm() {
- # let's be sure we are starting clean
- which nvm >/dev/null 2>&1 && nvm deactivate && nvm unload
- export NVM_DIR="$srcdir/.nvm"
-
- # The init script returns 3 if version specified
- # in ./.nvrc is not (yet) installed in $NVM_DIR
- # but nvm itself still gets loaded ok
- source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
-}
-
prepare() {
cd "$srcdir/mullvadvpn-app"
git submodule init dist-assets/binaries
@@ -55,6 +47,7 @@ prepare() {
# Disable building of rpm
sed -i "s/'deb', 'rpm'/'deb'/g" gui/tasks/distribution.js
+ export RUSTUP_TOOLCHAIN=stable
echo "Removing old Rust build artifacts"
cargo clean
@@ -65,10 +58,6 @@ prepare() {
# one becomes root or changes the write permissions.
export GOPATH="$srcdir/gopath"
go clean -modcache
-
- # Build fails with Node.js 16, use 15
- _ensure_local_nvm
- nvm install 15.14.0
}
build() {
@@ -134,7 +123,6 @@ build() {
# Build Electron GUI app
pushd gui
- _ensure_local_nvm
echo "Installing JavaScript dependencies..."
npm ci --cache "$srcdir/npm-cache"
echo "Packing final release artifact..."