summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-01-27 09:17:41 -0700
committerMark Wagie2023-01-27 09:17:41 -0700
commita1158fdbf53e56e17f287b7fd21b9cc5d7eee681 (patch)
tree51a486b45b9d7846e71f82d2becf29008fbafc25
parent294d2fec38db5a7d24cefb8b784d99e4dce0a288 (diff)
downloadaur-a1158fdbf53e56e17f287b7fd21b9cc5d7eee681.tar.gz
2023.1-beta1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
-rw-r--r--mullvad-vpn.install9
3 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adfe3cf4c6e7..278d29fc5cd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn-beta
pkgdesc = The Mullvad VPN client app for desktop (beta channel)
- pkgver = 2022.5.stable
- pkgrel = 4
+ pkgver = 2023.1.beta1
+ pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
@@ -9,9 +9,10 @@ pkgbase = mullvad-vpn-beta
makedepends = cargo
makedepends = git
makedepends = go
+ makedepends = libxcrypt-compat
makedepends = nodejs>=16
makedepends = npm>=8.3
- makedepends = libxcrypt-compat
+ makedepends = protobuf
depends = iputils
depends = libnotify
depends = libappindicator-gtk3
@@ -19,13 +20,11 @@ pkgbase = mullvad-vpn-beta
provides = mullvad-vpn
conflicts = mullvad-vpn
options = !lto
- source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=5bcd2533633d76b1deaf5875b24a2c83bec6fc49?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=5192b7e463aa198504819c3e1c2c894b26f1ddc4?signed
source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=f6dca66645c82501a330416ad39c7e63bcdae57d?signed
source = no-rpm.diff
source = mullvad-vpn.sh
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
- validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
- validpgpkeys = 4B986EF5222BA1B810230C602F391DE6B00D619C
sha256sums = SKIP
sha256sums = SKIP
sha256sums = ea35edffea2cbbb05586abce19581fdd9f133801ed47e6af30fa64a29c5cf116
diff --git a/PKGBUILD b/PKGBUILD
index 00305dba5585..13a210e31472 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,23 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn-beta
-_pkgver=2022.5
-_channel=stable
+_pkgver=2023.1
+_channel=beta
_rel=1
-# beta
-#pkgver=${_pkgver}.${_channel}${_rel}
-# stable
-pkgver=${_pkgver}.${_channel}
-pkgrel=4
+pkgver=${_pkgver}.${_channel}${_rel} # beta
+#pkgver=${_pkgver}.${_channel} # stable
+pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (beta channel)"
arch=('x86_64')
url="https://www.mullvad.net"
license=('GPL3')
depends=('iputils' 'libnotify' 'libappindicator-gtk3' 'nss')
-makedepends=('cargo' 'git' 'go' 'nodejs>=16' 'npm>=8.3' 'libxcrypt-compat')
+makedepends=('cargo' 'git' 'go' 'libxcrypt-compat' 'nodejs>=16' 'npm>=8.3' 'protobuf')
provides=("${pkgname%-beta}")
conflicts=("${pkgname%-beta}")
options=('!lto')
install="${pkgname%-beta}.install"
-_tag=5bcd2533633d76b1deaf5875b24a2c83bec6fc49 # tags/2022.5^0
+_tag=5192b7e463aa198504819c3e1c2c894b26f1ddc4 # tags/2023.1-beta1^0
_commit=f6dca66645c82501a330416ad39c7e63bcdae57d
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
@@ -34,8 +32,9 @@ sha256sums=('SKIP'
'ea35edffea2cbbb05586abce19581fdd9f133801ed47e6af30fa64a29c5cf116'
'2262346cb57deb187fe32a88ccd873dab669598889269088e749197c6e88954f')
validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87' # Linus Färnstrand (code signing key) <linus@mullvad.net>
- '8339C7D2942EB854E3F27CE5AEE9DECFD582E984' # David Lönnhager (code signing) <david.l@mullvad.net>
- '4B986EF5222BA1B810230C602F391DE6B00D619C') # Oskar Nyberg (code signing) <oskar@mullvad.net>
+# '8339C7D2942EB854E3F27CE5AEE9DECFD582E984' # David Lönnhager (code signing) <david.l@mullvad.net>
+# '4B986EF5222BA1B810230C602F391DE6B00D619C' # Oskar Nyberg (code signing) <oskar@mullvad.net>
+ )
prepare() {
cd "$srcdir/mullvadvpn-app"
@@ -68,7 +67,7 @@ prepare() {
build() {
cd "$srcdir/mullvadvpn-app"
local RUSTC_VERSION=$(rustc --version)
- local PRODUCT_VERSION=$(cd gui/; node -p "require('./package.json').version" | sed -Ee 's/\.0//g')
+ local PRODUCT_VERSION=$(cargo run -q --bin mullvad-version)
echo "Building Mullvad VPN ${PRODUCT_VERSION}..."
@@ -102,6 +101,7 @@ build() {
echo "Updating relays.json..."
cargo run --bin relay_list --frozen --release > dist-assets/relays.json
+ # Move binaries to correct locations in dist-assets
binaries=(
mullvad-daemon
mullvad
diff --git a/mullvad-vpn.install b/mullvad-vpn.install
index 0b29ddc28ea2..e276ecebd933 100644
--- a/mullvad-vpn.install
+++ b/mullvad-vpn.install
@@ -18,8 +18,9 @@ pre_install() {
post_install() {
chmod u+s "/usr/bin/mullvad-exclude"
- echo 'Enabling Mullvad VPN daemon...'
+ echo 'Starting & enabling Mullvad VPN daemon...'
systemctl enable --now mullvad-daemon
+ echo 'Enabling Mullvad early boot blocking service...'
systemctl enable mullvad-early-boot-blocking
}
@@ -28,13 +29,9 @@ pre_upgrade() {
}
post_upgrade() {
- echo 'Starting & enabling Mullvad VPN daemon...'
systemctl daemon-reload
- systemctl enable --now mullvad-daemon
- echo 'Enabling Mullvad early boot blocking service...'
- systemctl enable mullvad-early-boot-blocking
- chmod u+s "/usr/bin/mullvad-exclude"
+ post_install
}
pre_remove() {