summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-30 08:34:58 -0600
committerMark Wagie2021-06-30 08:34:58 -0600
commita66932f20202922dfbc8c2faa7ef8b766295cbd5 (patch)
treea11aafa515416cc6943a7e9dbd4e924d8d0818c1
parent37b761e65b1b37c4cf22d629bdf4ca3a8ec0c9cf (diff)
downloadaur-a66932f20202922dfbc8c2faa7ef8b766295cbd5.tar.gz
2021.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1dd1ae2e7418..16176f9b2b12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn-beta
pkgdesc = The Mullvad VPN client app for desktop (beta channel)
- pkgver = 2021.4.beta1
- pkgrel = 3
+ pkgver = 2021.4.stable
+ pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = mullvad-vpn-beta
depends = nss
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.4-beta1?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.4?signed
source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=3a236d50fd1ffb67cd3d29fbfc31393cdf03a224
source = mullvad-vpn.sh
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
diff --git a/PKGBUILD b/PKGBUILD
index bd306cb36b56..85d268614cd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn-beta
_pkgver=2021.4
-_channel=beta
-pkgver=${_pkgver}.${_channel}1
-pkgrel=3
+_channel=stable
+pkgver=${_pkgver}.${_channel}
+pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (beta channel)"
url="https://www.mullvad.net"
arch=('x86_64')
@@ -19,17 +19,20 @@ provides=("${pkgname%-beta}")
conflicts=("${pkgname%-beta}")
install="${pkgname%-beta}.install"
_commit=3a236d50fd1ffb67cd3d29fbfc31393cdf03a224
-source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}-${_channel}1?signed" # beta
-# "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}?signed" # stable
+source=(
+# "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}-${_channel}1?signed" # beta
+ "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}?signed" # stable
# "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit?signed" # unverified commit by mvd-ows
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit"
- "${pkgname%-beta}.sh")
+ "${pkgname%-beta}.sh"
+ )
sha256sums=('SKIP'
'SKIP'
'a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
-validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87')
+validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87'
# Linus Färnstrand (code signing key) <linus@mullvad.net>
-# '8339C7D2942EB854E3F27CE5AEE9DECFD582E984')
+# '8339C7D2942EB854E3F27CE5AEE9DECFD582E984'
+ )
# David Lönnhager (code signing) <david.l@mullvad.net>
_ensure_local_nvm() {