summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-09 18:18:33 -0600
committerMark Wagie2021-06-09 18:18:33 -0600
commitc58a526f6d4f7eb07a9dfb8e5bec3ae1b8b125aa (patch)
treef9a2fe5a688142f8fa5029b661f97203eb264f11
parenta69cb48b4fdf11e8c148ce23b1037ab6712be771 (diff)
downloadaur-c58a526f6d4f7eb07a9dfb8e5bec3ae1b8b125aa.tar.gz
2021.4-beta1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
-rw-r--r--mullvad-vpn.install2
3 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9c5b46609cf..f5313dc0743c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-beta
- pkgdesc = The Mullvad VPN client app for desktop (latest/beta release)
- pkgver = 2021.3.stable
+ pkgdesc = The Mullvad VPN client app for desktop (beta channel)
+ pkgver = 2021.4.beta1
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
@@ -11,7 +11,6 @@ pkgbase = mullvad-vpn-beta
makedepends = rust
makedepends = nodejs>=12
makedepends = npm>=6.12
- makedepends = python
makedepends = nvm
depends = iputils
depends = libnotify
@@ -19,11 +18,10 @@ pkgbase = mullvad-vpn-beta
depends = nss
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.3?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=2063422c167c874eceab10692d4385a0c40b3f47?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.4-beta1?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=3a236d50fd1ffb67cd3d29fbfc31393cdf03a224
source = mullvad-vpn.sh
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
- validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
sha256sums = SKIP
sha256sums = SKIP
sha256sums = a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4
diff --git a/PKGBUILD b/PKGBUILD
index aa89e40258ad..0071164e7dbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,29 +5,31 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn-beta
-_pkgver=2021.3
-_channel=stable
-pkgver=${_pkgver}.${_channel}
+_pkgver=2021.4
+_channel=beta
+pkgver=${_pkgver}.${_channel}1
pkgrel=1
-pkgdesc="The Mullvad VPN client app for desktop (latest/beta release)"
+pkgdesc="The Mullvad VPN client app for desktop (beta channel)"
url="https://www.mullvad.net"
arch=('x86_64')
license=('GPL3')
depends=('iputils' 'libnotify' 'libappindicator-gtk3' 'nss')
-makedepends=('git' 'go' 'rust' 'nodejs>=12' 'npm>=6.12' 'python' 'nvm')
+makedepends=('git' 'go' 'rust' 'nodejs>=12' 'npm>=6.12' 'nvm')
provides=("${pkgname%-beta}")
conflicts=("${pkgname%-beta}")
install="${pkgname%-beta}.install"
-_commit='2063422c167c874eceab10692d4385a0c40b3f47'
-source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}?signed"
- "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit?signed"
+_commit=3a236d50fd1ffb67cd3d29fbfc31393cdf03a224
+source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}-${_channel}1?signed" # beta
+# "git+https://github.com/mullvad/mullvadvpn-app.git#tag=${_pkgver}?signed" # stable
+# "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit?signed" # unverified commit by mvd-ows
+ "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit"
"${pkgname%-beta}.sh")
sha256sums=('SKIP'
'SKIP'
'a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
-validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87'
+validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87')
# Linus Färnstrand (code signing key) <linus at mullvad dot net>
- '8339C7D2942EB854E3F27CE5AEE9DECFD582E984')
+# '8339C7D2942EB854E3F27CE5AEE9DECFD582E984')
# David Lönnhager (code signing) <david dot l at mullvad dot net>
_ensure_local_nvm() {
@@ -73,7 +75,7 @@ build() {
local RUSTC_VERSION=$(rustc --version)
local PRODUCT_VERSION=$(node -p "require('./gui/package.json').version" | \
sed -Ee 's/\.0//g')
- source env.sh
+ source env.sh ""
echo "Building Mullvad VPN $PRODUCT_VERSION..."
@@ -82,14 +84,14 @@ build() {
echo "Building wireguard-go..."
pushd wireguard/libwg
- mkdir -p "../../build/lib/$arch-unknown-linux-gnu"
+ mkdir -p "../../build/lib/$CARCH-unknown-linux-gnu"
export GOPATH="$srcdir/gopath"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -v -o "../../build/lib/$arch-unknown-linux-gnu"/libwg.a -buildmode c-archive
+ go build -v -o "../../build/lib/$CARCH-unknown-linux-gnu"/libwg.a -buildmode c-archive
popd
# Clean mod cache for makepkg -C
diff --git a/mullvad-vpn.install b/mullvad-vpn.install
index 9926fc9b399c..83aa74c47467 100644
--- a/mullvad-vpn.install
+++ b/mullvad-vpn.install
@@ -3,6 +3,8 @@ pre_install() {
echo 'Stopping & disabling Mullvad VPN daemon...'
/opt/Mullvad\ VPN/resources/mullvad-setup prepare-restart || true
systemctl disable --now mullvad-daemon
+ cp /var/log/mullvad-vpn/daemon.log /var/log/mullvad-vpn/old-install-daemon.log \
+ || echo "Failed to copy old daemon log"
fi
pkill -x "mullvad-gui" || true