summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-10-14 11:47:00 -0600
committerMark Wagie2022-10-14 11:47:00 -0600
commitd0a2213e64c690e408d5b79769c4f79372678b76 (patch)
tree6714de53759c46946f7177016e544fa626186a06
parentf9b4b83683593358908976554006048192ddf556 (diff)
downloadaur-d0a2213e64c690e408d5b79769c4f79372678b76.tar.gz
2022.5
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--mullvad-vpn.install18
3 files changed, 36 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f8a4cdda4cb..5c449c6afff2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = mullvad-vpn-bin
pkgdesc = The Mullvad VPN client app for desktop
- pkgver = 2022.4
+ pkgver = 2022.5
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
+ arch = aarch64
license = GPL3
depends = iputils
depends = libnotify
@@ -12,12 +13,16 @@ pkgbase = mullvad-vpn-bin
depends = nss
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.4/MullvadVPN-2022.4_amd64.deb
- source = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.4/MullvadVPN-2022.4_amd64.deb.asc
source = mullvad-vpn.sh
validpgpkeys = A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF
- sha256sums = 3b04ed5b39598c734548de7f5231496dcacf0aff7eb9c59810bda27588dea335
- sha256sums = SKIP
sha256sums = a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4
+ source_x86_64 = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.5/MullvadVPN-2022.5_amd64.deb
+ source_x86_64 = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.5/MullvadVPN-2022.5_amd64.deb.asc
+ sha256sums_x86_64 = 1b707891bfae82e918b42547dc71c8e37bb79fd1b4757e96c98500dd7fec67ea
+ sha256sums_x86_64 = SKIP
+ source_aarch64 = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.5/MullvadVPN-2022.5_arm64.deb
+ source_aarch64 = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.5/MullvadVPN-2022.5_arm64.deb.asc
+ sha256sums_aarch64 = 6c37a787b394f517d4e9b38ccb419304c33d28e7e2a97c658a03553cb70d1370
+ sha256sums_aarch64 = SKIP
pkgname = mullvad-vpn-bin
diff --git a/PKGBUILD b/PKGBUILD
index 12709fdf8ba5..e06dbe545116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,34 @@
# Contributor: Matthew McGinn <mamcgi at gmail dot com>
# Contributor: alicewww <almw at protonmail dot com>
pkgname=mullvad-vpn-bin
-pkgver=2022.4
+pkgver=2022.5
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://www.mullvad.net"
license=('GPL3')
depends=('iputils' 'libnotify' 'libappindicator-gtk3' 'nss')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install="${pkgname%-*}.install"
-source=("https://github.com/mullvad/mullvadvpn-app/releases/download/$pkgver/MullvadVPN-${pkgver}_amd64.deb"{,.asc}
- "${pkgname%-*}.sh")
-sha256sums=('3b04ed5b39598c734548de7f5231496dcacf0aff7eb9c59810bda27588dea335'
- 'SKIP'
- 'a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
+source=("${pkgname%-*}.sh")
+source_x86_64=("https://github.com/mullvad/mullvadvpn-app/releases/download/$pkgver/MullvadVPN-${pkgver}_amd64.deb"{,.asc})
+source_aarch64=("https://github.com/mullvad/mullvadvpn-app/releases/download/$pkgver/MullvadVPN-${pkgver}_arm64.deb"{,.asc})
+sha256sums=('a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
+sha256sums_x86_64=('1b707891bfae82e918b42547dc71c8e37bb79fd1b4757e96c98500dd7fec67ea'
+ 'SKIP')
+sha256sums_aarch64=('6c37a787b394f517d4e9b38ccb419304c33d28e7e2a97c658a03553cb70d1370'
+ 'SKIP')
validpgpkeys=('A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF') # Mullvad (code signing) <admin@mullvad.net>
package() {
- bsdtar -xvf data.tar.xz -C "$pkgdir"
+ bsdtar -xvf data.tar.xz -C "$pkgdir/"
+ chmod 4755 "$pkgdir/opt/Mullvad VPN/chrome-sandbox"
# Link to the GUI binary
install -m755 "$srcdir/${pkgname%-*}.sh" "$pkgdir/usr/bin/${pkgname%-*}"
- # Symlink daemon service to correct directory
- install -d "$pkgdir/usr/lib/systemd/system"
- ln -s "/opt/Mullvad VPN/resources/mullvad-daemon.service" \
- "$pkgdir/usr/lib/systemd/system"
-
# Move ZSH completions to correct directory
- mv "$pkgdir/usr/local/share/zsh" "$pkgdir/usr/share"
+ mv "$pkgdir/usr/local/share/zsh" "$pkgdir/usr/share/"
rm -rf "$pkgdir/usr/local"
}
diff --git a/mullvad-vpn.install b/mullvad-vpn.install
index a03c95fc1574..0b29ddc28ea2 100644
--- a/mullvad-vpn.install
+++ b/mullvad-vpn.install
@@ -3,6 +3,8 @@ pre_install() {
echo 'Stopping & disabling Mullvad VPN daemon...'
/opt/Mullvad\ VPN/resources/mullvad-setup prepare-restart || true
systemctl disable --now mullvad-daemon
+ echo 'Disabling Mullvad early boot blocking service...'
+ systemctl disable mullvad-early-boot-blocking.service || true
cp /var/log/mullvad-vpn/daemon.log /var/log/mullvad-vpn/old-install-daemon.log \
|| echo "Failed to copy old daemon log"
fi
@@ -18,6 +20,7 @@ post_install() {
echo 'Enabling Mullvad VPN daemon...'
systemctl enable --now mullvad-daemon
+ systemctl enable mullvad-early-boot-blocking
}
pre_upgrade() {
@@ -28,17 +31,22 @@ post_upgrade() {
echo 'Starting & enabling Mullvad VPN daemon...'
systemctl daemon-reload
systemctl enable --now mullvad-daemon
+ echo 'Enabling Mullvad early boot blocking service...'
+ systemctl enable mullvad-early-boot-blocking
chmod u+s "/usr/bin/mullvad-exclude"
}
pre_remove() {
- # the user might've disabled or stopped the service themselves already
- echo 'Making sure the Mullvad VPN daemon is stopped & disabled...'
- systemctl stop mullvad-daemon || true
- systemctl disable mullvad-daemon || true
+ # SIGTERM for some reason causes the app to crash sometimes and SIGINT works as expected.
+ pkill -2 -x "mullvad-gui" || true
+ sleep 0.5
+ pkill -9 -x "mullvad-gui" || true
- pkill -x "mullvad-gui" || true
+ # the user might've disabled or stopped the services themselves already
+ echo 'Making sure the services are stopped & disabled...'
+ systemctl disable --now mullvad-daemon || true
+ systemctl disable --now mullvad-early-boot-blocking.service || true
/opt/Mullvad\ VPN/resources/mullvad-setup reset-firewall || echo "Failed to reset firewall"
/opt/Mullvad\ VPN/resources/mullvad-setup remove-device || echo "Failed to remove device from account"