summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-30 08:39:28 -0600
committerMark Wagie2021-06-30 08:39:28 -0600
commitdafa9a37900993ed902f9bf1a435ef39078a82cf (patch)
treea1445c9b67bae97af85db2091345bddf1dd97172
parentdaf5cc43aed1942d5ad435fb612b68d2d581c636 (diff)
downloadaur-dafa9a37900993ed902f9bf1a435ef39078a82cf.tar.gz
2021.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8808a08a8614..f920aa203d57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-bin
pkgdesc = The Mullvad VPN client app for desktop
- pkgver = 2021.3
+ pkgver = 2021.4
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
@@ -12,13 +12,12 @@ pkgbase = mullvad-vpn-bin
depends = nss
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = https://github.com/mullvad/mullvadvpn-app/releases/download/2021.3/MullvadVPN-2021.3_amd64.deb
- source = https://github.com/mullvad/mullvadvpn-app/releases/download/2021.3/MullvadVPN-2021.3_amd64.deb.asc
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2021.4/MullvadVPN-2021.4_amd64.deb
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2021.4/MullvadVPN-2021.4_amd64.deb.asc
source = mullvad-vpn.sh
validpgpkeys = A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF
- sha256sums = 7fb6420d9fd137e6744b39a7c7c99bce12998913e3a974ec80295f595885633a
+ sha256sums = 2671c6e2a0fa9c7da5ed10981e66fb52cce7d26accb05b4c1d0ddc2a95dcab4d
sha256sums = SKIP
sha256sums = a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4
pkgname = mullvad-vpn-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index ce6ad613b7b9..91e1d9646b60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Matthew McGinn <mamcgi at gmail dot com>
# Contributor: alicewww <almw at protonmail dot com>
pkgname=mullvad-vpn-bin
-pkgver=2021.3
+pkgver=2021.4
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop"
url="https://www.mullvad.net"
@@ -14,7 +14,7 @@ conflicts=("${pkgname%-bin}")
install="${pkgname%-bin}.install"
source=("https://github.com/mullvad/mullvadvpn-app/releases/download/$pkgver/MullvadVPN-${pkgver}_amd64.deb"{,.asc}
"${pkgname%-bin}.sh")
-sha256sums=('7fb6420d9fd137e6744b39a7c7c99bce12998913e3a974ec80295f595885633a'
+sha256sums=('2671c6e2a0fa9c7da5ed10981e66fb52cce7d26accb05b4c1d0ddc2a95dcab4d'
'SKIP'
'a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
validpgpkeys=('A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF') # Mullvad (code signing) <admin at mullvad dot net>
@@ -25,10 +25,12 @@ package() {
# Link to the GUI binary
install -m755 "$srcdir/${pkgname%-bin}.sh" "$pkgdir/usr/bin/${pkgname%-bin}"
- # Install daemon service
- install -Dm644 "$pkgdir/opt/Mullvad VPN/resources/mullvad-daemon.service" \
- "$pkgdir/usr/lib/systemd/system/mullvad-daemon.service"
+ # Symlink daemon service to correct directory
+ install -d "$pkgdir/usr/lib/systemd/system"
+ ln -s "/opt/Mullvad VPN/resources/mullvad-daemon.service" \
+ "$pkgdir/usr/lib/systemd/system"
+ # Move ZSH completions to correct directory
mv "$pkgdir/usr/local/share/zsh" "$pkgdir/usr/share"
rm -rf "$pkgdir/usr/local"
}