summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-10-13 17:44:49 -0600
committerMark Wagie2022-10-13 17:44:49 -0600
commit0a5f1e7ce9aca770010b714f11f9a6145db0fb71 (patch)
tree78b9c5cb1281716a45e72bece4fd2fcf78bb1f17
parent941ada6864ec024912428f41a9b2ab6b77fbe3ab (diff)
downloadaur-0a5f1e7ce9aca770010b714f11f9a6145db0fb71.tar.gz
numerous fixes and improvements
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD53
-rw-r--r--mullvad-vpn.install6
3 files changed, 25 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6628daf06e24..808621ea2636 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN CLI client
pkgver = 2022.4
- pkgrel = 1
+ pkgrel = 2
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
@@ -16,12 +16,10 @@ pkgbase = mullvad-vpn-cli
options = !lto
source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=06c847a7a7d72a148bd5dba0a44860eb1b3aa182?signed
source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec?signed
- source = override.conf
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
validpgpkeys = 4B986EF5222BA1B810230C602F391DE6B00D619C
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = ed978958f86da9acbce950a832491b140a350c594e2446b99a7c397a98731316
pkgname = mullvad-vpn-cli
diff --git a/PKGBUILD b/PKGBUILD
index 9840648da3a4..74b238327841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
pkgver=2022.4
-pkgrel=1
+pkgrel=2
pkgdesc="The Mullvad VPN CLI client"
arch=('x86_64')
url="https://www.mullvad.net"
@@ -17,11 +17,9 @@ install="${pkgname%-*}.install"
_tag=06c847a7a7d72a148bd5dba0a44860eb1b3aa182 # tags/2022.4^0
_commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
- "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
- 'override.conf')
+ "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed")
sha256sums=('SKIP'
- 'SKIP'
- 'ed978958f86da9acbce950a832491b140a350c594e2446b99a7c397a98731316')
+ 'SKIP')
validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87' # Linus Färnstrand (code signing key) <linus@mullvad.net>
'8339C7D2942EB854E3F27CE5AEE9DECFD582E984' # David Lönnhager (code signing) <david.l@mullvad.net>
'4B986EF5222BA1B810230C602F391DE6B00D619C' # Oskar Nyberg (code signing) <oskar@mullvad.net>
@@ -88,19 +86,6 @@ build() {
dist-assets/shell-completions/
done
- echo "Copying binaries"
- binaries=(
- mullvad-daemon
- mullvad
- mullvad-problem-report
- libtalpid_openvpn_plugin.so
- mullvad-setup
- mullvad-exclude
- )
- for binary in ${binaries[*]}; do
- cp target/release/${binary} dist-assets/${binary}
- done
-
echo "Updating relay list..."
cargo run --bin relay_list --frozen --release > dist-assets/relays.json
}
@@ -108,22 +93,30 @@ build() {
package() {
cd "$srcdir/mullvadvpn-app"
- # Install main files
- install -d "$pkgdir/opt/$pkgname"
- cp -r dist-assets/* "$pkgdir/opt/$pkgname/"
+ # Install binaries
+ install -Dm755 target/release/mullvad{-daemon,-problem-report,-setup} -t \
+ "$pkgdir/opt/Mullvad VPN/resources/"
- # Symlink daemon service to correct directory
- install -d "$pkgdir/usr/lib/systemd/system"
- ln -s "/opt/$pkgname/linux/mullvad-daemon.service" \
- "$pkgdir/usr/lib/systemd/system/"
+ install -Dm755 target/release/{mullvad,mullvad-exclude} -t \
+ "$pkgdir/usr/bin/"
- # Install binaries
- install -Dm755 dist-assets/{mullvad,mullvad-exclude} -t "$pkgdir/usr/bin/"
+ install -m644 target/release/libtalpid_openvpn_plugin.so -t \
+ "$pkgdir/opt/Mullvad VPN/resources/"
+
+ install -m755 "dist-assets/binaries/$CARCH-unknown-linux-gnu/openvpn" -t \
+ "$pkgdir/opt/Mullvad VPN/resources/"
# Link to the problem report binary
- ln -s "/opt/$pkgname/resources/mullvad-problem-report" \
+ ln -s "/opt/Mullvad VPN/resources/mullvad-problem-report" \
"$pkgdir/usr/bin/mullvad-problem-report"
+ # Install relay list
+ install -Dm644 dist-assets/relays.json -t "$pkgdir/opt/Mullvad VPN/resources/"
+
+ # Install service
+ install -Dm644 dist-assets/linux/mullvad-daemon.service -t \
+ "$pkgdir/usr/lib/systemd/system/"
+
# Install completions
install -Dm644 dist-assets/shell-completions/mullvad.bash \
"$pkgdir/usr/share/bash-completion/completions/mullvad"
@@ -131,8 +124,4 @@ package() {
"$pkgdir/usr/share/zsh/site-functions/"
install -Dm644 dist-assets/shell-completions/mullvad.fish -t \
"$pkgdir/usr/share/fish/vendor_completions.d/"
-
- # Install override for daemon
- install -Dm644 "$srcdir/override.conf" -t \
- "$pkgdir/etc/systemd/system/mullvad-daemon.service.d/"
}
diff --git a/mullvad-vpn.install b/mullvad-vpn.install
index 669472777c59..2f602f6df88c 100644
--- a/mullvad-vpn.install
+++ b/mullvad-vpn.install
@@ -1,7 +1,7 @@
pre_install() {
if systemctl status mullvad-daemon &> /dev/null; then
echo 'Stopping & disabling Mullvad VPN daemon...'
- /opt/mullvad-cli/resources/mullvad-setup prepare-restart || true
+ /opt/Mullvad VPN/resources/mullvad-setup prepare-restart || true
systemctl disable --now mullvad-daemon
cp /var/log/mullvad-vpn/daemon.log /var/log/mullvad-vpn/old-install-daemon.log \
|| echo "Failed to copy old daemon log"
@@ -36,8 +36,8 @@ pre_remove() {
systemctl stop mullvad-daemon || true
systemctl disable mullvad-daemon || true
- /opt/mullvad-cli/resources/mullvad-setup reset-firewall || echo "Failed to reset firewall"
- /opt/mullvad-cli/resources/mullvad-setup remove-device || echo "Failed to remove device from account"
+ /opt/Mullvad VPN/resources/mullvad-setup reset-firewall || echo "Failed to reset firewall"
+ /opt/Mullvad VPN/resources/mullvad-setup remove-device || echo "Failed to remove device from account"
}
post_remove() {