summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-08-10 13:54:02 -0600
committerMark Wagie2022-08-10 13:54:02 -0600
commit17229a35b58947d1eb876ebb8b6787c71ed6336d (patch)
tree950a8a0aab92bf1970d7c67cb509e4bce2a097e6
parent5eb4131f77331ff1b2d461626ae105c2c8ac3332 (diff)
downloadaur-17229a35b58947d1eb876ebb8b6787c71ed6336d.tar.gz
2022.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--mullvad-vpn.install12
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bc4b91bff4a..137ff8146717 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN CLI client
- pkgver = 2022.2
+ pkgver = 2022.3
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
@@ -14,7 +14,7 @@ pkgbase = mullvad-vpn-cli
provides = mullvad-vpn
conflicts = mullvad-vpn
options = !lto
- source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=a66504d6b8cc708a1da4b4e6b40fbe51e9dde4d2?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=ca45335dba9f8b2b90263c3b6c08e64c6898f35f?signed
source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec?signed
source = override.conf
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
diff --git a/PKGBUILD b/PKGBUILD
index ea08ddac7f95..d6a4ff7d1cb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: John Andrews <theunderdog09 at gmail dot com>
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2022.2
+pkgver=2022.3
pkgrel=1
pkgdesc="The Mullvad VPN CLI client"
arch=('x86_64')
@@ -14,7 +14,7 @@ provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
options=('!lto')
install="${pkgname%-*}.install"
-_tag=a66504d6b8cc708a1da4b4e6b40fbe51e9dde4d2 # tags/2022.2^0
+_tag=ca45335dba9f8b2b90263c3b6c08e64c6898f35f # tags/2022.3^0
_commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
diff --git a/mullvad-vpn.install b/mullvad-vpn.install
index c3c183b30369..669472777c59 100644
--- a/mullvad-vpn.install
+++ b/mullvad-vpn.install
@@ -1,11 +1,14 @@
pre_install() {
if systemctl status mullvad-daemon &> /dev/null; then
echo 'Stopping & disabling Mullvad VPN daemon...'
- /opt/mullvad-vpn-cli/resources/mullvad-setup prepare-restart || true
+ /opt/mullvad-cli/resources/mullvad-setup prepare-restart || true
systemctl disable --now mullvad-daemon
+ cp /var/log/mullvad-vpn/daemon.log /var/log/mullvad-vpn/old-install-daemon.log \
+ || echo "Failed to copy old daemon log"
fi
- rm -f /var/cache/mullvad-vpn/relays.json || true
+ rm -f /var/cache/mullvad-vpn/relays.json
+ rm -f /var/cache/mullvad-vpn/api-ip-address.txt
}
post_install() {
@@ -28,14 +31,13 @@ post_upgrade() {
}
pre_remove() {
- /usr/bin/mullvad account clear-history || echo "Failed to remove leftover WireGuard keys"
-
# the user might've disabled or stopped the service themselves already
echo 'Making sure the Mullvad VPN daemon is stopped & disabled...'
systemctl stop mullvad-daemon || true
systemctl disable mullvad-daemon || true
- /opt/mullvad-vpn-cli/resources/mullvad-setup reset-firewall || true
+ /opt/mullvad-cli/resources/mullvad-setup reset-firewall || echo "Failed to reset firewall"
+ /opt/mullvad-cli/resources/mullvad-setup remove-device || echo "Failed to remove device from account"
}
post_remove() {