summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Kramer2020-02-12 00:31:59 +0100
committerTimo Kramer2020-02-12 00:32:08 +0100
commit9bdc13b761630a861e4c692f060bad133df03f53 (patch)
tree6848715eeaaac4344265d0d368d5ffdd30f0777e
parent3321fa60218b9c502ac9c3eea03acd29aee9478f (diff)
downloadaur-9bdc13b761630a861e4c692f060bad133df03f53.tar.gz
updated to 2020.1
The wireguard lib is not part of the binaries anymore and has to be built by hand. It is part of the build.sh so I copied it from there. There is a new pgp-key needed to verify the binaries-commit, that is now part of the PKGBUILD.
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
-rw-r--r--README.md6
4 files changed, 31 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7a04641fc11..16f9d0d89698 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN client cli
- pkgver = 2019.10
+ pkgver = 2020.1
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn-cli.install
@@ -10,11 +10,12 @@ pkgbase = mullvad-vpn-cli
makedepends = cargo
depends = nss
conflicts = mullvad-vpn
- source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2019.10?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=0c1a0aca41492fbb9ef1f187122e2f5bda0927ba?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2020.1?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=90b0c06b59a0b9d6cda69924377335f39854b216?signed
source = override.conf
source = settings.json.sample
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
+ validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
sha256sums = SKIP
sha256sums = SKIP
sha256sums = ed978958f86da9acbce950a832491b140a350c594e2446b99a7c397a98731316
diff --git a/.gitignore b/.gitignore
index f96ffbbce799..d8203fdd3d28 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,9 @@
-mullvad-vpn-2019.10-1-x86_64.pkg.tar.xz
mullvadvpn-app-binaries/
mullvadvpn-app/
pkg/
src/
*.pkg.tar.xz
+.BUILDINFO
+.INSTALL
+.MTREE
+.PKGINFO
diff --git a/PKGBUILD b/PKGBUILD
index 42799729794e..527fa3f0e4b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2019.10
+pkgver=2020.1
pkgrel=1
pkgdesc="The Mullvad VPN client cli"
url="https://www.mullvad.net"
@@ -10,8 +10,8 @@ license=('GPL3')
depends=('nss')
makedepends=('git' 'cargo')
conflicts=('mullvad-vpn')
-install="$pkgname.install"
-_commit='0c1a0aca41492fbb9ef1f187122e2f5bda0927ba'
+install="${pkgname}.install"
+_commit='90b0c06b59a0b9d6cda69924377335f39854b216'
source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=${pkgver}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
'override.conf'
@@ -20,8 +20,10 @@ sha256sums=('SKIP'
'SKIP'
'ed978958f86da9acbce950a832491b140a350c594e2446b99a7c397a98731316'
'2729b6842bff30eb3dae23a2133054ab1cfe9312a4fc9baa8433a81e9bafd362')
-validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87')
+validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87'
# Linus Färnstrand (code signing key) <linus at mullvad dot net>
+ '8339C7D2942EB854E3F27CE5AEE9DECFD582E984')
+ # David Lönnhager (code signing) <david dot l at mullvad dot net>
prepare() {
# Point the submodule to our local copy
@@ -35,6 +37,9 @@ prepare() {
build() {
cd "${srcdir}/mullvadvpn-app"
+ # Build wireguard-go
+ ./wireguard/build-wireguard-go.sh
+
# Remove old Rust build artifacts
cargo clean --release --locked
@@ -42,11 +47,14 @@ build() {
cargo build --release --locked
# Copy binaries for packaging
- cp dist-assets/binaries/x86_64-unknown-linux-gnu/{openvpn,sslocal} \
- dist-assets/
- cp target/release/*talpid_openvpn_plugin* dist-assets/
- cp target/release/{mullvad,mullvad-daemon,mullvad-problem-report} \
- dist-assets/
+ cp dist-assets/binaries/x86_64-unknown-linux-gnu/{openvpn,sslocal} dist-assets/
+ binaries=(mullvad
+ mullvad-daemon
+ mullvad-problem-report
+ libtalpid_openvpn_plugin.so)
+ for binary in ${binaries[*]}; do
+ cp target/release/${binary} dist-assets/${binary}
+ done
}
check() {
@@ -59,7 +67,7 @@ package() {
# Install main files
install --verbose --directory --mode=755 "${pkgdir}/opt/mullvad-vpn-cli"
- cp -av dist-assets/* "${pkgdir}/opt/mullvad-vpn-cli"
+ cp -av dist-assets/* "${pkgdir}/opt/mullvad-vpn-cli"
# Install daemon service
install --verbose -D --mode=644 dist-assets/linux/mullvad-daemon.service -t \
diff --git a/README.md b/README.md
index bf2709144130..3ce8eaacd1ec 100644
--- a/README.md
+++ b/README.md
@@ -8,10 +8,14 @@ This repository is an alternative for people who want to avoid building and runn
- `gpg2 --keyserver pool.sks-keyservers.net --recv-keys EA0A77BF9E115615FC3BD8BC7653B940E494FE87`
- `gpg2 --edit-key EA0A77BF9E115615FC3BD8BC7653B940E494FE87`
+- `gpg2 --keyserver pool.sks-keyservers.net --recv-keys 8339C7D2942EB854E3F27CE5AEE9DECFD582E984`
+- `gpg2 --edit-key 8339C7D2942EB854E3F27CE5AEE9DECFD582E984`
+for each key do:
- in gpg console enter `trust`
- in gpg console enter `5`
- in gpg console enter `quit`
-- `makepkg`
+### build package
+- `makepkg --cleanbuild --clean --force`
- `pacman -U mullvad-vpn-....pkg.tar.xz`
## CLI Manual