summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Andrews2021-08-01 00:53:01 -0400
committerJohn Andrews2021-08-01 01:38:17 -0400
commitc3ac5f53f1706128ac9a3c8a9e4c21d369f30803 (patch)
tree8163d03c3f47820b06957d981bc43bf58361bcef
parenta426c4cd70a00a7eb46285b46b7390b73d5877ac (diff)
downloadaur-c3ac5f53f1706128ac9a3c8a9e4c21d369f30803.tar.gz
2021.4
Removed sample settings; the main mullvad-vpn package omits it, it's unneccessary for proper functionality, and keeping it up to date is a chore.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
-rw-r--r--mullvad-vpn-cli.install10
-rw-r--r--settings.json.sample53
4 files changed, 21 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2762d40badd..9917fb33ff92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN client cli
- pkgver = 2021.3
- pkgrel = 2
+ pkgver = 2021.4
+ pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn-cli.install
arch = x86_64
@@ -14,16 +14,13 @@ pkgbase = mullvad-vpn-cli
optdepends = networkmanager: create Wireguard interface
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.3?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=2063422c167c874eceab10692d4385a0c40b3f47?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.4?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=3a236d50fd1ffb67cd3d29fbfc31393cdf03a224
source = override.conf
- source = settings.json.sample
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
sha256sums = SKIP
sha256sums = SKIP
sha256sums = ed978958f86da9acbce950a832491b140a350c594e2446b99a7c397a98731316
- sha256sums = 448755ee76e7c150d6a091a003ed5ccbdefdcac3a13514ed88e35e9617383f40
pkgname = mullvad-vpn-cli
-
diff --git a/PKGBUILD b/PKGBUILD
index cca9be4eb7df..9cf5e9f4fa55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2021.3
-pkgrel=2
+pkgver=2021.4
+pkgrel=1
pkgdesc="The Mullvad VPN client cli"
url="https://www.mullvad.net"
arch=('x86_64')
@@ -14,15 +14,15 @@ optdepends=('networkmanager: create Wireguard interface')
conflicts=('mullvad-vpn')
provides=('mullvad-vpn')
install="${pkgname}.install"
-_commit='2063422c167c874eceab10692d4385a0c40b3f47'
+_commit='3a236d50fd1ffb67cd3d29fbfc31393cdf03a224'
source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=${pkgver}?signed"
- "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
+# "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed" # unverified commit by mvd-ows
+ "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}"
'override.conf'
- 'settings.json.sample')
+ )
sha256sums=('SKIP'
'SKIP'
- 'ed978958f86da9acbce950a832491b140a350c594e2446b99a7c397a98731316'
- '448755ee76e7c150d6a091a003ed5ccbdefdcac3a13514ed88e35e9617383f40')
+ 'ed978958f86da9acbce950a832491b140a350c594e2446b99a7c397a98731316')
validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87'
# Linus Färnstrand (code signing key) <linus at mullvad dot net>
'8339C7D2942EB854E3F27CE5AEE9DECFD582E984')
@@ -45,19 +45,19 @@ prepare() {
build() {
cd "$srcdir/mullvadvpn-app"
- source env.sh
+ source env.sh ""
echo "Building Mullvad VPN..."
echo "Building wireguard-go..."
pushd wireguard/libwg
- mkdir -p "../../build/lib/$arch-unknown-linux-gnu"
+ mkdir -p "../../build/lib/$CARCH-unknown-linux-gnu"
export GOPATH="$srcdir/gopath"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -v -o "../../build/lib/$arch-unknown-linux-gnu"/libwg.a -buildmode c-archive
+ go build -v -o "../../build/lib/$CARCH-unknown-linux-gnu"/libwg.a -buildmode c-archive
popd
# Clean mod cache for makepkg -C
@@ -106,8 +106,9 @@ package() {
install --verbose --directory --mode=755 "${pkgdir}/opt/mullvad-vpn-cli"
cp -rav dist-assets/* "${pkgdir}/opt/mullvad-vpn-cli"
- # Install daemon service
- install --verbose -D --mode=644 dist-assets/linux/mullvad-daemon.service -t \
+ # Symlink daemon service to correct directory
+ install --verbose -d "${pkgdir}/usr/lib/systemd/system"
+ ln -s "/opt/mullvad-vpn-cli/linux/mullvad-daemon.service" \
"${pkgdir}/usr/lib/systemd/system"
# Install override for daemon
@@ -132,9 +133,6 @@ package() {
install -Dm755 dist-assets/shell-completions/mullvad.fish -t \
"$pkgdir/usr/share/fish/vendor_completions.d"
- # Install settings.json
- install --verbose -D --mode=644 "${srcdir}/settings.json.sample" -t "${pkgdir}/etc/mullvad-vpn"
-
# Install license
install --verbose -D --mode=644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/mullvad-vpn-cli.install b/mullvad-vpn-cli.install
index 2df9ed3bfabf..9e18d553ed80 100644
--- a/mullvad-vpn-cli.install
+++ b/mullvad-vpn-cli.install
@@ -3,15 +3,11 @@ pre_install() {
echo 'Stopping & disabling Mullvad VPN daemon...'
systemctl disable --now mullvad-daemon
fi
+
+ rm -f /var/cache/mullvad-vpn/relays.json || true
}
post_install() {
- echo 'Copying sample settings...'
- if [[ ! -e /etc/mullvad-vpn/settings.json ]]; then
- cp -av /etc/mullvad-vpn/settings.json.sample \
- /etc/mullvad-vpn/settings.json
- echo 'Please edit /etc/mullvad-vpn/settings.json'
- fi
chmod u+s "/usr/bin/mullvad-exclude"
echo 'Enabling Mullvad VPN daemon...'
systemctl enable mullvad-daemon
@@ -27,6 +23,8 @@ post_install() {
pre_upgrade() {
echo 'Stopping Mullvad VPN daemon...'
systemctl stop mullvad-daemon
+
+ rm -f /var/cache/mullvad-vpn/relays.json || true
}
post_upgrade() {
diff --git a/settings.json.sample b/settings.json.sample
deleted file mode 100644
index f07e182694da..000000000000
--- a/settings.json.sample
+++ /dev/null
@@ -1,53 +0,0 @@
-{
- "account_token": "12345678901",
- "relay_settings": {
- "normal": {
- "location": {
- "only": {
- "city": [
- "us",
- "atl"
- ]
- }
- },
- "providers": "any",
- "tunnel_protocol": "any",
- "wireguard_constraints": {
- "port": "any",
- "ip_version": "any"
- },
- "openvpn_constraints": {
- "port": "any",
- "protocol": "any"
- }
- }
- },
- "bridge_settings": {
- "normal": {
- "location": "any",
- "providers": "any"
- }
- },
- "bridge_state": "auto",
- "allow_lan": true,
- "block_when_disconnected": false,
- "auto_connect": true,
- "tunnel_options": {
- "openvpn": {
- "mssfix": null
- },
- "wireguard": {
- "mtu": null,
- "rotation_interval": null
- },
- "generic": {
- "enable_ipv6": true
- },
- "dns_options": {
- "custom": false,
- "addresses": []
- }
- },
- "show_beta_releases": false,
- "settings_version": 3
-}