summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Andrews2021-04-28 19:56:01 -0400
committerJohn Andrews2021-04-28 19:56:01 -0400
commitfc9557dc339fb7f7ac8ed6fc78de63c884c6f1a3 (patch)
tree050ab0361b23429344c92a1662ea4fc752872905
parent17735af26521353eea16161ce40b2ce0c8a8d1b8 (diff)
downloadaur-fc9557dc339fb7f7ac8ed6fc78de63c884c6f1a3.tar.gz
2021.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
-rw-r--r--settings.json.sample17
3 files changed, 26 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2755b4c161d..3cf297f15502 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN client cli
- pkgver = 2021.2
+ pkgver = 2021.3
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn-cli.install
@@ -11,12 +11,11 @@ pkgbase = mullvad-vpn-cli
makedepends = go
depends = nss
depends = iputils
- depends = resolvconf
optdepends = networkmanager: create Wireguard interface
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.2?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=fa76f058d6f5fa66e62f9c4a291e6079cea22e37?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2021.3?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=2063422c167c874eceab10692d4385a0c40b3f47?signed
source = override.conf
source = settings.json.sample
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
diff --git a/PKGBUILD b/PKGBUILD
index 49a1839e979a..7041806fe96a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2021.2
+pkgver=2021.3
pkgrel=1
pkgdesc="The Mullvad VPN client cli"
url="https://www.mullvad.net"
arch=('x86_64')
license=('GPL3')
-depends=('nss' 'iputils' 'resolvconf')
+depends=('nss' 'iputils')
makedepends=('git' 'rust' 'go')
optdepends=('networkmanager: create Wireguard interface')
conflicts=('mullvad-vpn')
provides=('mullvad-vpn')
install="${pkgname}.install"
-_commit='fa76f058d6f5fa66e62f9c4a291e6079cea22e37'
+_commit='2063422c167c874eceab10692d4385a0c40b3f47'
source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=${pkgver}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
'override.conf'
@@ -36,8 +36,9 @@ prepare() {
git submodule update
echo "Removing old Rust build artifacts"
- cargo clean
+ cargo clean --target-dir=target
+ # Prevent creation of `go` directory in user's HOME.
export GOPATH="$srcdir/gopath"
go clean -modcache
}
@@ -67,13 +68,13 @@ build() {
echo "Building Rust code in release mode"
# Build mullvad-daemon
- cargo build --release --locked
+ cargo build --release --locked --target-dir=target
mkdir -p dist-assets/shell-completions
for sh in bash zsh fish; do
echo "Generating shell completion script for $sh..."
- cargo run --bin mullvad --release --locked -- shell-completions "$sh" \
- dist-assets/shell-completions/
+ cargo run --bin mullvad --release --locked --target-dir=target \
+ -- shell-completions "$sh" dist-assets/shell-completions/
done
echo "Copying binaries"
@@ -92,10 +93,10 @@ build() {
echo "Updating relay list..."
# Update relays.json
- cargo run --bin relay_list --release > dist-assets/relays.json
+ cargo run --bin relay_list --release --target-dir=target > dist-assets/relays.json
echo "Updating API address cache..."
- cargo run --bin address_cache --release > dist-assets/api-ip-address.txt
+ cargo run --bin address_cache --release --target-dir=target > dist-assets/api-ip-address.txt
}
package() {
diff --git a/settings.json.sample b/settings.json.sample
index 7aadd5c481cb..f07e182694da 100644
--- a/settings.json.sample
+++ b/settings.json.sample
@@ -10,9 +10,11 @@
]
}
},
+ "providers": "any",
"tunnel_protocol": "any",
"wireguard_constraints": {
- "port": "any"
+ "port": "any",
+ "ip_version": "any"
},
"openvpn_constraints": {
"port": "any",
@@ -22,7 +24,8 @@
},
"bridge_settings": {
"normal": {
- "location": "any"
+ "location": "any",
+ "providers": "any"
}
},
"bridge_state": "auto",
@@ -34,11 +37,17 @@
"mssfix": null
},
"wireguard": {
- "mtu": null
+ "mtu": null,
+ "rotation_interval": null
},
"generic": {
"enable_ipv6": true
+ },
+ "dns_options": {
+ "custom": false,
+ "addresses": []
}
},
- "settings_version": 2
+ "show_beta_releases": false,
+ "settings_version": 3
}