summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-06-27 19:31:07 +0200
committerLukáš Jirkovský2015-06-27 19:31:07 +0200
commitfd284094d5540e215c5c05ae5f2711006bffc2d1 (patch)
tree0d5328095861a19b095c6a718d82140d6f2cddab
downloadaur-fd284094d5540e215c5c05ae5f2711006bffc2d1.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa8cdc0c4323
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = multiblend
+ pkgdesc = Image blender for the seamless blending of panoramic images similar to enblend
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = http://horman.net/multiblend/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libtiff
+ source = http://horman.net/multiblend/multiblend0.6.2.tar.gz
+ md5sums = 3a2afe6aa55d6ee155029605dbc41751
+
+pkgname = multiblend
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eee452b59177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=multiblend
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="Image blender for the seamless blending of panoramic images similar to enblend"
+arch=('i686' 'x86_64')
+url="http://horman.net/multiblend/"
+license=('GPL')
+depends=('libjpeg-turbo' 'libpng' 'libtiff')
+source=("http://horman.net/multiblend/multiblend${pkgver}.tar.gz")
+md5sums=('3a2afe6aa55d6ee155029605dbc41751')
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ # note: SSE2 must be enabled in order to compile (needed especially on i686)
+ gcc $CXXFLAGS -msse2 -ltiff -ltiffxx -ljpeg -lpng $LDFLAGS multiblend.cpp -o $pkgname
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -D -m755 $pkgname "$pkgdir/usr/bin/$pkgname"
+}