summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892020-07-30 23:06:52 +0200
committerPhoton892020-07-30 23:06:52 +0200
commitaa99900220c2e7b84400f7120ec3e97ad578bf8c (patch)
treed3b91c20c46e106fb317ea87d3a61b6a6abfbff8
parentc183b2beb1e66df9619be5822f0d5144048e6f27 (diff)
downloadaur-aa99900220c2e7b84400f7120ec3e97ad578bf8c.tar.gz
Silent update: Added patch to fix build errors
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--build-fix.patch24
3 files changed, 30 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec82fd937d0b..aa3b58031362 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,9 @@ pkgbase = multiload-ng-indicator-gtk2
conflicts = multiload-ng-indicator-gtk2-git
conflicts = multiload-ng-indicator-gtk3-git
source = https://github.com/udda/multiload-ng/archive/v1.5.2.tar.gz
+ source = build-fix.patch
md5sums = bdb9344d696324bd4db04a8bce6d7ec0
+ md5sums = b474387e4532bdd6a639f721a51d2587
pkgname = multiload-ng-indicator-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index 2627a5615ae0..354f0e0b124f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,9 @@ depends=('gtk2>=2.20.0' 'cairo' 'libappindicator-gtk2>=0.4.92' 'multiload-ng-com
conflicts=('multiload-ng-indicator-gtk3' 'multiload-ng-indicator-gtk2-git' 'multiload-ng-indicator-gtk3-git')
-source=("https://github.com/udda/multiload-ng/archive/v$pkgver.tar.gz")
-md5sums=('bdb9344d696324bd4db04a8bce6d7ec0')
+source=("https://github.com/udda/multiload-ng/archive/v$pkgver.tar.gz" "build-fix.patch")
+md5sums=('bdb9344d696324bd4db04a8bce6d7ec0'
+'b474387e4532bdd6a639f721a51d2587')
arch=('i686' 'x86_64')
url='https://udda.github.io/multiload-ng/'
@@ -22,6 +23,7 @@ license=('GPL2')
build() {
cd "multiload-ng-$pkgver"
+ patch -p1 -i $srcdir/build-fix.patch
./autogen.sh
./configure --prefix=/usr --with-gtk=2.0 --without-awn --with-indicator --without-lxpanel --without-mate --without-standalone --without-systray --without-xfce4
make
diff --git a/build-fix.patch b/build-fix.patch
new file mode 100644
index 000000000000..6e7f125bad49
--- /dev/null
+++ b/build-fix.patch
@@ -0,0 +1,24 @@
+diff -Naur a/common/multiload-config.c b/common/multiload-config.c
+--- a/common/multiload-config.c 2016-12-05 17:13:59.000000000 +0100
++++ b/common/multiload-config.c 2020-07-30 21:18:03.568945194 +0200
+@@ -26,6 +26,8 @@
+ #include "graph-data.h"
+ #include "multiload-config.h"
+
++GraphType graph_types[GRAPH_MAX];
++
+ guint multiload_config_get_num_colors(guint id)
+ {
+ g_assert_cmpuint (graph_types[id].num_colors, <=, MAX_COLORS);
+diff -Naur a/common/multiload-config.h b/common/multiload-config.h
+--- a/common/multiload-config.h 2016-12-05 17:13:59.000000000 +0100
++++ b/common/multiload-config.h 2020-07-30 21:18:21.685273529 +0200
+@@ -56,7 +56,7 @@
+
+
+ // global variable
+-GraphType graph_types[GRAPH_MAX];
++extern GraphType graph_types[GRAPH_MAX];
+
+
+ G_GNUC_INTERNAL guint