summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaylor Smock2016-01-21 15:16:57 -0700
committerTaylor Smock2016-01-21 15:16:57 -0700
commit93a68ebd1014a46ad42b038bdcb31810a8eefe1c (patch)
tree54cdcce76a9a7f6e22418f8c0871eb0c36a9128d
parent2b85fa7c22d39e082c23fd9457668705a4f47938 (diff)
downloadaur-93a68ebd1014a46ad42b038bdcb31810a8eefe1c.tar.gz
Updated to MultiMC5 0.4.9
* Fixed wireless connections (GH-1408) * World Management (GH-1047, GH-1233) * Track time spent in instance (GH-1217) * Supports Java 9 (GH-1365) * LD_PRELOAD/LD_LIBRARY_PATH affect game, not MultiMC * MMC_{PRELOAD,LIBRARY_PATH} replace LD_...
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD42
2 files changed, 37 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0da7e84fd61c..37e593f43e24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 22:16:49 UTC 2016
pkgbase = multimc5
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 0.4.7
- pkgrel = 4
+ pkgver = 0.4.9
+ pkgrel = 1
url = http://multimc.org/
arch = i686
arch = x86_64
@@ -11,16 +13,18 @@ pkgbase = multimc5
makedepends = qt5-tools
makedepends = qt5-x11extras
makedepends = java-environment
- depends = qt5-base
- depends = qt5-x11extras
- depends = java-runtime
+ makedepends = zlib
depends = qt5-svg
+ depends = java-environment
+ depends = xdg-utils
optdepends = mcedit: Allows editing of minecraft worlds
conflicts = multimc5-git
- source = https://github.com/MultiMC/MultiMC5/archive/0.4.7.tar.gz
+ source = https://github.com/MultiMC/MultiMC5/archive/0.4.9.tar.gz
+ source = https://github.com/MultiMC/libnbtplusplus/archive/v2.3.1-alpha.tar.gz
source = multimc5.sh
source = multimc5.desktop
- sha512sums = 237b566ee6b7e6ba0800790f0ec25e3e2fd6037688fd5b3105d8f3dfe880c3d0eeb5d08969b222b45cf815e8c616aef0bc955a4ac12bf65138a88f004ea2175f
+ sha512sums = 0b5fc69c22f0cd762d6c4225078af1e38b00b583a9c231cc680a724394c88624b4d5602573090036ff1198bc656356aaad2f94d0f76c5cbe8f985cf8ba155cde
+ sha512sums = 5e7a85275b7452ce1f507273e1ee264df8ba6536c431df8d223f2512b4823417f9699c1403108468c066c0f7f9bd359bce27cd3a33f35726fb6ba1a2d9b8e4de
sha512sums = 6eb9476c8350fb8055238afc4d62f89897ea6d255a13edde88b76a67d021d88266d86236ef9ea9ebe82729b92cb7d8a9a66114de7c6b31666a82654dfe672049
sha512sums = a6712d0e84acc719ed1aff740717add44202f88cb42a0b7a3157108b73a1009ac7edd325f75d372e0a63617f40eb614d55fb4e24e5c1fb8957cd280486070675
diff --git a/PKGBUILD b/PKGBUILD
index 1231073acdfb..3b367bfa8edb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,52 @@
# Contributor: b.klettbach@gmail.com
pkgname=multimc5
-pkgver=0.4.7
-pkgrel=4
+pkgver=0.4.9
+__pkgver_libnbtplusplus=2.3.1-alpha
+pkgrel=1
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64')
url="http://multimc.org/"
license=('Apache')
-depends=('qt5-base' 'qt5-x11extras' 'java-runtime' 'qt5-svg')
-makedepends=('git' 'cmake' 'qt5-tools' 'qt5-x11extras' 'java-environment')
+depends=('qt5-svg' 'java-environment' 'xdg-utils')
+makedepends=('git' 'cmake' 'qt5-tools' 'qt5-x11extras' 'java-environment'
+ 'zlib')
optdepends=('mcedit: Allows editing of minecraft worlds')
conflicts=('multimc5-git')
source=("https://github.com/MultiMC/MultiMC5/archive/${pkgver}.tar.gz"
+ "https://github.com/MultiMC/libnbtplusplus/archive/v${__pkgver_libnbtplusplus}.tar.gz"
'multimc5.sh'
'multimc5.desktop'
)
-sha512sums=('237b566ee6b7e6ba0800790f0ec25e3e2fd6037688fd5b3105d8f3dfe880c3d0eeb5d08969b222b45cf815e8c616aef0bc955a4ac12bf65138a88f004ea2175f'
+sha512sums=('0b5fc69c22f0cd762d6c4225078af1e38b00b583a9c231cc680a724394c88624b4d5602573090036ff1198bc656356aaad2f94d0f76c5cbe8f985cf8ba155cde'
+ '5e7a85275b7452ce1f507273e1ee264df8ba6536c431df8d223f2512b4823417f9699c1403108468c066c0f7f9bd359bce27cd3a33f35726fb6ba1a2d9b8e4de'
'6eb9476c8350fb8055238afc4d62f89897ea6d255a13edde88b76a67d021d88266d86236ef9ea9ebe82729b92cb7d8a9a66114de7c6b31666a82654dfe672049'
'a6712d0e84acc719ed1aff740717add44202f88cb42a0b7a3157108b73a1009ac7edd325f75d372e0a63617f40eb614d55fb4e24e5c1fb8957cd280486070675')
build() {
- cd "$srcdir/MultiMC5-${pkgver}"
-
- sed -i '/add_subdirectory(mmc_updater)/d' CMakeLists.txt
+ rmdir "${srcdir}/MultiMC5-${pkgver}/depends/libnbtplusplus" | echo "libnbtplusplus has data"
+ cp --recursive "${srcdir}/libnbtplusplus-${__pkgver_libnbtplusplus}/" "${srcdir}/MultiMC5-${pkgver}/depends/libnbtplusplus"
+ cd "${srcdir}/MultiMC5-${pkgver}"
+ #sed -i '/add_subdirectory(mmc_updater)/d' CMakeLists.txt
mkdir -p build
cd build
- cmake $srcdir/MultiMC5-${pkgver}
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/lib/multimc5" $srcdir/MultiMC5-${pkgver}
make
}
package() {
- cd "$srcdir/MultiMC5-${pkgver}/build"
- install -D MultiMC $pkgdir/usr/lib/multimc5/MultiMC5
- install -D $srcdir/multimc5.sh $pkgdir/usr/bin/multimc5
- install -D $srcdir/MultiMC5-${pkgver}/application/resources/multimc/scalable/multimc.svg $pkgdir/usr/share/pixmaps/multimc5.svg
- install -D $srcdir/multimc5.desktop $pkgdir/usr/share/applications/multimc5.desktop
- install -D jars/NewLaunch.jar $pkgdir/usr/lib/multimc5/jars/NewLaunch.jar
- install -D jars/JavaCheck.jar $pkgdir/usr/lib/multimc5/jars/JavaCheck.jar
+ cd "$srcdir/MultiMC5-${pkgver}/build"
+ #make DESTDIR="${pkgdir}" install
+ install -D MultiMC "${pkgdir}/usr/lib/multimc5/MultiMC5"
+ install -D libMultiMC_logic.so \
+ "${pkgdir}/usr/lib/multimc5/bin/libMultiMC_logic.so"
+ install -D librainbow.so "${pkgdir}/usr/lib/multimc5/bin/librainbow.so"
+ install -D "${srcdir}/multimc5.sh" "${pkgdir}/usr/bin/multimc5"
+ install -D \
+ "${srcdir}/MultiMC5-${pkgver}/application/resources/multimc/scalable/multimc.svg" \
+ "${pkgdir}/usr/share/pixmaps/multimc5.svg"
+ install -D "${srcdir}/multimc5.desktop" \
+ "${pkgdir}/usr/share/applications/multimc5.desktop"
}