summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2020-02-07 14:05:34 +1030
committerWill Handley2020-02-07 14:05:34 +1030
commit9505ab8801a301ab1cde48614891ba3af364a008 (patch)
tree082c222bde8b9ff2aaeaff8aa8a5871b5f93ce77
downloadaur-9505ab8801a301ab1cde48614891ba3af364a008.tar.gz
Version 3.12
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b603fa145f37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = multinest
+ pkgdesc = MultiNest is a Bayesian inference tool which calculates the evidence and explores the parameter space which may contain multiple posterior modes and pronounced (curving) degeneracies in moderately high dimensions.
+ pkgver = 3.12
+ pkgrel = 1
+ url = https://github.com/farhanferoz/MultiNest
+ arch = any
+ license = custom
+ depends = lapack
+ depends = gcc-fortran
+ depends = openmpi
+ options = !emptydirs
+ source = https://github.com/farhanferoz/MultiNest/archive/ba3e7d812b04e044b4d6e0319bd49a9fa6d78192.tar.gz
+ source = https://github.com/JohannesBuchner/PyMultiNest/archive/b147515e950cf225befef3f0e26408c672f01979.tar.gz
+ sha256sums = 4175009164b362355c4bbef2b2ece73235cfd9b505d4f49fe76e55876609cd4b
+ sha256sums = cebd358d24044863560d80e43436414a9341c25a25d572db1851a507ecf59bfc
+
+pkgname = multinest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..501a595ee61c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=multinest
+pkgver='3.12'
+pkgrel=1
+pkgdesc="MultiNest is a Bayesian inference tool which calculates the evidence and explores the parameter space which may contain multiple posterior modes and pronounced (curving) degeneracies in moderately high dimensions."
+arch=(any)
+url="https://github.com/farhanferoz/MultiNest"
+groups=()
+depends=('lapack' 'gcc-fortran' 'openmpi')
+license=('custom')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(
+ "https://github.com/farhanferoz/MultiNest/archive/ba3e7d812b04e044b4d6e0319bd49a9fa6d78192.tar.gz"
+ "https://github.com/JohannesBuchner/PyMultiNest/archive/b147515e950cf225befef3f0e26408c672f01979.tar.gz"
+)
+sha256sums=(
+ '4175009164b362355c4bbef2b2ece73235cfd9b505d4f49fe76e55876609cd4b'
+ 'cebd358d24044863560d80e43436414a9341c25a25d572db1851a507ecf59bfc'
+)
+build() {
+ cd "${srcdir}/MultiNest-ba3e7d812b04e044b4d6e0319bd49a9fa6d78192/MultiNest_v3.12_CMake/multinest/"
+ mkdir -p build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd "${srcdir}/MultiNest-ba3e7d812b04e044b4d6e0319bd49a9fa6d78192/MultiNest_v3.12_CMake/multinest"
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
+ cd build
+ make DESTDIR=${pkgdir} install
+ cd "${srcdir}/PyMultiNest-b147515e950cf225befef3f0e26408c672f01979/"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+}
+