summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2019-02-28 17:53:54 +0100
committerMiguel Revilla2019-02-28 17:53:54 +0100
commit188a6a9bba8311635048f9bab24637a720699c67 (patch)
tree9ee7e15fd77a4b2848de1776ffbbb28acd43d851
parent4a871f76809b9e448adfca4f52c801605c99679d (diff)
downloadaur-188a6a9bba8311635048f9bab24637a720699c67.tar.gz
Builds again
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--systemd.patch11
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fef65b2cd040..cb75a41782a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = multipath-tools-git
pkgdesc = Tools to drive the Device Mapper multipathing driver (contains kpartx)
- pkgver = 2141.ef969b3
+ pkgver = 2747.eb688e18
pkgrel = 1
url = http://christophe.varoqui.free.fr/
arch = x86_64
@@ -15,7 +15,9 @@ pkgbase = multipath-tools-git
conflicts = multipath-tools
options = !emptydirs
source = multipath-tools-git::git+http://git.opensvc.com/multipath-tools/.git
+ source = systemd.patch
md5sums = SKIP
+ md5sums = 4e354195b0cdcfeb3173ff6f10f0948e
pkgname = multipath-tools-git
diff --git a/PKGBUILD b/PKGBUILD
index 03e95f96bade..fed55b15c0cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Timothée Ravier <tim@siosm.fr>
pkgname=multipath-tools-git
-pkgver=2141.ef969b3
+pkgver=2747.eb688e18
pkgrel=1
pkgdesc="Tools to drive the Device Mapper multipathing driver (contains kpartx)"
url="http://christophe.varoqui.free.fr/"
@@ -13,8 +13,10 @@ depends=('libaio' 'device-mapper' 'liburcu' 'ceph')
makedepends=('git' 'setconf')
conflicts=('multipath-tools')
options=(!emptydirs)
-source=("${pkgname}::git+http://git.opensvc.com/multipath-tools/.git")
-md5sums=('SKIP')
+source=("${pkgname}::git+http://git.opensvc.com/multipath-tools/.git"
+ 'systemd.patch')
+md5sums=('SKIP'
+ '4e354195b0cdcfeb3173ff6f10f0948e')
pkgver() {
cd ${pkgname}
@@ -27,6 +29,8 @@ prepare() {
sed -i 's|${prefix}/lib/udev|${prefix}/usr/lib/udev|g' Makefile.inc
sed -i 's|$(prefix)/lib/systemd/system|$(prefix)/usr/lib/systemd/system|g' Makefile.inc
sed -i 's|/etc/udev/|/usr/lib/udev/|g' kpartx/Makefile
+
+ patch -p0 < ${srcdir}/systemd.patch
}
build() {
diff --git a/systemd.patch b/systemd.patch
new file mode 100644
index 000000000000..10a4ff2505c2
--- /dev/null
+++ b/systemd.patch
@@ -0,0 +1,11 @@
+--- Makefile.inc.orig 2019-02-28 17:50:52.552812580 +0100
++++ Makefile.inc 2019-02-28 17:51:11.782813067 +0100
+@@ -37,7 +37,7 @@
+
+ ifndef SYSTEMD
+ ifeq ($(shell systemctl --version > /dev/null 2>&1 && echo 1), 1)
+- SYSTEMD = $(shell systemctl --version 2> /dev/null | sed -n 's/systemd \([0-9]*\)/\1/p')
++ SYSTEMD = $(shell systemctl --version 2> /dev/null | sed -n 's/systemd \([0-9]*\) .*/\1/p')
+ endif
+ endif
+