summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-07-27 23:58:41 +0200
committerJ5lx2015-07-27 23:58:41 +0200
commit4f0a438df1bdc1e87135e571dfc3e35cb4342fc4 (patch)
tree6b1b2fdad1bd9b4a07f0b9c677ca43fb6447cf52
parent6ae16db7afd66d5cd2d9f0ebcd731278b2cb9d3e (diff)
downloadaur-4f0a438df1bdc1e87135e571dfc3e35cb4342fc4.tar.gz
1.2.10-1: Update to new upstream version, incorporate changes from community
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed4cd1f5755b..ebcafb0c486a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mumble-jack
pkgdesc = Mumble with support for JACK
- pkgver = 1.2.9
+ pkgver = 1.2.10
pkgrel = 1
url = http://mumble.info/
install = mumble.install
@@ -9,7 +9,6 @@ pkgbase = mumble-jack
license = BSD
makedepends = boost
makedepends = mesa
- makedepends = avahi
depends = qt4
depends = speex
depends = lsb-release
@@ -20,11 +19,13 @@ pkgbase = mumble-jack
depends = libpulse
depends = jack
depends = opus
+ depends = xdg-utils
+ depends = speech-dispatcher
provides = mumble
conflicts = mumble
- source = http://downloads.sourceforge.net/mumble/mumble-1.2.9.tar.gz
+ source = http://downloads.sourceforge.net/mumble/mumble-1.2.10.tar.gz
source = http://sourceforge.net/p/mumble/patches/_discuss/thread/1bfdbda2/a90e/attachment/mumble-jack-support.patch
- md5sums = 85decb9a1efb13e7558fab6265f81ad8
+ md5sums = 14ab2e9174b7ca87623e63aa56dd6d5b
md5sums = 03d89f5f4265de696505211984b969a0
pkgname = mumble-jack
diff --git a/PKGBUILD b/PKGBUILD
index 20af66029ff6..1a7585e6c075 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Contributor: Moritz Kiefer <moritz.kiefer@gmail.com>
pkgname=mumble-jack
-pkgver=1.2.9
+pkgver=1.2.10
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Mumble with support for JACK"
license=('BSD')
-depends=('qt4' 'speex' 'lsb-release' 'libxi' 'avahi' 'libsndfile' 'protobuf' 'libpulse' 'jack' 'opus')
-makedepends=('boost' 'mesa' 'avahi')
+depends=('qt4' 'speex' 'lsb-release' 'libxi' 'avahi' 'libsndfile' 'protobuf' 'libpulse' 'jack' 'opus' 'xdg-utils' 'speech-dispatcher')
+makedepends=('boost' 'mesa')
provides=('mumble')
conflicts=('mumble')
install=mumble.install
url=http://mumble.info/
source=(http://downloads.sourceforge.net/mumble/mumble-$pkgver.tar.gz
http://sourceforge.net/p/mumble/patches/_discuss/thread/1bfdbda2/a90e/attachment/mumble-jack-support.patch)
-md5sums=('85decb9a1efb13e7558fab6265f81ad8'
+md5sums=('14ab2e9174b7ca87623e63aa56dd6d5b'
'03d89f5f4265de696505211984b969a0')
@@ -29,9 +29,10 @@ build() {
cd $srcdir/mumble-$pkgver
# Building mumble
qmake-qt4 main.pro \
- CONFIG+="bundled-celt no-bundled-opus no-bundled-speex no-speechd no-g15 no-xevie no-server \
+ CONFIG+="bundled-celt no-bundled-opus no-bundled-speex no-g15 no-xevie no-server \
no-embed-qt-translations no-update packaged" \
- DEFINES+="PLUGIN_PATH=/usr/lib/mumble"
+ DEFINES+="PLUGIN_PATH=/usr/lib/mumble" \
+ INCLUDEPATH+="/usr/include/speech-dispatcher"
make release
}