summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-06-09 17:04:21 +0200
committerJ5lx2015-06-09 17:04:56 +0200
commit994711e433579ee9b543bcca1271f9113cd75560 (patch)
tree8ba74d455a939e10260f85e37355515255d7cb0d
downloadaur-994711e433579ee9b543bcca1271f9113cd75560.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD64
-rw-r--r--mumble.install11
3 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51f6cc3f8290
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = mumble-jack
+ pkgdesc = Mumble with support for JACK
+ pkgver = 1.2.8
+ pkgrel = 3
+ url = http://mumble.info/
+ install = mumble.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = boost
+ makedepends = mesa
+ makedepends = avahi
+ depends = qt4
+ depends = speex
+ depends = lsb-release
+ depends = libxi
+ depends = avahi
+ depends = libsndfile
+ depends = protobuf
+ depends = libpulse
+ depends = jack
+ provides = mumble
+ conflicts = mumble
+ source = http://downloads.sourceforge.net/mumble/mumble-1.2.8.tar.gz
+ source = gcc49.patch::https://github.com/mumble-voip/mumble/commit/349436284b5f1baa61836c98ff0d518392140c5d.patch
+ source = http://sourceforge.net/p/mumble/patches/_discuss/thread/1bfdbda2/a90e/attachment/mumble-jack-support.patch
+ md5sums = 1a3ef91489ff674dfc010377d7721a28
+ md5sums = 9a1c254352dd4bb9fe4ba2f7471fb030
+ md5sums = 03d89f5f4265de696505211984b969a0
+
+pkgname = mumble-jack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..558ce883db23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Moritz Kiefer <moritz.kiefer@gmail.com>
+
+pkgname=mumble-jack
+pkgver=1.2.8
+pkgrel=3
+arch=('i686' 'x86_64')
+pkgdesc="Mumble with support for JACK"
+license=('BSD')
+depends=('qt4' 'speex' 'lsb-release' 'libxi' 'avahi' 'libsndfile' 'protobuf' 'libpulse' 'jack')
+makedepends=('boost' 'mesa' 'avahi')
+provides=('mumble')
+conflicts=('mumble')
+install=mumble.install
+url=http://mumble.info/
+source=(http://downloads.sourceforge.net/mumble/mumble-$pkgver.tar.gz
+ gcc49.patch::https://github.com/mumble-voip/mumble/commit/349436284b5f1baa61836c98ff0d518392140c5d.patch
+ http://sourceforge.net/p/mumble/patches/_discuss/thread/1bfdbda2/a90e/attachment/mumble-jack-support.patch)
+md5sums=('1a3ef91489ff674dfc010377d7721a28'
+ '9a1c254352dd4bb9fe4ba2f7471fb030'
+ '03d89f5f4265de696505211984b969a0')
+
+
+prepare() {
+ cd $srcdir/mumble-$pkgver
+
+ patch -Np1 < $srcdir/gcc49.patch
+ patch -Np1 < $srcdir/mumble-jack-support.patch
+}
+
+build() {
+ cd $srcdir/mumble-$pkgver
+ # Building mumble
+ qmake-qt4 main.pro \
+ CONFIG+="bundled-celt no-bundled-opus no-bundled-speex no-speechd no-g15 no-xevie no-server \
+ no-embed-qt-translations no-update packaged" \
+ DEFINES+="PLUGIN_PATH=/usr/lib/mumble"
+ make release
+}
+
+package() {
+ cd $srcdir/mumble-$pkgver
+
+ # bin stuff
+ install -m755 -D ./release/mumble $pkgdir/usr/bin/mumble
+ install -m755 -D ./scripts/mumble-overlay $pkgdir/usr/bin/mumble-overlay
+
+ # lib stuff
+ install -m755 -D ./release/libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so.$pkgver
+ ln -s libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so
+ ln -s libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so.1
+ ln -s libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so.1.2
+ install -m755 -D ./release/plugins/liblink.so $pkgdir/usr/lib/mumble/liblink.so
+ install -m755 -D ./release/plugins/libmanual.so $pkgdir/usr/lib/mumble/libmanual.so
+ install -m755 -D ./release/libcelt* $pkgdir/usr/lib/mumble/
+
+ # other stuff
+ install -m644 -D ./scripts/mumble.desktop $pkgdir/usr/share/applications/mumble.desktop
+ install -m755 -d $pkgdir/usr/share/man/man1
+ install -m644 -D ./man/mum* $pkgdir/usr/share/man/man1/
+ install -m644 -D ./icons/mumble.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/mumble.svg
+ install -m644 -D ./LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
diff --git a/mumble.install b/mumble.install
new file mode 100644
index 000000000000..547348418df4
--- /dev/null
+++ b/mumble.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}