summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2018-01-18 07:17:29 +0100
committerGiovanni Harting2018-01-18 07:17:29 +0100
commitbed3f7aa7d820591d1c3713cc2f2c1118d27fcbf (patch)
tree4f7f78ce32ace019c3a7d3fa0272ce71b7e429ea
parent43316a1abdc07322a90e10605a04c165b1f849cd (diff)
downloadaur-bed3f7aa7d820591d1c3713cc2f2c1118d27fcbf.tar.gz
1.3.0~2586~g894ade2; optimized dependencies
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD24
-rw-r--r--float_overload.patch32
-rw-r--r--mumble.install12
4 files changed, 60 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c361b932d59b..1a3d670b0329 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,33 @@
pkgbase = mumble-snapshot
pkgdesc = A high quality voice chat program.
- pkgver = 1.3.0_2584_g53c5a91
+ pkgver = 1.3.0_2586_g894ade2
pkgrel = 1
url = https://www.mumble.info/
- install = mumble.install
arch = i686
arch = x86_64
license = BSD
makedepends = boost
makedepends = qt5-tools
- depends = qt5-base
+ makedepends = python
+ makedepends = libsndfile
+ makedepends = speech-dispatcher
depends = qt5-svg
depends = opus
depends = speex
- depends = libpulse
- depends = avahi
depends = protobuf
- depends = speech-dispatcher
+ depends = hicolor-icon-theme
+ depends = libspeechd
+ depends = libpulse
optdepends = espeak: speech synthesizer
provides = mumble
conflicts = mumble
- source = https://dl.mumble.info/mumble-1.3.0~2584~g53c5a91~snapshot.tar.gz
- source = https://dl.mumble.info/mumble-1.3.0~2584~g53c5a91~snapshot.tar.gz.sig
+ source = https://dl.mumble.info/mumble-1.3.0~2586~g894ade2~snapshot.tar.gz
+ source = https://dl.mumble.info/mumble-1.3.0~2586~g894ade2~snapshot.tar.gz.sig
+ source = float_overload.patch
validpgpkeys = C4666C6767A26017CE68406988048D0D625297A0
- sha256sums = 0f5b042d56da91fdaada7016ca8f94bedf4fbaa0a78c7c57f54ca5b97c3ead82
+ sha256sums = a0b8720e01495c399d14c2051bcf5e7356ceea8e0162a75cc4e10039a5324f7e
sha256sums = SKIP
+ sha256sums = c65cd76cdc4243ce29d7ce005a438e0a1bd7f99327e2623bea9436901fab98ec
pkgname = mumble-snapshot
diff --git a/PKGBUILD b/PKGBUILD
index 4c0720407d02..de263431f5a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
-# Maintainer: synapse84 <synapse84 at gmail dot com>
+# Maintainer: Giovanni Harting <539@idlegandalf.com>
+# Contributor: synapse84 <synapse84 at gmail dot com>
pkgname=mumble-snapshot
-pkgver=1.3.0_2584_g53c5a91
+pkgver=1.3.0_2586_g894ade2
pkgrel=1
pkgdesc="A high quality voice chat program."
arch=('i686' 'x86_64')
url="https://www.mumble.info/"
license=('BSD')
-depends=('qt5-base' 'qt5-svg' 'opus' 'speex' 'libpulse' 'avahi' 'protobuf' 'speech-dispatcher')
-makedepends=('boost' 'qt5-tools')
+depends=('qt5-svg' 'opus' 'speex' 'protobuf' 'hicolor-icon-theme' 'libspeechd' 'libpulse')
+makedepends=('boost' 'qt5-tools' 'python' 'libsndfile' 'speech-dispatcher')
optdepends=('espeak: speech synthesizer')
provides=('mumble')
conflicts=('mumble')
-install=mumble.install
-source=("https://dl.mumble.info/mumble-${pkgver//_/\~}~snapshot.tar.gz"{,.sig})
+source=("https://dl.mumble.info/mumble-${pkgver//_/\~}~snapshot.tar.gz"{,.sig}
+ "float_overload.patch")
validpgpkeys=('C4666C6767A26017CE68406988048D0D625297A0')
-sha256sums=('0f5b042d56da91fdaada7016ca8f94bedf4fbaa0a78c7c57f54ca5b97c3ead82'
- 'SKIP')
+sha256sums=('a0b8720e01495c399d14c2051bcf5e7356ceea8e0162a75cc4e10039a5324f7e'
+ 'SKIP'
+ 'c65cd76cdc4243ce29d7ce005a438e0a1bd7f99327e2623bea9436901fab98ec')
+
+
+prepare() {
+ cd $srcdir/mumble-${pkgver//_/\~}~snapshot
+ patch -Np1 -i "${srcdir}/float_overload.patch"
+}
build() {
cd $srcdir/mumble-${pkgver//_/\~}~snapshot
diff --git a/float_overload.patch b/float_overload.patch
new file mode 100644
index 000000000000..cf61106ce6c6
--- /dev/null
+++ b/float_overload.patch
@@ -0,0 +1,32 @@
+From ea861fe86743c8402bbad77d8d1dd9de8dce447e Mon Sep 17 00:00:00 2001
+From: Mikkel Krautz <mikkel@krautz.dk>
+Date: Fri, 29 Dec 2017 14:47:25 +0100
+Subject: [PATCH] AudioOutput: do not use non-existant template version of
+ std::abs.
+
+This change fixes AudioOutput to use the float overload of std::abs:
+
+ float std::abs(float);
+
+instead of a non-existant template version.
+
+Fixes mumble-voip/mumble#3281
+
+Needs-Backport: 1.2.x
+---
+ src/mumble/AudioOutput.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mumble/AudioOutput.cpp b/src/mumble/AudioOutput.cpp
+index cbe0c0e2b..7a0a5e2ab 100644
+--- a/src/mumble/AudioOutput.cpp
++++ b/src/mumble/AudioOutput.cpp
+@@ -437,7 +437,7 @@ bool AudioOutput::mix(void *outbuff, unsigned int nsamp) {
+ top[2] = 0.0f;
+ }
+
+- if (std::abs<float>(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
++ if (std::abs(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
+ // Not perpendicular. Assume Y up and rotate 90 degrees.
+
+ float azimuth = 0.0f;
diff --git a/mumble.install b/mumble.install
deleted file mode 100644
index 71627fa64211..000000000000
--- a/mumble.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}