summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil2015-06-19 17:11:28 -0600
committerPhil2015-06-19 17:11:28 -0600
commitc194237f63c5b562c93b7a61087d8e455773a8ed (patch)
tree021437262375f394da8fcb89cb7b1443b2e3417c
downloadaur-c194237f63c5b562c93b7a61087d8e455773a8ed.tar.gz
initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD61
-rw-r--r--mumble.install12
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89972418148a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = mumble-snapshot
+ pkgdesc = A high quality voice chat program. (snapshot build)
+ pkgver = 1.3.0_664_g6db171e
+ pkgrel = 1
+ url = http://mumble.info/
+ install = mumble.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = boost
+ depends = qt4
+ depends = opus
+ depends = speex
+ depends = libpulse
+ depends = avahi
+ depends = protobuf
+ provides = mumble
+ conflicts = mumble
+ source = http://mumble.info/snapshot/mumble-1.3.0~664~g6db171e~snapshot.tar.gz
+ sha256sums = 3ab66ad2d4cd49edc3cb493c8adef1d994807aa0f15cfc8c7162e2dc9330adf8
+
+pkgname = mumble-snapshot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a371a23da6c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: synapse84 <synapse84 at gmail dot com>
+
+pkgname=mumble-snapshot
+pkgver=1.3.0_664_g6db171e
+pkgrel=1
+pkgdesc="A high quality voice chat program. (snapshot build)"
+arch=('i686' 'x86_64')
+url="http://mumble.info/"
+license=('BSD')
+depends=('qt4' 'opus' 'speex' 'libpulse' 'avahi' 'protobuf')
+makedepends=('boost')
+provides=('mumble')
+conflicts=('mumble')
+install=mumble.install
+source=("http://mumble.info/snapshot/mumble-${pkgver//_/\~}~snapshot.tar.gz")
+sha256sums=('3ab66ad2d4cd49edc3cb493c8adef1d994807aa0f15cfc8c7162e2dc9330adf8')
+
+build() {
+ cd $srcdir/mumble-${pkgver//_/\~}~snapshot
+
+ qmake-qt4 main.pro \
+ CONFIG+="bundled-celt no-bundled-opus no-bundled-speex no-g15 no-xevie no-server no-embed-qt-translations no-update no-speechd qt4-legacy-compat" \
+ DEFINES+="PLUGIN_PATH=/usr/lib/mumble"
+
+ make release
+}
+
+package() {
+ cd $srcdir/mumble-${pkgver//_/\~}~snapshot
+
+ # binaries
+ install -m755 -D ./release/mumble $pkgdir/usr/bin/mumble
+ install -m755 -D ./scripts/mumble-overlay $pkgdir/usr/bin/mumble-overlay
+
+ # libraries
+ # mumble
+ install -m755 -D ./release/libmumble.so.1.3.0 $pkgdir/usr/lib/mumble/libmumble.so.1.3.0
+ ln -s libmumble.so.1.3.0 $pkgdir/usr/lib/mumble/libmumble.so
+ ln -s libmumble.so.1.3.0 $pkgdir/usr/lib/mumble/libmumble.so.1
+ ln -s libmumble.so.1.3.0 $pkgdir/usr/lib/mumble/libmumble.so.1.3
+ # celt 11
+ install -m755 -D ./release/libcelt0.so.0.11.0 $pkgdir/usr/lib/mumble/libcelt0.so.0.11.0
+ ln -s libcelt0.so.0.11.0 $pkgdir/usr/lib/mumble/libcelt0.so
+ ln -s libcelt0.so.0.11.0 $pkgdir/usr/lib/mumble/libcelt0.so.0
+ ln -s libcelt0.so.0.11.0 $pkgdir/usr/lib/mumble/libcelt0.so.0.11
+ # celt 7
+ install -m755 -D ./release/libcelt0.so.0.7.0 $pkgdir/usr/lib/mumble/libcelt0.so.0.7.0
+ ln -s libcelt0.so.0.7.0 $pkgdir/usr/lib/mumble/libcelt0.so.0.7
+
+ # plugins
+ install -m755 -D ./release/plugins/liblink.so $pkgdir/usr/lib/mumble/plugins/liblink.so
+ install -m755 -D ./release/plugins/libmanual.so $pkgdir/usr/lib/mumble/plugins/libmanual.so
+
+ # other
+ install -m755 -d $pkgdir/usr/share/man/man1
+ install -m644 -D ./man/mumble* $pkgdir/usr/share/man/man1/
+ install -m644 -D ./scripts/mumble.desktop $pkgdir/usr/share/applications/mumble.desktop
+ install -m644 -D ./icons/mumble.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/mumble.svg
+ install -m644 -D ./LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
diff --git a/mumble.install b/mumble.install
new file mode 100644
index 000000000000..71627fa64211
--- /dev/null
+++ b/mumble.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}