summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Singer2016-10-04 16:22:38 +0200
committerFelix Singer2016-10-04 16:22:38 +0200
commit683362891e299dd1860e757b8478279e36949c3d (patch)
tree89b5262f38356596c50a23cb6f2373955e438cd2
parent61dcaf3e5a8537c5fae0920b5ff738e3f96544ef (diff)
downloadaur-683362891e299dd1860e757b8478279e36949c3d.tar.gz
Updated package description, use sha512 instead of md5 for source package verification, added compiler flag 'optimize' and removed some plugin libs
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad5f7b431983..c6c4b62da840 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = mumble-stable-minimal
- pkgdesc = Mumble stable without Text2Speech and Overlay
+ pkgdesc = Mumble is a voice chat application similar to TeamSpeak. This release doesn't include Text2Speech, Overlay and several plugins.
pkgver = 1.2.17
pkgrel = 1
url = http://mumble.info/
@@ -22,7 +22,7 @@ pkgbase = mumble-stable-minimal
provides = mumble=1.2.17
conflicts = mumble
source = https://github.com/mumble-voip/mumble/releases/download/1.2.17/mumble-1.2.17.tar.gz
- md5sums = 98a28c10cb607bb51f13e568db2b9570
+ sha512sums = 03cb0a2048d42bd480741e0580cb4bf6961d607d6cf9b620434aea87ac0cd7cdbfae33863b71821ac8b931300df490ae5436f3c8098d6a5f37dd1eab0fb34dbe
pkgname = mumble-stable-minimal
diff --git a/PKGBUILD b/PKGBUILD
index ba82bed148a7..d5d7675d9d03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=${_pkgname}-stable-minimal
pkgver=1.2.17
pkgrel=1
arch=('i686' 'x86_64')
-pkgdesc="Mumble stable without Text2Speech and Overlay"
+pkgdesc="Mumble is a voice chat application similar to TeamSpeak. This release doesn't include Text2Speech, Overlay and several plugins."
license=('BSD')
depends=('qt4' 'speex' 'lsb-release' 'libxi' 'avahi' 'libsndfile' 'protobuf' 'libpulse' 'jack' 'opus' 'xdg-utils')
makedepends=('boost' 'mesa')
@@ -13,14 +13,14 @@ provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
url="http://mumble.info/"
source=("https://github.com/mumble-voip/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
-md5sums=('98a28c10cb607bb51f13e568db2b9570')
+sha512sums=('03cb0a2048d42bd480741e0580cb4bf6961d607d6cf9b620434aea87ac0cd7cdbfae33863b71821ac8b931300df490ae5436f3c8098d6a5f37dd1eab0fb34dbe')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
qmake-qt4 main.pro \
CONFIG+="bundled-celt no-bundled-opus no-bundled-speex no-g15 no-xevie no-server \
- no-embed-qt-translations no-update no-speechd no-overlay packaged" \
+ no-embed-qt-translations no-update packaged no-speechd no-overlay optimize" \
DEFINES+="PLUGIN_PATH=/usr/lib/mumble"
make release
@@ -29,15 +29,19 @@ build() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- install -Dm755 "./release/mumble" "${pkgdir}/usr/bin/mumble"
+ install -m755 -D "./release/mumble" "${pkgdir}/usr/bin/mumble"
- install -Dm755 "./release/plugins/liblink.so" "${pkgdir}/usr/lib/mumble/liblink.so"
- install -Dm755 "./release/plugins/libmanual.so" "${pkgdir}/usr/lib/mumble/libmanual.so"
- install -Dm755 "./release/libcelt"* "${pkgdir}/usr/lib/mumble/"
+ install -m755 -D "./release/libcelt0.so.0.11.0" "${pkgdir}/usr/lib/mumble/libcelt0.so.0.11.0"
+ ln -s "libcelt0.so.0.11.0" "${pkgdir}/usr/lib/mumble/libcelt0.so"
+ ln -s "libcelt0.so.0.11.0" "${pkgdir}/usr/lib/mumble/libcelt0.so.0"
+ ln -s "libcelt0.so.0.11.0" "${pkgdir}/usr/lib/mumble/libcelt0.so.0.11"
- install -Dm644 "./scripts/mumble.desktop" "${pkgdir}/usr/share/applications/mumble.desktop"
- install -dm755 "${pkgdir}/usr/share/man/man1"
- install -Dm644 "./man/mum"* "${pkgdir}/usr/share/man/man1/"
- install -Dm644 "./icons/mumble.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/mumble.svg"
- install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m755 -D "./release/libcelt0.so.0.7.0" "${pkgdir}/usr/lib/mumble/libcelt0.so.0.7.0"
+ ln -s "libcelt0.so.0.7.0" "${pkgdir}/usr/lib/mumble/libcelt0.so.0.7"
+
+ install -m644 -D "./scripts/mumble.desktop" "${pkgdir}/usr/share/applications/mumble.desktop"
+ install -m755 -d "${pkgdir}/usr/share/man/man1"
+ install -m644 -D "./man/mumble.1" "${pkgdir}/usr/share/man/man1/"
+ install -m644 -D "./icons/mumble.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/mumble.svg"
+ install -m644 -D "./LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}