summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2016-10-27 12:17:04 -0200
committerLucas Heitzmann Gabrielli2016-10-27 12:17:04 -0200
commite75cb83674ea087a2271a6e2bcb8afa02530fdd0 (patch)
treebb21acfd2bfd83d305bf8bddf679d1fbb9102c34
parented581367a33cfa5a0a3f528320c9ed303fd21470 (diff)
downloadaur-e75cb83674ea087a2271a6e2bcb8afa02530fdd0.tar.gz
Updated to 5.0.2
-rw-r--r--.SRCINFO10
-rw-r--r--[-rwxr-xr-x]Makefile.inc106
-rwxr-xr-xPKGBUILD8
3 files changed, 87 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4e61b5aa630..772431db017d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mumps
pkgdesc = Sparse solver library using Gaussian elimination
- pkgver = 5.0.1
- pkgrel = 2
+ pkgver = 5.0.2
+ pkgrel = 1
url = http://mumps.enseeiht.fr
arch = i686
arch = x86_64
@@ -13,10 +13,10 @@ pkgbase = mumps
depends = metis
depends = zlib
depends = bzip2
- source = http://mumps.enseeiht.fr/MUMPS_5.0.1.tar.gz
+ source = http://mumps.enseeiht.fr/MUMPS_5.0.2.tar.gz
source = Makefile.inc
- md5sums = b477573fdcc87babe861f62316833db0
- md5sums = 6dff109173476993b430856aad890a45
+ md5sums = SKIP
+ md5sums = 245a17bb48599ef407863bbed00d488f
pkgname = mumps
diff --git a/Makefile.inc b/Makefile.inc
index 25ad331ab64c..40e1a76de7fc 100755..100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -1,5 +1,6 @@
-############################## Begin orderings ###############################
-
+########################################################################
+#Begin orderings
+#
# NOTE that PORD is distributed within MUMPS by default. If you would like to
# use other orderings, you need to obtain the corresponding package and modify
# the variables below accordingly.
@@ -20,12 +21,11 @@ ISCOTCH = -I$(SCOTCHDIR)/include/scotch
# You have to choose one among the following two lines depending on
# the type of analysis you want to perform. If you want to perform only
# sequential analysis choose the first (remember to add -Dscotch in the ORDERINGSF
-# variable below); for both parallel and sequential analysis choose the second
+# variable below); for both parallel and sequential analysis choose the second
# line (remember to add -Dptscotch in the ORDERINGSF variable below)
LSCOTCH = -L$(SCOTCHDIR)/lib -lesmumps -lbz2 -lz -lscotch -lscotcherr
-#LSCOTCH = -L$(SCOTCHDIR)/lib -lptesmumps -lptscotch -lptscotcherr -lscotchmetis
-#LSCOTCH = -L$(SCOTCHDIR)/lib -lptesmumps -lptscotch -lptscotcherr -lscotchmetis -lscotch
+#LSCOTCH = -L$(SCOTCHDIR)/lib -lptesmumps -lptscotch -lptscotcherr -lscotch
LPORDDIR = $(topdir)/PORD/lib/
@@ -34,58 +34,108 @@ LPORD = -L$(LPORDDIR) -lpord
LMETISDIR = /usr/lib
IMETIS = -I/usr/include/metis
-# IPARMETIS = -I/usr/include/parmetis
# You have to choose one among the following two lines depending on
# the type of analysis you want to perform. If you want to perform only
# sequential analysis choose the first (remember to add -Dmetis in the ORDERINGSF
-# variable below); for both parallel and sequential analysis choose the second
+# variable below); for both parallel and sequential analysis choose the second
# line (remember to add -Dparmetis in the ORDERINGSF variable below)
LMETIS = -L$(LMETISDIR) -lmetis
-# LMETIS = -L$(LMETISDIR) -lparmetis -lmetis
+#LMETIS = -L$(LMETISDIR) -lparmetis -lmetis
# The following variables will be used in the compilation process.
# Please note that -Dptscotch and -Dparmetis imply -Dscotch and -Dmetis respectively.
+# If you want to use Metis 4.X or an older version, you should use -Dmetis4 instead of -Dmetis
+# or in addition with -Dparmetis (if you are using parmetis 3.X or older).
+#ORDERINGSF = -Dscotch -Dmetis -Dpord -Dptscotch -Dparmetis
+#ORDERINGSF = -Dpord
ORDERINGSF = -Dscotch -Dmetis -Dpord
-# ORDERINGSF = -Dscotch -Dmetis -Dpord -Dptscotch -Dparmetis
-# ORDERINGSF = -Dpord
ORDERINGSC = $(ORDERINGSF)
LORDERINGS = $(LMETIS) $(LPORD) $(LSCOTCH)
IORDERINGSF = $(ISCOTCH)
-IORDERINGSC = $(IPARMETIS) $(IMETIS) $(IPORD) $(ISCOTCH)
+IORDERINGSC = $(IMETIS) $(IPORD) $(ISCOTCH)
+
+#End orderings
+########################################################################
-########################### End orderings ###################################
+########################################################################
+# DEFINE HERE SOME COMMON COMMANDS, THE COMPILER NAMES, ETC...
+# PLAT : use it to add a default suffix to the generated libraries
PLAT =
+# Library extension, + C and Fortran "-o" option
+# may be different under Windows
LIBEXT = .a
OUTC = -o
OUTF = -o
-RM = /bin/rm -f
-CC = mpicc
-FC = mpif77
-FL = mpif77
-AR = ar vr
-RANLIB = ranlib
-# RANLIB = echo
-SCALAP = -lscalapack -llapack # -lblacs -lblacsf77 -lblacs #
+# RM : remove files
+RM = /bin/rm -f
+# CC : C compiler
+CC = mpicc
+# FC : Fortran 90 compiler
+FC = mpif90
+# FL : Fortran linker
+FL = mpif90
+# AR : Archive object in a library
+# keep a space at the end if options have to be separated from lib name
+AR = ar vr
+# RANLIB : generate index of an archive file
+# (optionnal use "RANLIB = echo" in case of problem)
+RANLIB = ranlib
+#RANLIB = echo
+
+# SCALAP should define the SCALAPACK and BLACS libraries.
+SCALAP = -lscalapack -llapack
+
+# INCLUDE DIRECTORY FOR MPI
INCPAR = -I/usr/include/openmpi
+
+# LIBRARIES USED BY THE PARALLEL VERSION OF MUMPS: $(SCALAP) and MPI
LIBPAR = $(SCALAP) -L/usr/lib/openmpi -lmpi_usempif08 -lmpi_usempi_ignore_tkr -lmpi_mpifh -lmpi
-# See point 17 in the FAQ to have more details on the compilation of mpich with gfortran
-INCSEQ = -I$(topdir)/libseq
-LIBSEQ = -L$(topdir)/libseq -lmpiseq
+
+# The parallel version is not concerned by the next two lines.
+# They are related to the sequential library provided by MUMPS,
+# to use instead of ScaLAPACK and MPI.
+INCSEQ = -I$(topdir)/libseq
+LIBSEQ = -L$(topdir)/libseq -lmpiseq
+
+# DEFINE HERE YOUR BLAS LIBRARY
+
LIBBLAS = -lblas
+
+# DEFINE YOUR PTHREAD LIBRARY
LIBOTHERS = -lpthread
-# Preprocessor defs for calling Fortran from C (-DAdd_ or -DAdd__ or -DUPPER)
-CDEFS = -DAdd_
-# Begin Optimized options
+# FORTRAN/C COMPATIBILITY:
+# Use:
+# -DAdd_ if your Fortran compiler adds an underscore at the end
+# of symbols,
+# -DAdd__ if your Fortran compiler adds 2 underscores,
+#
+# -DUPPER if your Fortran compiler uses uppercase symbols
+#
+# leave empty if your Fortran compiler does not change the symbols.
+#
+
+CDEFS = -DAdd_
+
+#COMPILER OPTIONS
+
OPTF = -DALLOW_NON_INIT ${CFLAGS} -fPIC
OPTL = ${CFLAGS} -fPIC
OPTC = ${CFLAGS} -fPIC
-# End Optimized options
+# CHOOSE BETWEEN USING THE SEQUENTIAL OR THE PARALLEL VERSION.
+
+#Sequential:
+#INCS = $(INCSEQ)
+#LIBS = $(LIBSEQ)
+LIBSEQNEEDED = libseqneeded
+
+#Parallel:
INCS = $(INCPAR)
LIBS = $(LIBPAR)
-LIBSEQNEEDED = libseqneeded
+#LIBSEQNEEDED =
+
diff --git a/PKGBUILD b/PKGBUILD
index a03c4107b719..8ec86b5e02a4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Guillaume Dollé < dolle dot guillaume at gmail dot com >
# Contributor: Lucas H. Gabrielli
pkgname=mumps
-pkgver=5.0.1
-pkgrel=2
+pkgver=5.0.2
+pkgrel=1
pkgdesc="Sparse solver library using Gaussian elimination"
url="http://mumps.enseeiht.fr"
license=("custom")
@@ -16,8 +16,8 @@ backup=()
arch=('i686' 'x86_64')
source=(http://mumps.enseeiht.fr/MUMPS_${pkgver}.tar.gz
Makefile.inc)
-md5sums=('b477573fdcc87babe861f62316833db0'
- '6dff109173476993b430856aad890a45')
+md5sums=('SKIP'
+ '245a17bb48599ef407863bbed00d488f')
build() {
cd "${srcdir}/MUMPS_${pkgver}"