summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2015-06-09 15:24:45 +0200
committereolianoe2015-06-09 15:24:45 +0200
commit624cc8d44dc491c4b6482b16697123a1a0627052 (patch)
tree8feb917542135a5de0c81f5ceae22807cf442722
parent9c033bcf1c6e3c52f99babcf6515c989c382efe1 (diff)
downloadaur-624cc8d44dc491c4b6482b16697123a1a0627052.tar.gz
Use metis instead of metis-4
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.seq.inc6
-rw-r--r--PKGBUILD6
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8252123c8735..a3b2744713c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = mumps-seq
pkgdesc = Sparse solver library using Gaussian elimination (sequential version)
pkgver = 5.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://mumps.enseeiht.fr
arch = i686
arch = x86_64
license = custom
depends = gcc-libs
depends = blas
- depends = metis4
+ depends = metis
provides = mumps
conflicts = mumps
source = http://mumps.enseeiht.fr/MUMPS_5.0.0.tar.gz
source = Makefile.seq.inc
sha256sums = 191ec4b3ea8c4b5955279a9c03e469be49cb75c9ed672b85fd68623dcef52019
- sha256sums = 377e619043715a660763135643b46c1a9e61317c8e54696073f1635e4025ebc0
+ sha256sums = e73105ab186f78c14c71f8032deec0af77f9f32f6fe51381a56f0a545fd6ea3c
pkgname = mumps-seq
diff --git a/Makefile.seq.inc b/Makefile.seq.inc
index 22d0f2a853cc..f8f44ae261db 100644
--- a/Makefile.seq.inc
+++ b/Makefile.seq.inc
@@ -60,7 +60,7 @@ IPORD = -I$(topdir)/PORD/include/
LPORD = -L$(LPORDDIR) -lpord
LMETISDIR = /usr/lib
-IMETIS = /usr/include/metis-4
+IMETIS = /usr/include
# You have to choose one among the following two lines depending on
# the type of analysis you want to perform. If you want to perform only
@@ -68,7 +68,7 @@ IMETIS = /usr/include/metis-4
# variable below); for both parallel and sequential analysis choose the second
# line (remember to add -Dparmetis in the ORDERINGSF variable below)
-LMETIS = -L$(LMETISDIR) -lmetis-4
+LMETIS = -L$(LMETISDIR) -lmetis
#LMETIS = -L$(LMETISDIR) -lparmetis -lmetis
# The following variables will be used in the compilation process.
@@ -76,7 +76,7 @@ LMETIS = -L$(LMETISDIR) -lmetis-4
# If you want to use Metis 4.X or an older version, you should use -Dmetis4 instead of -Dmetis
# or in addition with -Dparmetis (if you are using parmetis 3.X or older).
#ORDERINGSF = -Dscotch -Dmetis -Dpord -Dptscotch -Dparmetis
-ORDERINGSF = -Dpord -Dmetis4
+ORDERINGSF = -Dpord -Dmetis
ORDERINGSC = $(ORDERINGSF)
LORDERINGS = $(LMETIS) $(LPORD) $(LSCOTCH)
diff --git a/PKGBUILD b/PKGBUILD
index 6b1900012d2f..3a74fda4fca9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,18 @@ pkgname=mumps-seq
_pkgname=mumps
_PKGNAME=MUMPS
pkgver=5.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Sparse solver library using Gaussian elimination (sequential version)"
url="http://mumps.enseeiht.fr"
license=('custom')
-depends=('gcc-libs' 'blas' 'metis4')
+depends=('gcc-libs' 'blas' 'metis')
provides=('mumps')
conflicts=('mumps')
arch=('i686' 'x86_64')
source=("http://mumps.enseeiht.fr/${_PKGNAME}_${pkgver}.tar.gz"
"Makefile.seq.inc")
sha256sums=('191ec4b3ea8c4b5955279a9c03e469be49cb75c9ed672b85fd68623dcef52019'
- '377e619043715a660763135643b46c1a9e61317c8e54696073f1635e4025ebc0')
+ 'e73105ab186f78c14c71f8032deec0af77f9f32f6fe51381a56f0a545fd6ea3c')
prepare(){
cd "${srcdir}/${_PKGNAME}_${pkgver}"