summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoerg Behrmann2020-10-16 16:39:15 +0200
committerJoerg Behrmann2020-10-16 16:39:15 +0200
commite66f017607dcf778945261c2cf31b9dbc6762972 (patch)
tree4963907947b6b38b0d32134b22d78bf90cfd9d4f
parentecf98224cbed68ab0c71833fdbc77c70a40826a5 (diff)
downloadaur-e66f017607dcf778945261c2cf31b9dbc6762972.tar.gz
Update patches and Makefile from Debian
-rw-r--r--Makefile.seq.inc6
-rw-r--r--shared-libseq.patch17
-rw-r--r--shared-mumps.patch50
-rw-r--r--shared-pord.patch19
4 files changed, 49 insertions, 43 deletions
diff --git a/Makefile.seq.inc b/Makefile.seq.inc
index ad99b3f2ba79..3e00a107afe0 100644
--- a/Makefile.seq.inc
+++ b/Makefile.seq.inc
@@ -66,9 +66,9 @@ CDEFS = -DAdd_
#Begin Optimized options
# uncomment -fopenmp in lines below to benefit from OpenMP
-OPTF = -O -Dintel_ # -fopenmp
-OPTL = -O # -fopenmp
-OPTC = -O # -fopenmp
+OPTF := $(shell dpkg-buildflags --get FFLAGS) $(OPTF_64BIT) $(OPTF_DEBIAN) -Dintel_ # -fopenmp
+OPTL := $(shell dpkg-buildflags --get LDFLAGS) # -fopenmp
+OPTC := $(shell dpkg-buildflags --get CFLAGS) $(OPTC_64BIT) # -fopenmp
#End Optimized options
INCS = $(INCSEQ)
LIBS = $(LIBSEQ)
diff --git a/shared-libseq.patch b/shared-libseq.patch
index 28f01bf81280..4c05c15eff56 100644
--- a/shared-libseq.patch
+++ b/shared-libseq.patch
@@ -2,9 +2,9 @@ Create a shared version of the sequential library, MUST BE LAST IN SERIES
Index: mumps/libseq/Makefile
===================================================================
---- mumps.orig/libseq/Makefile
-+++ mumps/libseq/Makefile
-@@ -8,15 +8,17 @@ all: libmpiseq
+--- mumps.orig/libseq/Makefile 2020-10-01 23:16:43.684187324 +0800
++++ mumps/libseq/Makefile 2020-10-01 23:16:43.680187348 +0800
+@@ -8,15 +8,20 @@
include ../Makefile.inc
@@ -17,7 +17,10 @@ Index: mumps/libseq/Makefile
+ $(AR) $@ mpi.o mpic.o elapse.o
$(RANLIB) $@
+libmpiseq$(PLAT).so: mpi.o mpic.o elapse.o
-+ $(FC) -shared $^ -Wl,-soname,libmpiseq$(PLAT)-5.2.0.so -o libmpiseq$(PLAT)-5.2.0.so -Wl,-z,defs
++ $(FC) $(OPTL) -shared $^ -Wl,-soname,libmpiseq$(PLAT)-$(SOVERSION).so -o libmpiseq$(PLAT)-$(VERSION).so -Wl,-z,defs
++ ln -s libmpiseq$(PLAT)-$(VERSION).so libmpiseq$(PLAT)-$(SOVERSION).so
++ ln -s libmpiseq$(PLAT)-$(VERSION).so $@
++
.f.o:
- $(FC) $(OPTF) -c $*.f $(OUTF)$*.o
+ $(FC) $(OPTF) -fPIC -c $*.f $(OUTF)$*.o
@@ -30,9 +33,9 @@ Index: mumps/libseq/Makefile
+ $(RM) *.o *.a *.so
Index: mumps/Makefile
===================================================================
---- mumps.orig/Makefile
-+++ mumps/Makefile
-@@ -60,6 +60,7 @@ requiredobj: Makefile.inc $(LIBSEQNEEDED
+--- mumps.orig/Makefile 2020-10-01 23:16:43.684187324 +0800
++++ mumps/Makefile 2020-10-01 23:16:43.680187348 +0800
+@@ -63,6 +63,7 @@
libseqneeded:
(cd libseq; $(MAKE))
diff --git a/shared-mumps.patch b/shared-mumps.patch
index 35432e7f9acf..d70b55feab81 100644
--- a/shared-mumps.patch
+++ b/shared-mumps.patch
@@ -2,22 +2,22 @@ Create a shared version of the MUMPS library.
Index: mumps/src/Makefile
===================================================================
---- mumps.orig/src/Makefile
-+++ mumps/src/Makefile
-@@ -23,8 +23,10 @@ z:
-
+--- mumps.orig/src/Makefile 2020-10-01 23:59:29.359262672 +0800
++++ mumps/src/Makefile 2020-10-02 00:36:33.502904903 +0800
+@@ -23,8 +23,10 @@
include $(topdir)/Makefile.inc
--mumps_lib: $(libdir)/libmumps_common$(PLAT)$(LIBEXT) \
+ mumps_lib: $(incdir)/mumps_int_def.h \
+- $(libdir)/libmumps_common$(PLAT)$(LIBEXT) \
- $(libdir)/lib$(ARITH)mumps$(PLAT)$(LIBEXT)
-+mumps_lib: $(libdir)/libmumps_common$(PLAT).a \
++ $(libdir)/libmumps_common$(PLAT).a \
+ $(libdir)/libmumps_common$(PLAT).so \
+ $(libdir)/lib$(ARITH)mumps$(PLAT).a \
+ $(libdir)/lib$(ARITH)mumps$(PLAT).so
- OBJS_COMMON_MOD = \
- lr_common.o \
-@@ -167,14 +169,22 @@ OBJS_OTHER = \
+ # Build $(incdir)/mumps_int_def.h, needed by mumps_c_types.h
+ $(incdir)/mumps_int_def.h: build_mumps_int_def
+@@ -188,14 +190,24 @@
$(ARITH)tools.o\
$(ARITH)type3_root.o
@@ -30,34 +30,36 @@ Index: mumps/src/Makefile
-$(libdir)/lib$(ARITH)mumps$(PLAT)$(LIBEXT): $(OBJS_MOD) $(OBJS_OTHER)
- $(AR)$@ $?
+$(libdir)/libmumps_common$(PLAT).so: $(OBJS_COMMON_MOD) $(OBJS_COMMON_OTHER)
-+ $(FC) -shared $^ -Wl,-soname,libmumps_common$(PLAT)-5.2.0.so -L$(libdir) $(LORDERINGS) -lpthread $(MPIFLIB) $(MPICLIB) -o $(libdir)/libmumps_common$(PLAT)-5.2.0.so -Wl,-z,defs
-+ ln -s libmumps_common$(PLAT)-5.2.0.so $@
++ $(FC) $(OPTL) -shared $^ -Wl,-soname,libmumps_common$(PLAT)-$(SOVERSION).so -L$(libdir) $(LORDERINGS) -lpthread $(MPIFLIB) $(MPICLIB) -o $(libdir)/libmumps_common$(PLAT)-$(VERSION).so -Wl,-z,defs
++ ln -s libmumps_common$(PLAT)-$(VERSION).so $(libdir)/libmumps_common$(PLAT)-$(SOVERSION).so
++ ln -s libmumps_common$(PLAT)-$(VERSION).so $@
+
+$(libdir)/lib$(ARITH)mumps$(PLAT).a: $(OBJS_MOD) $(OBJS_OTHER)
+ $(AR) $@ $?
$(RANLIB) $@
+$(libdir)/lib$(ARITH)mumps$(PLAT).so: $(OBJS_MOD) $(OBJS_OTHER)
-+ $(FC) -shared $^ -Wl,-soname,lib$(ARITH)mumps$(PLAT)-5.2.0.so -L$(libdir) -lmumps_common$(PLAT) $(LORDERINGS) $(MPIFLIB) -lblas $(SCALAP) $(LAPACK) -o $(libdir)/lib$(ARITH)mumps$(PLAT)-5.2.0.so -Wl,-z,defs
-+ ln -s lib$(ARITH)mumps$(PLAT)-5.2.0.so $@
++ $(FC) $(OPTL) -shared $^ -Wl,-soname,lib$(ARITH)mumps$(PLAT)-$(SOVERSION).so -L$(libdir) -lmumps_common$(PLAT) $(LORDERINGS) $(MPIFLIB) -lblas $(SCALAP) $(LAPACK) -o $(libdir)/lib$(ARITH)mumps$(PLAT)-$(VERSION).so -Wl,-z,defs
++ ln -s lib$(ARITH)mumps$(PLAT)-$(VERSION).so $(libdir)/lib$(ARITH)mumps$(PLAT)-$(SOVERSION).so
++ ln -s lib$(ARITH)mumps$(PLAT)-$(VERSION).so $@
+
# Dependencies between modules:
- $(ARITH)mumps_load.o: $(ARITH)mumps_comm_buffer.o \
- $(ARITH)mumps_struc_def.o \
-@@ -290,13 +300,13 @@ $(OBJS_OTHER):$(OBJS_COMMON_MOD) $(OBJS_
+ # i) arithmetic-dependent modules:
+ $(ARITH)ana_aux.o: $(ARITH)mumps_struc_def.o \
+@@ -405,13 +417,13 @@
.SUFFIXES: .c .F .o
.F.o:
-- $(FC) $(OPTF) $(INCS) $(IORDERINGSF) $(ORDERINGSF) -I. -I../include -c $*.F $(OUTF)$*.o
-+ $(FC) $(OPTF) $(INCS) $(IORDERINGSF) $(ORDERINGSF) -I. -I../include -fPIC -c $*.F $(OUTF)$*.o
+- $(FC) $(OPTF) -I. -I../include $(INCS) $(IORDERINGSF) $(ORDERINGSF) -c $*.F $(OUTF)$*.o
++ $(FC) $(OPTF) -I. -I../include $(INCS) $(IORDERINGSF) $(ORDERINGSF) -fPIC -c $*.F $(OUTF)$*.o
.c.o:
-- $(CC) $(OPTC) $(INCS) -I../include $(CDEFS) $(IORDERINGSC) $(ORDERINGSC) -c $*.c $(OUTC)$*.o
-+ $(CC) $(OPTC) $(INCS) -I../include $(CDEFS) $(IORDERINGSC) $(ORDERINGSC) -fPIC -c $*.c $(OUTC)$*.o
+- $(CC) $(OPTC) -I../include $(INCS) $(CDEFS) $(IORDERINGSC) $(ORDERINGSC) -c $*.c $(OUTC)$*.o
++ $(CC) $(OPTC) -I../include $(INCS) $(CDEFS) $(IORDERINGSC) $(ORDERINGSC) -fPIC -c $*.c $(OUTC)$*.o
$(ARITH)mumps_c.o: mumps_c.c
- $(CC) $(OPTC) $(INCS) $(CDEFS) -DMUMPS_ARITH=MUMPS_ARITH_$(ARITH) \
-- $(IORDERINGSC) $(ORDERINGSC) -I../include -c mumps_c.c $(OUTC)$@
-+ $(IORDERINGSC) $(ORDERINGSC) -I../include -fPIC -c mumps_c.c $(OUTC)$@
-
+ $(CC) $(OPTC) -I../include $(INCS) $(CDEFS) -DMUMPS_ARITH=MUMPS_ARITH_$(ARITH) \
+- $(IORDERINGSC) $(ORDERINGSC) -c mumps_c.c $(OUTC)$@
++ $(IORDERINGSC) $(ORDERINGSC) -fPIC -c mumps_c.c $(OUTC)$@
clean:
+ $(RM) *.o *.mod $(incdir)/mumps_int_def.h
diff --git a/shared-pord.patch b/shared-pord.patch
index 79c7cf61a47f..64c8d8cf8a4d 100644
--- a/shared-pord.patch
+++ b/shared-pord.patch
@@ -2,8 +2,8 @@ Create static and shared versions of the PORD library.
Index: mumps/PORD/lib/Makefile
===================================================================
---- mumps.orig/PORD/lib/Makefile
-+++ mumps/PORD/lib/Makefile
+--- mumps.orig/PORD/lib/Makefile 2020-10-01 23:16:20.992316016 +0800
++++ mumps/PORD/lib/Makefile 2020-10-01 23:16:20.984316062 +0800
@@ -9,7 +9,7 @@
INCLUDES = -I../include
@@ -13,7 +13,7 @@ Index: mumps/PORD/lib/Makefile
OBJS = graph.o gbipart.o gbisect.o ddcreate.o ddbisect.o nestdiss.o \
multisector.o gelim.o bucket.o tree.o \
-@@ -24,12 +24,16 @@ OBJS = graph.o gbipart.o gbisect.o ddcre
+@@ -24,12 +24,17 @@
.c.o:
$(CC) $(COPTIONS) -c $*.c $(OUTC)$*.o
@@ -24,8 +24,9 @@ Index: mumps/PORD/lib/Makefile
$(RANLIB) $@
+libpord$(PLAT).so: $(OBJS)
-+ $(CC) -shared $(OBJS) -Wl,-soname,libpord$(PLAT)-5.2.0.so -o libpord$(PLAT)-5.2.0.so -Wl,-z,defs
-+ ln -s libpord$(PLAT)-5.2.0.so $@
++ $(CC) -shared $(OBJS) -Wl,-soname,libpord$(PLAT)-$(SOVERSION).so -o libpord$(PLAT)-$(VERSION).so -Wl,-z,defs
++ ln -s libpord$(PLAT)-$(VERSION).so libpord$(PLAT)-$(SOVERSION).so
++ ln -s libpord$(PLAT)-$(VERSION).so $@
+
clean:
rm -f *.o
@@ -35,9 +36,9 @@ Index: mumps/PORD/lib/Makefile
+ rm -f *.o libpord*.a *.so
Index: mumps/Makefile
===================================================================
---- mumps.orig/Makefile
-+++ mumps/Makefile
-@@ -54,7 +54,7 @@ dexamples: d
+--- mumps.orig/Makefile 2020-10-01 23:16:20.992316016 +0800
++++ mumps/Makefile 2020-10-01 23:16:20.988316040 +0800
+@@ -57,7 +57,7 @@
multi_example: s d c z
(cd examples ; $(MAKE) multi)
@@ -46,7 +47,7 @@ Index: mumps/Makefile
# dummy MPI library (sequential version)
-@@ -62,19 +62,25 @@ libseqneeded:
+@@ -65,19 +65,25 @@
(cd libseq; $(MAKE))
# Build the libpord.a library and copy it into $(topdir)/lib