summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoerg Behrmann2020-10-16 17:10:30 +0200
committerJoerg Behrmann2020-10-16 17:10:30 +0200
commitfab12f255938d15cd5f4057bd8c19941d3eea9f9 (patch)
tree038caedc6a6eb193ba8252af4a84220a0f6f911c
parent214f9f80f4ea8bec6653ac331571f18e2a2ae9cc (diff)
downloadaur-fab12f255938d15cd5f4057bd8c19941d3eea9f9.tar.gz
take over some changes from the included Make.inc/Makefile.debian.SEQ
MPIFLIB cannot be removed though, because without the compilation of PORD breaks.
-rw-r--r--Makefile.seq.inc11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile.seq.inc b/Makefile.seq.inc
index 4ca4c7cfe8cd..05198133f27c 100644
--- a/Makefile.seq.inc
+++ b/Makefile.seq.inc
@@ -20,7 +20,7 @@ LSCOTCH = -L$(LSCOTCHDIR) -lesmumps -lscotch -lscotcherr
LPORDDIR = $(topdir)/PORD/lib/
IPORD = -I$(topdir)/PORD/include/
-LPORD = -L$(LPORDDIR) -lpord$(PLAT)
+LPORD = -L$(LPORDDIR) -lpord
LMETISDIR = /usr/lib
#IMETIS = -I/usr/include/parmetis
@@ -31,13 +31,12 @@ LMETIS = -L$(LMETISDIR) -lmetis
# Corresponding variables reused later
#ORDERINGSF = -Dmetis -Dpord -Dparmetis -Dscotch -Dptscotch
-#ORDERINGSF = -Dmetis -Dpord -Dscotch
-ORDERINGSF = -Dpord -Dscotch
+ORDERINGSF = -Dmetis -Dpord -Dscotch
ORDERINGSC = $(ORDERINGSF)
-LORDERINGS = $(LPORD) $(LSCOTCH)
+LORDERINGS = $(LMETIS) $(LPORD) $(LSCOTCH)
IORDERINGSF = $(ISCOTCH)
-IORDERINGSC = $(IPORD) $(ISCOTCH)
+IORDERINGSC = $(IMETIS) $(IPORD) $(ISCOTCH)
# End orderings
################################################################################
@@ -65,11 +64,11 @@ LIBOTHERS = -lpthread
CDEFS = -DAdd_
#Begin Optimized options
-# uncomment -fopenmp in lines below to benefit from OpenMP
OPTF := -O -DPORD_INTSIZE64 -fallow-argument-mismatch -Dintel_ # -fopenmp
OPTL := -O # -fopenmp
OPTC := -O -DPORD_INTSIZE64 # -fopenmp
#End Optimized options
+
INCS = $(INCSEQ)
LIBS = $(LIBSEQ)
LIBSEQNEEDED = libseqneeded